Roll Eyes
Lips Sealed
page  <- 12345678910 -> <- 1 .. 5 .. 10 ->
List results:
Search options:
Use \ before commas in usernames
Okay, feel free to send me the .exe!

Hmm... You seem to have edited out the part about whether there's new routes etc. Yes there might be but I've (and Aqfaq) have written about all of them in our posts. I've never run the game myself so I won't do it (well possibly segmented) but maybe E1 could be done faster with one of the OOB routes I mentioned. Also it might be faster to get the key from behind the clock (another thing I mentioned) and use it to escape quicker. If you could quickly get the sabre from the sabre room (takes some 18 seconds from in-bounds AFAIR) from OOB (you can get the key from OOB but I'm not sure how it can be fast enough to also get the sabre), you could even get the sabre to ENTER the underground from the study. I'm a bit dubious. Finally the exit with Aqfaq's route is probably faster, but then again if you had that study key... I don't know.

It's all up in the air.
Edit history:
NHG: 2016-02-03 01:14:08 pm
NHG: 2016-02-03 01:14:05 pm
NHG: 2016-02-03 01:14:04 pm
NHG: 2016-02-02 03:23:42 pm
NHG: 2016-02-01 11:16:57 am
Shut up and go back to another earth
God... So much to read... So much to see... It's always the same thing with you guys ! You just can't expect to be absent for some weeks... Okay months, and hope that you won't be lost when you'll come back.

Greetings pals Smiley

I see you worked as hell, it is really really REALLY impressive. Like really ! I did not tested the map yet but I'm curious about that. Curious and kind scared because apparently it could be change the whole route... Again x/ I did not read everything because most of your... Coding/coded language was confusing to me but I think I understood all the idead x)

I am finally free from my work. it could be a bad new, it is not at all: this place was horrible and I never felt so bad of my life. My last day was 2 weeks ago. Since then I took my time to sleep, read, play and more important, do nothing ! And now I'm ready to work again with this game. I have a lot to learn apparently but I absolutly have all my time so I'm not worried ^^ I also hope that if I have to update the speedrun it'll be the last time FOR GOOD ! I like this game as hell but I feel kinda dirty to break it more and more ^^'

I'll watch more the program... The map... The thing tomorow and I'll probably ask you what changes it brings and where those changes are. It seems logical that running a program during play isn't allowed on SDA so I hope I wont have to learn a lot of blind sequences. The old corridor path was a pain in the ass x/

Edit: Oh and by the way, all of this is really exciting =3 it brings like all the answers to every technical questions we had since the beginning. Tigrou, (I think that is you who asked me on Youtube if there was such a topic about the game ?) I can't thank you enough. You made a fantastic job !

Edit 2: Did not try the map&stuff yet, I just reread everything, watched all images you posted and, curious about this mysterious hidden corridor in E5R10 I tested it. It's unbelievible to think this place is here since the beginning, not even blocked by a wall or anything xD I'm not sure it's faster though. If it is, the difference is really tiny. But my opinion isn't definitive. First, there are two ways to pass the jump part, one with 6 jumps and the other one (but much more difficult) with 5. It's also very possible that my road in the hidden corridor is not optimized at all as I don't see what I'm doing. I'll practice with the map until I "feel" where I am. In any case it wont be an huge optimization. Too bad because it's pretty cool x)

Edit3: Okay, call me idiot (well that's not new anyway) but I'm not abble to use QuickBMS, so if one of you can explain to me how do I proceed to launch correctly, it'll be very nice of you :$ I downloaded the room viewer, QuickBMS and i made a file with the given script but I don't really know what to do after giving a script to quickBMS, as it seems to wait other things to load x) Sorry about that, I really suck with programs in general u_u
Edit history:
tigrou: 2016-02-05 04:27:31 am
@NHG : great to see you back !

About room viewer installation : did you took a look at readme.txt ? Basically there is 3 steps : after selecting the script you have to select the PAK files (hold CTRL to select more than one file at the same time), then the folder were the files will be extracted (eg : a new folder). Feel free to PM me if you still have issues.
Edit history:
NHG: 2016-02-08 02:43:06 am
Shut up and go back to another earth
Didn't see the Readme, I was looking for it in the QuickBMS folder ^^' I've done everything and it looks pretty nice but I have to ask: did you try to link the game to the viewer with the GOG version of the game ? It doesn't seem to work with me and I thought maybe it was because I don't use exactly the same game than you. Maybe it only works with the "free" version of the game that you have to launch manually by mouting it in Dosbox etc... Honestly I don't see how it could be that because my version is just an "automatic" one but still works with dosbox, but in any case I can't manage to link the viewer with the game x/ Sorry 'bout that !

Edit: By the way I read everything another time now that I understand positions and stuff. LotBlind said we knew about the sound in E2R3, but I personnally did not xD I find this detail very cool in fact. I guess devs put this here to anticipate what a player could do in the room. The sound is here to warn you that there's a monster behind (well it really sounds like a grunt). I read somewhere that something about this sound is randomized but it's not true; it happens everytime you check the curtain, but as soon as you killed the zombi-chicken (triggered by grabbing the notes in the room) the sound wont be there anymore. It's kinda clever ^^
Did you remember to start a new game and stand still before hitting 'L'?
Shut up and go back to another earth
I'm trying to figure what the problem is with Tigrou by PM but so far so nothing. The viewer works well and it seems that the only thing that I can't do is link it to the game.  As far as I know I do everything the Readme.txt says but the L button just don't do anything. No error message, not a single reaction. I'm going to try again but I don't really know what I could possibly do different.

Did you record some videos ? I'm curious about new paths in ETAGE1 and ETAGE2 (and maybe ETAGE3 ?) as I can't really try anything without the linked viewer. By the way I saw you arguing about maybe use the classical way to go down in caves (wich makes chtonian eat the rock): about the possibly new path in ETAGE05 by hidden corridor, if I wasn't sure it could save time, I am 100% sure it wont save anything if Chtonien ate the boulder. That's all I have to say x) But we have to see if, even with news OOB paths, it is faster or not to use E3R11 way, wich at the very least asks taking the saber and maybe the key, depending on if we choose to take the matchbox or the lighter (but about that, as I'll need lantern in library I think I wont be abble to not take the matchbox, except if we find another way for this damn talisman)
When I feel inclined to launch AitD again (doing those updates and various things), I want to do a thorough check for places to go OOB from. I'm not 100% sure I haven't missed one in E2 or E3 and I'd like to be sure. Also the lower sections, E5 and E6. Because any OOB spot can affect routing. If you want to do that go ahead and it won't require the viewer either. Here's where I put everything so far:

It'll be easy for you to start going through the rest of the doors etc. and I hope you understand the format. I just cleaned the whole file up... the guide itself will be out-of-date until we're done with another round of runs.
Shut up and go back to another earth
Well I have the feeling it is now necessary to check every OOB spot we know but I feel I wont be effective at all without the viewer, I'll lose a lot of time just wondering around and searching triggers without knowing where I am. The only thing I tried yesterday (after forgetting the idea to link the viewer) was to manipulate the arrow now we totally understand how the grab-thing works. No good result infortunately, I am pretty sure it wont be possible to use it (considering I wont use the viewer during the actual run): even if  we manage to find a path for the arrow, it stills have to come back to the player to re-focus the camera and do the whole thing from a spot where it'll be possible to continue without triggering another arrow, unless I take the medikit but it'll cost time etc... If the arrow manipulation isn't effective it won't save time to use it anyway. I tried to trigger one from behind the wall because I think I already made it by mistake but I do not seem to do it again without come back into the corridor, wich is... Bad...

Anyway, Tigrou makes his possible to help me solve the problem. It's not the first time that things just don't work properly in this computer without any apparent reason. I can't wait for a new one x/
I said places to go OOB from.
Edit history:
NHG: 2016-02-15 10:56:32 am
NHG: 2016-02-15 10:55:49 am
Shut up and go back to another earth
Tigrou rocks ! He found the solution, now everything works, I can work !

Places to go OOB FROM => Okay I'll do that, first I am going to enjoy the viewer a little =3 it's almost Christmas for me. I'll update this post all day long everytime I'll find something, useful or not. For exemple: I tried the moves in E1 and I saw two things. The first-one I think you already said it but you can bring some mobile desks wherever you want when you OOB (like chair in E1R4). 2nd thing, WHATEVER YOU DO, don't touch the zombi-chicken's window in E1R4 when you're OOB. you'll break it and the game won't like that. I suffered many consequences: the game freezes with weird colors, the character doesn't listen to you anymore and keep running the way he did when he broke the window... Anyway, bad stuff happens.

Also, AqFaq about the "Colours Out of Space", good observation ! You're probably right about that !

Edit: Okay so, after joking around one hour or two E3 and E5, I passed most of the day observ E2's arrow and stuff. Here's some details that I collected and that I don't think we knew until then. First it is important to notice that camera and position are 2 differents entities for the game. They are both connected to character's position (well most of time =p) so when you play normally, (without OOB and stuff) you can't make the difference. We already knew that. But what happens when you disconnect the camera from  character's position with, for exemple, an arrow ? Well you can see that the camera by itself loads stuff from rooms, but not everything. Only "green boxes" (items, doors, monsters...). Thoses depends of the camera to be or not be loaded in the map. BUT the actual rooms still depends on the player's position, wich allows you to load the rooms you want. To be clearer here's what I did:

1) Start at E2, don't pick up matchboxes, directly go to OOB in E2R1
2) Go touch E2R7 wall from behind, now the room is loaded
3)With a precise angle, you can trigger E2R1 and pass trhough the wall. The painting'll shot and the arrow'll make turns in R7
4) You can go back behind the wall in OOB if you didn't go too far but actually, just go into the corridor and reach R0 by normal way. Normally the door won't be there (after some retries, I can tell it really depends on the arrow's path: sometimes the loop makes it always be in R7, in the other case it's between R7 and R1 and the arrow'll chase you is in the corridor)
5) Reach R8, search in the right desk (same ID as the spot behind the grand-father clock so you'll grab the key), then after a little wait the arrow should find your way in your direction. I am not sure what actions modify or not the arrow pattern.
6) We wondered if it was possible to exit the hidden room even if it was closed (as the camera never shows it closed from inside), the answer is not. But fortunately you can OOB from the closed door, from the right or from the left as you choose (but it seems better from the left) to go back to E0 and then do whatever you want.

I also notice that ID from the shell when you have to put the fake book and ID from axe trigger are the same. It can be useful because if you trigger an arrow, then an axe, the camera'll follow the last one and'll come back to you when it'll hit you. Even if the the arrow is still turning around somewhere in the floor. Finally (I always wondered), go downstairs during arrow/axe chase cancels it when you go back. That's it for today xp I'll try more things tomorow about this floor, I am not happy about the 4), the fact that the arrow sometimes turns into R1 and R7 (and not only R7) is a problem.

Oh and also, it's great and stuuf but saddly I don't think it's possible to use that in a traditional run x/
I've hit that window outside E1 and "survived" but come to think of it it froze pretty soon after, so maybe that was it.

Tigrou: why can't I link the viewer to the game any more in the latest versions which I just dowloaded? I'm doing the exact same thing... What did NHG have to do to make it work?

I'll also take a better look at things tomorrow probably.
Edit history:
NHG: 2016-02-15 02:40:26 pm
Shut up and go back to another earth

"Yes looks like it fails enumerating processes on the computer (which is necessary to find where DosBox is...)
This is similar to what is reported here :
I made a fix, could you try it out ? :

It should works now (or at least it should go one step further :D)"

Here's what was my problem. Maybe you didn't need this modification with your set-up ? I also reported to him that this new version didn't have all Hitbox IDs. It 's not a big deal but still it was kinda useful (especially with arrow trick)

Reading my last post I'd like to add something: The effect that I describe with the camera only works with the arrow. There are several places where I manage to position the camera on a spot while I am in a very different localization but in this situation the green boxes are where I loaded the room so... I don't know, it's kinda arrow favour =p

With all of this I forgot to say that I fastly forget the idea to trigger an arrow, make it go to R8 and touch anything with blue ID=0 box to grab the talisman. Camera transitions keep being a mystery to me. Do you think it's possible to make camera triggers appear in the viewer ? It'll help with the arrow.

Edit: After some tests I can clearly say that arrow's path is altered by any dialog window, item menu and loaded save (but not by the ESC menu though). Spamming Enter then ESC is a good way to tickle the arrow and eventually makes it find its way to you x)
Edit history:
tigrou: 2016-02-17 12:50:51 am
tigrou: 2016-02-17 12:50:44 am
tigrou: 2016-02-17 12:50:26 am
tigrou: 2016-02-16 09:17:42 am
tigrou: 2016-02-16 09:11:37 am
tigrou: 2016-02-16 09:11:16 am
tigrou: 2016-02-16 09:09:49 am
tigrou: 2016-02-16 09:09:32 am
tigrou: 2016-02-16 09:09:20 am
tigrou: 2016-02-16 08:55:50 am
tigrou: 2016-02-16 08:52:05 am
tigrou: 2016-02-16 08:51:58 am
tigrou: 2016-02-16 06:48:18 am
tigrou: 2016-02-16 04:09:20 am
tigrou: 2016-02-16 04:08:59 am
tigrou: 2016-02-16 03:11:12 am
tigrou: 2016-02-16 03:10:42 am
tigrou: 2016-02-16 03:10:23 am
@LotBlind : It could be that I made (by mistake) some changes that breaks the link to DOSBOX functionality. The bug does not seems to occurs all the time.
It is fixed in version that NHG posted. You can use that link meanwhile. I will update the official zip when I will have time.

@NHG : about cameras, how they works is well understood and it can be added to the viewer, I will see if I have time.
Shut up and go back to another earth
Quick hi there !

@Tigrou: Thanks ! It could be great especially for the whole arrow thing. It could help to know where it'll chase you and where it'll not (wich may help to manipulate it). It also could help to see where it has to pass to load R8. By the way, I think someone asked about how trigger the hidden camera in R10. It a lot easier now that we have the viewer, really easy to do. I can explain if you want to.

I tried things with OOB & cameras. As running in one direction makes you go back at the opposite spot of the map, I wondered if something'll happen if the character touches some spot while he is stretched by his teleportation. I also tried to run all along the borderline and finally to touch an angle so the character is more or less everywhere x)

The only effect i can observ is that walking on this line triggers all different cameras from there room that the game considers you're in. The funny thing about it is that it seems that you confuse the game by goind that, as if you shift the camera position compared to where the game think you are in the room. So when you trigger another room, it'll continue to load the wrong camera until you switch between the 2 same rooms so the camera catch you again. Funny but pretty useless.

I also could see that smoke in E3R13 will hurt you whatever you are as long as the game thinks you're in the room. What else... Oh, it may be a good idea to look if some items can be collected even when the game thinks you're in another room. It should be impossible if we applicate all we know about ID's but I saw that you can pick up the hook even when you're still in E6R5 so maybe there are some exceptions...
Edit history:
tigrou: 2016-02-17 11:38:38 am
tigrou: 2016-02-17 11:38:16 am
tigrou: 2016-02-17 11:29:57 am
tigrou: 2016-02-17 11:10:26 am
tigrou: 2016-02-17 11:07:45 am
tigrou: 2016-02-17 11:06:52 am
tigrou: 2016-02-17 10:07:27 am
tigrou: 2016-02-17 10:07:00 am
tigrou: 2016-02-17 10:05:29 am
tigrou: 2016-02-17 10:05:03 am
tigrou: 2016-02-17 10:04:33 am
tigrou: 2016-02-17 10:03:58 am
tigrou: 2016-02-17 10:03:23 am
tigrou: 2016-02-17 10:03:07 am
tigrou: 2016-02-17 10:02:38 am
tigrou: 2016-02-17 10:01:22 am
tigrou: 2016-02-17 10:01:07 am
tigrou: 2016-02-17 10:00:47 am
tigrou: 2016-02-17 10:00:36 am
tigrou: 2016-02-17 09:58:06 am
tigrou: 2016-02-17 09:57:48 am
tigrou: 2016-02-17 09:57:10 am
tigrou: 2016-02-17 09:56:45 am
tigrou: 2016-02-17 09:56:32 am
tigrou: 2016-02-17 09:56:12 am
Hi ! I have updated the viewer.  There is now support for cameras Smiley See readme.txt for details. It also (of course) contains the bug fix.

1) some explanation about how cameras works : for each room, there is a given set of cameras defined. The attic for example, has 5 cameras. Each camera is associated with an area, which is a 2D polygon on the floor. A camera area defines all valid 2D positions for a camera view. When player exits an area and enters a new one, it triggers a camera switch. Areas can overlap, which mean there might be more than one camera possible for a given 2D position.

Special cases : if you are in an area, then go to a place where there is no area (eg : by going OOB) the game will keep last valid camera.
same for this : if you are in an single area and then go to a place where several areas overlap : the game will keep previous camera as long as possible.

In the viewer : i put a different color for each area, to make it easier to distinguish them (since they overlaps). If you put the mouse on an area will show the ID which is actually the ID of the picture the game will show for that camera. That ID is unique per floor.

2) About the bug that occurs in E1R4 : there is an area near the window. It is used to focus the view on the window the zombie chicken is going to break. Could the bug reported by NHG actually occurs when you touch the area itself, not the window ? (to be tested, i am not sure about this)

3) About the arrow trick : with the areas view enabled in the viewer, it's now easy to understand how the camera switches happen when the arrow is flying.
Anyway (AFAIK): the false book trick is not related to the view triggered by the arrow but room where the arrow is. I was able to grab the false book when the view was still in the gallery.

4) About the trick that allow to view the hidden E2R9 camera view : I already reproduced that glitch myself some time ago and tried to understand how it works.
Here is what I found out : each room has a set of camera areas defined (has i explained earlier). However, to make room transitions easier, when looking for best camera, the game is also allowed to look in camera areas of rooms nearby current room. For example in E2R10 there is 5 possible cameras where to search : the 3 ones inside the room, one shared with E2R2 (near the door) and one shared with E2R9 (in the hidden corridor).

What happen during the glitch : after you wrapped up position, the game get lost. It does not know which camera view to show anymore. And since you are OOB player position does not help. When such thing happen the game displays the first defined camera for the room (regardless player position). For example at 1:05 (in the youtube video) it displays the first camera view for E2R2 which happen to be a camera view shared with E2R4. At 1:07, when you come back to E2R10 it displays first camera view for that room which happen to be (by chance) the camera view shared with E2R9 (inside the hidden corridor).

5) about player "stretched" effect : AITD is a 16-bit DOS game. It means most variables (including player position) can only be between -32768 and 32767. If you go higher or lower that range it will wrap up. That explain why the player is teleported when you go outside map boundaries. Well you probably already know this Smiley
The fact the player looks "stretched" is (I think) related to a glitch in the viewer which incorrectly calculate the box size at that point.

Edit history:
LotBlind: 2016-02-17 02:05:36 pm
LotBlind: 2016-02-17 02:00:40 pm
I'm filled with child-like joy every time the Room Viewer has a new revision out. Cheesy On the downside it means I ALWAYS have to start a new file and take it from the beginning so I don't miss anything. Haha...

Looks like the camera changes every time the CENTER of the PC model has passed the line, which also seems to be the case with any other trigger. I don't know why I thought otherwise at any point.

The camera area that extends through the window in E1R4 is similar to how the area for the first view in the loft also seems to trigger when the bird enters it outside the window, presumably. And we're sure we touched the window itself. But actually just passing through that room in OOB when the corridor is loaded in often has those weird effects when you're NOT near the window. Including lots of crashes.

Yes, I also thought the viewer was the one to blame for the effect of stretching the player's hitbox when they're at the edge of the map (and I couldn't see any special effects related to this for the same reason), but it's also clearly the game drawing the polygonal model in the normal way, connecting the vertices in the usual way, only it sees a part of you all the way across the other side and so certain polygons get stretched a ton. That having been said what NHG said about changing views works if the camera areas are around the middle of the map which they normally are. For some reason it also doesn't look like the two effects coincide, one happens a little bit before the other.

Tigrou: I'm sorry if you've already explained this, but why are some walls blue "colliders" when most of them are just gray rectangles? I can now clearly see how it works, I was just thinking all the walls had those IDs. Any idea? EDIT: I feel every room has one doesn't it? Then maybe the game just couldn't handle having 0 colliders in the room for some reason? That would "explain" it.

At some point, if you're going to make any more changes to the viewer, one of them could be to make it highlight the current view you're in. Maybe also all the walls that are loaded in, so you can clearly see what's loaded in even when you have "show all" mode on.

In some places when you have that kind of lag that eats your inputs, I've found that triple-mashing the key makes you run pretty consistently! That's really useful in some places when you're expecting lag.

I noticed that the room triggers tend to have the same ID as the room they load into memory, i.e. trigger box with ID 0 in E2 loads in E2R0 etc.

Arrow grabs: I noticed you can also use this to pick up items that are grabbed by "use/search", e.g. bullets in E2R6 and first aid case in E2R5. This means you could combine two kinds of grabs from the same collider possibly. I'm also looking at the collider with ID 0 in E2R2 instead of the library one for performing the grabs. That would be ideal because it takes you closer to the stairs already. You can also get the study key like this. The collider for that has ID 1 which is matched by e.g. the closet in R10 and the cupboard in R8.

Here's something important, kinda... why can't we pick up the matches from E2R10 from the other side of the hearth? It's the same collider after all. Is there a secondary check for how far away from the object you are? Probably.

Another little thing: seems some objects are dormant (like the knight) if they're loaded into memory but the view is wrong. I think this is the same as NHG said about how you can only get the talisman off the table once the arrow has entered the room.

Something else I never realized to this day: you can hit "space" to pick up items instead of "enter".

Good job everyone on anything I didn't comment on! Continuing later...
Edit history:
tigrou: 2016-02-22 07:19:45 am
tigrou: 2016-02-20 04:19:19 am
tigrou: 2016-02-20 04:19:19 am
tigrou: 2016-02-20 04:19:10 am
tigrou: 2016-02-19 01:27:18 am
tigrou: 2016-02-18 03:21:13 am
tigrou: 2016-02-18 03:20:19 am
tigrou: 2016-02-18 03:20:10 am
tigrou: 2016-02-18 03:09:35 am
tigrou: 2016-02-18 02:59:45 am
tigrou: 2016-02-18 02:53:03 am
tigrou: 2016-02-18 02:52:14 am
tigrou: 2016-02-18 02:51:57 am
tigrou: 2016-02-18 02:51:48 am
tigrou: 2016-02-18 02:51:38 am
@LotBlind : there is actually no difference between blue and gray boxes. They are all hard, non-moveable colliders. They all have an ID. They all also have a FLAG field (not shown in viewer).
It seems that only boxes with FLAG = 9 can interact with the player (eg : give an item, display "nothing found", ...). They are shown in blue in the viewer.
It would be probably more clear if the viewer would display "COLLIDER" as well for gray boxes (and the ID). It would also probably be good to display the FLAG field value for all boxes.

Yesterday I was wondering this : since it's a 16-bit game what would happen if player life would be near max limits then you would get some healing ?
Well I tried it : I set the player life to 32767 (using Cheat Engine) then went to the kitchen and ate some cookies.
The game displayed "You feel better" but just after Emily agonized in horrible pain and fall to the floor. Her life was approx -32700 at that moment so she died.
Eating cookies in a old haunted mansion can be dangerous...
This make me think that the opposite could happen : taking TOO MUCH damage in a single frame could bring life to around +32700 and thus make you virtually invincible. Unfortunately I don't know how it could happen.
Shut up and go back to another earth
@Tigrou: I could answer about the life limits things. It's actually possible to do the glitch in Alone in the Dark 2. There's a poisoned bottle that you can drink. It makes a lot of damages and you can manage to re-use the item (who does not dissapear as it is a key item that you're not suppose to use like that) before the end of the drinking animation. You just repeat the manip over and over until the negatives life points come back to an huge positive number. It's still very possible to die fast though, there's a room with some guys with guns made in Scriptium ( a very rare metal, very useful when devs want the player to understand that he has to find another path that the current one) who takes like 500 LifePoints per shot.

In Alone 1 I think you can't take more than 40 damages (by Chtonian and Color out of Space if I remember well, I tried it). Saddly, I'm pretty sure the number stucks to 0 (you can verify that when the painting shots the arrows directly to you without stopping), and as far as I know there isn't any way to reproduce the glitch as it works in Alone 2 (with infinite item use).

@LotBlind: Yeah you can use "search" with the ID mess: "Reach R8, search in the right desk (same ID as the spot behind the grand-father clock so you'll grab the key)". I guess R2 would be ideal to grab everything then leave the place but the main problem is to make the arrow go where you want without walking somewhere where it'll chase you, wich seems to depends on cameras. That's why I wanted to see the triggers in the first place ^^

About matches, I think the answer is simplier than that: look the size of the wall between room and OOB. It 's not the same size at all than dividing walls. I think you just can't touch the good spot from OOB to grab matches. You can't check the desk next to it neither (photo of Jeremy & Emily Artwood, I haven't the update yet so I can't tell the ID =p). But still, the viewer shows the fireplace like a single hitbox so we can wonder why we can't grab things from the other side of the fireplace.

About the Talisman, I didn't say exactly that. I said that when the arrow is triggered, it's is it who makes green boxes appear, not the player anymore. So as a player you can trigger rooms normally, and as the door of R8 is a greenbox it won't be there if the arrow isn't in the library or the corridor (about that, did you notice this detail ? We already knew that when you're in a room, the game loads the entrance of all rooms directly linked to the actual room but it also loads all other doors/greenboxes of those rooms, that why for exemple when you're in R1, the three doors of R0 are already loaded and you can interract with them). Then once you're in R8 you'll be abble to grab the talisman only when the arrow will be, at least, in the library. But if I observed it well, it is the camera who determine where the arrow is. So even if in the viewer you see that the arrow makes turns between R0 and R4, R8's greenboxes will only appear if the arrow actually triggers an R0 camera. BUT don't forget that there still is the ID mess law in effect so even if the talisman is loaded and as the camera is with the arrow, touching the ID0 desk where Talisman is 'll do the same effect that touching the ID0 desk in library (so theorically I can grab a book if I search in it). That's why I have to wait the arrow to be in the room.

I don't know if I am clear about that x) There are a lot of effects to take in consideration with all of this !
Edit history:
tigrou: 2016-02-20 07:04:43 am
tigrou: 2016-02-20 07:03:47 am
@LotBlind : I re-read your message and took some time to answer more questions :

Looks like the camera changes every time the CENTER of the PC model

Yes, sometimes game use player box center (eg: for camera area, triggers, ...),
for some other things game use bounding box (eg : hard collisions with walls or enemies)

I noticed that the room triggers tend to have the same ID as the room they load

Good catch, I didn't noticed this.

why can't we pick up the matches from E2R10

Well I took a deep look at game code and found out :

Inside a script, game has possibility to check from which side you are touching a box (top, bottom, left, right)
Getting the matches only happen if you touch the hearts box collider from bottom side. It has nothing to do with distance, current camera view or player angle as we thought.
Same goes for piano in attic, only right side will give Jeremie script.
And this is also used for doors : that's why some doors only open if touched from one side and are closed from the other side (regardless the current loaded room).

some objects are dormant (like the knight)

In case of knight, there is a check inside the related script, he is awaken only if current ROOM is 2 (I verified this, this is not a assumption). So that dormant behavior is specific to each object.
For talisman, the only check done to grab it is that player touch a collider with ID = 0 (but scripts for that room must be loaded which only happen if you are in that room or if arrow has triggered it's loading, as it is done for false book)
Edit history:
LotBlind: 2016-02-23 01:51:37 pm
Matches: NHG, I didn't mean getting them from OOB. Tigrou seems to have answered this.

tigrou: unless there's some practical use for the PARAM fields that you can see or potentially see, I suggest keeping it as it is!

The Knight: that can't be right... if you manage to lure him into other rooms with you, he will still continue chasing you. He's different from the Vagabond for instance, who is clearly only ever present when the room is 0.

EDIT: The knight is really funny! Looks like if you get him moving, then enter the library and close the doors, he will "know" he's no longer in the view so he stops until you open them again! I also noticed if he moves away, you can no longer do the clip against the closed left-side (South side) door from inside the library. It stops working immediately after he's been alerted. When you're clipping against him, you move really rapidly as well.

Do we have anything interesting to say about why you get caught in corners a lot of the time? I.e. you're running against a convex corner and you get stuck unless you face far out enough. It's not important probably.

I'm just going to look for more of those OOB opportunities tonight. Tongue


Let's not forget you can pick up items that are lying on the floor whenever they're loaded into memory without needing colliders to be loaded in. Only things this affects are: jug, fuel canister in floor 1, book in floor 1, wedge in cellar. I.e. it's pretty useless more than likely.

Looks like if you start an animation such as opening a door, but then the camera moves with the arrow so the objects involved get unloaded, the animation will reset every time the arrow enters the area. I'm looking at Emily helplessly crawl forwards after starting to open a door because the door can never finish loading in. Let's keep this in mind just in case.

When the arrow is circling, you can manipulate it not just by opening/closing the inventory, but even more so when you do something in the inventory. This can completely kill the arrow's "momentum" and get it to come straight for you but it's very inconsistent. I don't even know how to reproduce it. Maybe it was waiting with the inventory open? I've also seen immediately opening the menu from a save state cause the arrow to take a broader approach.

Looks like you can reclaim the false book after placing it just by clipping into the SW bookshelf.




This is pretty difficult to do even with the room viewer, and even harder without... In order to be able to clip all the way to the secret room door, you HAVE TO make sure you do those "baby steps" when you're close to the walls in order to be able to clip along the next wall fast enough. You can JUST BARELY escape the Vagabond o_O

To exit the secret room, obviously you can just clip a little ways and re-enter the library and get the quick door clip I mentioned. This might actually be faster than what I did but in any case it's certainly easier. As you can see my solution involves clipping outside the secret room, then hitting the library trigger near the right edge without entering the library, then turning S and going around the secret room trigger into R2.

Try and find a faster way to do E2 BITCHES!!!!
Edit history:
tigrou: 2016-02-25 03:16:38 am
tigrou: 2016-02-25 01:04:48 am
tigrou: 2016-02-24 10:05:04 am
tigrou: 2016-02-24 10:04:36 am
tigrou: 2016-02-24 10:04:30 am
tigrou: 2016-02-24 10:03:23 am
tigrou: 2016-02-24 10:03:03 am
tigrou: 2016-02-24 10:02:46 am
tigrou: 2016-02-24 10:00:59 am
tigrou: 2016-02-24 10:00:12 am
tigrou: 2016-02-24 09:55:34 am
@LotBlind : this is an awesome finding ! Good job ! This make the whole gallery stuff skipable.
I calculated that it should at least reduce time for the speed run by a good 30 seconds. I still dont know how you found all those OOB, I tried to find some by myself but this is really hard.

Some new stuff about the room viewer : remember I told you i modified the original game to allow to view the 3D models ? Well now there is better : those models can be viewed directly from room viewer ! See readme.txt section for details. While it has probably zero added value for the speedrun, it was quite fun to do and it allows us (for the first time) to inspect those models in high res.

Some stuff I found out about the models (trivia) :
- there is a lot duplicates. For eg. kitchen knifes appears twice, while the same model could have been used. Models that are in inventory are also duplicated : there is one for the inventory (small size), one for the rooms.  Maybe artists were supposed to create a low polycount version for inventory models but it was cancelled later.
- the axe thrown in the gallery is actually a smoke/weed pipe !
- some models have no bottom, probably to reduce the polygon count.
- ghosts are 3D models. I believed they were just 2D animation.
- the two model folders (LISTBODY and LISTBOD2) are 100% identical, expect in one folder player character is Edward, and the other Emily. The second character was probably added near the end of the deadline and as a quick fix they just duplicated everything. What a waste of space.

I can see why you can use the library door for the clip now: it's clearly the only one that juts out when closed.

I'll download the new room viewer and look at the models, but I just wanna see if I can find more OOB chances.

Interesting that sometimes when you open doors, the PC will turn to face the door, sometimes they won't. Example where they won't: entrance to E2R3. Speaking of R3, if you go outside it (use the door to go OOB from the corridor) and go round on its N side, you'll get stuck on something that's right outside the window even though it doesn't seem to have any objects or colliders there... spooky! If you collect the notepad and the bird is summoned, the obstacle is also removed. I can't get the bird to follow me outside the room. Must have been programmed to stay inside it. Lastly I noticed that when you're in R3, the 0 collider in the library (!) is loaded in, but you can't collect the notepad by touching it. It's also loaded in when you're in the corridor/R4. Maybe it's not really the 0 collider, but rather another collider that's on top of it that's there. When I disable drawing all rooms, it doesn't show anything there. That must be just a bug right? It's also present when you're in the gallery!

I can't for the life of me get into R5 OOB (bathroom).

Like the bird in R4, the Vagabond has been told not to enter the secret room. It's kinda funny Cheesy
Shut up and go back to another earth
Nice found ! Finally the talisman is in our hands. I did not compare timers, I'm pretty it'll be faster. Do we have to think about a modification of the general path ?

Considering we grab the talisman like this, here's the possible alternative paths:

-take the pirate sword, do not take matches, take key (by OOB after Talisman ?), take the lighter, erase boulder in underground;

-do not change anything obviously

I'm not sure all those modifications save time even with a well done performance. Besides, the first case only concerns a run with viewer because it asks to do library thing in the dark.
Also, I'm pretty sure the actual E1 path is better than the one asking you to OOB  in R6. I did not try the hidden corridor in E5 yet (at least not with the viewer), I'll make a good try to see if it can save time (comparing to the path with boulder still there) or not.
You have to try the OOB in E1 NHG, my initial results were it might just be a tiny bit faster! Unless I was sloppy with comparing them. Just do the clipping optimally and use the room viewer to make sure you're beelining it. I feel the method of:
- get to E1R6 OOB
- run around to the bottom left corner of load zone
- run back around to the top left corner of load zone

is probably the fastest but requires a ton of stuff done blind and so you don't have to worry about it IMO. The other method though, where you run around the staircase to touch the top part of the loading zone instead doesn't require that many blind actions. In any case it's crash-prone as we know, but it IS close to the start. With both variations you avoid having to open two more doors, having to stop at the second door for a little bit to re-enter R4 and you might be able to get a faster stairs descent (which is something I've seen), but that's very finicky. Hitting the exact right point when entering R7 (landing) is tricky of course and has to be done by counting steps somehow.

"take the pirate sword" - wastes 17 seconds according to my old notes - that plus the time for getting the key... you save a bit of time if you have the lighter when you don't have to pull the lantern out but that's small... and you're forgetting you HAVE NO LIGHT IN THE LIBRARY :D. I don't see a way this could work anymore. There's a chance you could get the sabre from OOB (combining it with the second variation of E1 OOB I mentioned above) but I'm still very skeptical.

On E3, the "weird" block that's loaded in at all times is the kitchen hearth.
Edit history:
NHG: 2016-02-27 04:40:37 am
NHG: 2016-02-26 12:12:48 pm
NHG: 2016-02-26 07:47:02 am
NHG: 2016-02-26 07:43:48 am
NHG: 2016-02-26 07:43:19 am
NHG: 2016-02-26 07:41:43 am
Shut up and go back to another earth
OOB in E1: Understood and agreed ! I trust you when you say it's faster, and I also trust you when you say it's very complicated without the viewer x) I'm going to try the 2nd method as it is indeed more conceivable without the tool but yes, I feel like it's kinda impossible too. Even if i don't count the freeze possibility, being at the exact line spot when I load R7 sounds crazy.

New talisman path: I manage to do it without the viewer (didn't try with it actually, it's better if i want to grasp the move). You have to be very precise with every corner indeed. it's possible to rectify a bad position but it must be very quick, and the baby steps are needed. I am going to try more but wow!  What a move.

Pirate sword path: I still wonder wich path is theoretically the faster one. Admit that you use the viewer (so no darkness issues etc)... . It's possible by OOB to reach E3R11 but is it faster than grabbing the key ? The OOB path is kinda complicated in E3, but it's probably the same problem in E2 with the key. But if you have the key you just go directly in E3R11, grabbing the lighter in the way. Without the key you have to take it, then come back to the stairs to OOB and then follow the complicated way to R11. BUT if you take the key, when ? Probably possible by OOB after taking talisman ?

I think I'll make some tries tomorrow just to be sure what path is, in theory, the best one ^^

Edit: I trained myself with the LotBlind Talisman Path and I think it saves aproximatly 25 secs, depending on some details. If you're fast enough the monster wont be near the entrance and you'll be abble to leave hidden room by left, but if Vagabond is too close you'll have to OOB in the right and make a bigger turn into the Library to reach the door. I must improve myself with clip in R10 door (as I leave the room just before clipping through the door, my position doesn't help), and I also have to be better with the first clip into desks. the two next corners are pretty easy to get or even to rectify, but with the first one... It's easy to miss the spot. Most of the time my clip is too large and I don't reach the good spot to be able to continue (it's easy to see, if Emily's feet arent totally behind desk line, it's not good). And weirdly with this corner it doesn't seem possibly to rectify the path. I'm going to insist a little, see if I eventually find a persistant way to succeed.

The more I clip, the more I learn how it works. The range of every "clip step" depends on how far your angle is from perfect perpendicularity with the wall. Of course there's a radius and if your angle is too far you wont move at all. When you reach a corner in this trick (and as it is important to be the closest from the 2nd wall you can), you wont be abble to approach the angle if the distance between it and you is inferior to the range of your "clip-steps", so at this moment you have to modify your angle a little and come back near perpendicularity so clip-step range'll be smaller. There also seems to be another radius concerning the "baby-steps". Consider that the whole clip-step radius is between 90° and 60° relative to the wall (or 120°, same thing), if you begin your clip with an angle under 85° (so between 85° and 60°) you'll make large steps who makes you move 1 time per sec. But if you clip with an tiny angle between 90° and 85°, you'll make those baby-steps that are required to use this new path. Oddly enough though, it seems that once you are in "baby-step mode", you can slightly rectify your angle and pass under 85° (I would say 80° in my imaginary scale) and still keep the baby-step, but with larger steps. I'm not totally sure about that last part but I tried several times and it really seems that once I modified my angle enough to make baby-steps,  I can come back to a larger angle without cancelling it as long as I'm not too greedy.

I gave random degrees just to explain the idea, but with the viewer it's actually conceivable to measure those numbers.

Edit2: First wall perpendicularity is exactly 180°, then 270° with 2nd wall and 0° with last wall, it seems logical considering how maps are builded. It means that with this angle you run against the wall without being moved to east/west. But for some reasons that I don't quite understand, sometimes being pefectly perpendicular to the wall makes you move anyway: to west with the first wall, south with the 2nd and north with the last one (so it's always to the left of the character, i thought maybe it was because shel holds the lantern but it happens without it too). Somehow it's as if sometimes the game did not really have the perpendicular degree

I didn't take numbers in first wall simply because the clip part is too small, so let's see with west wall: considering i was in a session with no point zero (270° made me move), I could go north with a 254° angle and south with a 285° (not 286°). I'll try to find a session with the point zero and see if it works with 254° and 286°, wich seems more logical.
With south wall, the radius is oddly larger. Knowing that point zero is 0°, I could go east with 24° and west with 335°.

About baby-step I don't get it, it seems to change all the time. After playing a lot I have the feeling it depends on the moment when you change direction, but this theory is going to be very complicated to explain, and also builded on a simple feeling ^^'
So to resume: West wall radius theorically 16° degrees to north or south (so a complete window of 32°) and South wall has a relative radius of 24° degrees for a complete window of 48° degrees. I took all thoses numbers in the same session with no zero point. I'm going to check if it changes between two different games. It would be weird but who knows.