Roll Eyes
Lips Sealed
page  <- 12345678910 -> <- 1 .. 4 .. 10 ->
List results:
Search options:
Use \ before commas in usernames
I've seen that video actually! NHG even spoke to Frederic at some event in France last year... he asked him all sorts of things.

Edward is taller than Emily? I thought it was the other way around! Smiley I thought he looked shorter. Him being thinner COULD potentially affect some stuff but we really haven't seen any differences. On the other hand we knew that Emily runs a bit faster (I wonder if she corners slower?), about 1/12 faster. You can tell because when you listen to their footsteps you can measure their beat, and both have the same beat, however Emily will have gotten further in the same number of [running] steps, therefore she is faster. NHG confirmed that you can do something in the boss room with Emily that fails with Edward.

I will later do a pass on everything that has been said on the thread recently (thanks to your input) and edit in bits and pieces for the Guide but I might have to start a new sub-page for some of it (or submit to the wikia wiki) unless we can find speedrun applications.

That screenshot: I'm guessing it's not another secret room (or even dark necessarily) but rather they never finished the art for that corridor. So yeah the second theory is the one I like. BTW could I possibly take a look at those 144 pictures you extracted? I only have 137 after doing a thorough scouring of the entire game, so I should be able to recognize which ones are not normally accessible.

We also knew about the growling sound in front of the curtains. It's a bit random but that IS one of the bird assault rooms.

Yeah, NHG had to look around OOB for quite a bit to find the triggers. I've done a good amount of wondering about aimlessly myself... It's really great there's people about who are able to somehow get all that data from the game itself! There's a lot of runs that will benefit hugely from stuff like that, especially if no-one has TASed the same game. At the same time you can't replace some amount of aimless wanderings to get more ideas for what to look for in the code! Did you already read our Guide? If there's anything there that you think you might have an explanation or any comments on feel free to do so!

I'm looking forwards to testing the coordinates' viewer...
May I suggest a small change to the program: whenever you clip Emily into corners and things, her box disappears underneath other objects that are taller than her... maybe you could make there be a tall line segment that protrudes from the center of her model so it never gets occluded? How about printing the coordinates underneath "floor, room" so you can easily see when you've wrapped around without having to scroll the viewer out really far?

Actually an arrow pointing in the direction you're facing with degrees if possible (always visible even when the character's model box is not) would also be very useful for the same reason! Together with an arrow on the PC box itself.

Third feature request would be, if possible, can you make it possible to look at different rooms even though you're linked with the game, or temporarily un-link and then relink so you can do that? When I tried hitting l again, it actually crashed the program.

Looks like the Player Character's (PC's) position gets updated a little bit BEFORE the camera transitions. Good to know.

I'd like to suggest in order to avoid confusion we use "loft, floor 3,2,1, cellar, caverns, end" to talk about the various floors, but if you want to refer to the in-game floor system, you use abbreviations like this "f2r4" meaning floor 2 room 4. I was trying to name every room and view in the game earlier with natural but snappy names but that project is kind of half-finished. The Wiki even has different names altogether and I thought maybe later it could be coordinated with them a little bit... Alternatively, if it's confusing that F doesn't stand for the same floors that we otherwise talk about, maybe we should say "Etage" or "E"? So "E2R4". What do you guys think? (the others are sleeping through all this exciting stuff :D)

So I noticed that when I go OOB and hit loading zones, there will be a sequence of transitions when you enter a new area but your coordinates place you inside another zone in that area, so it immediately loads in another area afterwards. This can probably have any number of times just depending on where the zones overlap. I wonder if it's even possible to get into an endless loop somewhere. Cheesy I still don't quite understand what determines which camera view you're put in, sometimes the view is from a different room altogether. I guess there's just an unrelated camera map somewhere in the game's memory. When you're in a view like that it shows you the objects you expect to see on the floor so those must have been loaded into memory.

When I'm in F1R1 OOB (use the door frame of the storage room to get OOB and another trigger to get to E1R1), you can see the little gaps between zones up top. Well for some reason you can't walk into the first gap at all! Actually I believe this is because there's an object in the way, the door frame itself being an object. But then it doesn't seem to line up quite right. I don't know what's stopping me. Maybe the closet? When there's movable objects, you can push them right though the missing walls and get them OOB with you.

I noticed that by aiming for the NW corner of the trigger zone in the corridor OOB that loads in the landing area, you CAN get downstairs directly without having to camera defocus to do it! That's exactly what we were trying to do earlier but no-one managed to do it that precisely.

1) So going OOB from E1R1 (I'm about to upload a video), so you arrive in R6.
2) Now you could either go around the staircase to reach the right half of the trigger zone so you get R0.
3) When you have R0, you can go back around the R6 trigger box so you hit the top of the R1 trigger box instead.
4) Now you have R1 but you're OOB. Then you just run to the stairs.


2) Go around the left side instead so you hit the very bottom part of the corridor zone.
3) Now you have R0 like before, but you have to run back to the top and do the same from there.

Two concerns: it's maybe only a little bit faster! I think it's a few seconds slower to do it the first way I described, but possible a little faster the second way with optimal execution. This brings us to the second concern, which is I'm not sure if it's allowed to use external software to do memory watching during your runs. I know a few runs that specifically DO use external software for various things, e.g. solving a puzzle quickly. So I don't think it's banned but I just asked about this and will tell you what they said... Because without visual aid from the program, you're not going to have an easy time doing this type of route in a non-segmented run!

Continuing later.
Edit history:
tigrou: 2016-01-16 05:13:17 am
tigrou: 2016-01-10 11:47:42 am
tigrou: 2016-01-10 10:23:37 am
Bad news: my main rig is broken (the LCD is dead).  I am writing from a laptop.
I read your posts quickly. I will see what can be done about the viewer improvements.
When you look at the map when you do the current route with camera defocus clipping, you can easily confirm what I've suspected for some time: the objects (including monsters) that are loaded in depend on the camera view, not your position. I guess they made the assumption that whatever was out of your view you weren't going to be able to interact with either. The same probably goes for the kinds of "objects" that trigger when you get close to then (false book, talisman...).

I just came up with an interesting idea about the arrow grab: what if you first went OOB, then somehow got an arrow or axe to chase you (or first get it to chase you then go OOB), then run to the secret room and wait for it to catch up. What should happen is when it reaches that view, you're going to be there too.

When you run far OOB you can see your coordinates start to blink back and forth. Sometimes it might look like you're in the middle of the view but you can't see yourself. I think that's just an artifact of the program actually, because I think what happens is you reach the edge and one half zips onto the other side, then the algorithm uses the middle point of your hitbox coordinates to draw your box, and that's why it shows up around the middle. That's not where the game draws you though. It's very easy to understand why the graphics glitching happens when you're around the edges... the game just draws vertices based on the locations of the dots and those happen to be on opposite sides of the world.

Come to think of it, this might also explain why the game triggers strange views sometimes while OOB: maybe it uses your center to determine which view to give you. It seems to always happen when you've run far away, which supports this theory nicely... However that might also have to do with lax view triggers that extend really far (lines that have no end).

From E2R2 OOB (use the hearth room frame) you can enter the library. However, when you do, it looks like the game does not no where to place you! EDIT: whoops it's just that you're inside a bookshelf... this is what I suspected would happen.

Well, I think I've seen a faster E2 OOB to the clock room:

ALT 1: Get to gallery normal way, then OOB like before, but now wrap around on the left side avoiding the corridor trigger.
ALT 2: OOB in R2, then reach R4 trigger so you stay OOB, then reach R1 (gallery) but on the bottom side of the trigger. You can spawn yourself in the wall this way and do a 180 doing the rest normally.

You don't really even need the matches now if no-one opposes to getting to use the viewer during your runs. You can get them from E3 kitchen if that's any faster. Also I found that you can push the clock while you're in R1 OOB and then trigger the R7 view towards the clock. When you have that view, you can get the key from the wall from OOB, then take the book etc. Now you can, if desired, use the study entrance to the caverns and trigger the cthonian so the boulder is out of the way. If you take the study way, you can also pick up the lighter when going there which means you won't have to light the lantern or keep it in hand in the water until you're in the boss room itself, provided you're using the viewer to see... The exit through study is also believed (NHG said so) to be faster, so looks like we might get to kiss the Cthonian skip goodbye finally Cheesy

When you re-enter the library from clock room, might be best to go towards the gallery so you spawn closer (in a sense) to the secret room.

To be continued...
On floor 1, if you like, you could go OOB against the staircase (on the kitchen side), then run around and enter the corridor trigger (towards the front door) from the N, then the lobby trigger from the NW corner, etc. and you can get anywhere like that. To reach the study [E3R11] fast, if you have the key, I'd forgotten that you can simply clip though the smoke room door from the lobby and go from there so none of this might be necessary. To get to the study without the key (and without being able to collect the lighter), you continue the OOB I described by just hitting the smoke room trigger on the E side, then the study from there.

I forgot you needed the sabre to access the caverns... it takes extra time to get the sabre for sure, even if you can combine that with the general OOB route through E1.

The front door trigger box always does the same thing no matter where you approach it from: it makes the PC continue moving the same way they were moving before until they either
a) hit the door at which point they'll open the door (even from the wrong side) and get sucked in by the jelly
b) get softlocked if they're moving backwards or otherwise can't get the door opened
c) hit the side of the trigger zone at which point you just die

Because of c I presume leaving the same zone is what triggers you dying, however if you die to the sides, it kills you normally and sends your body to the boss room as normal.
Wow, thank you tigrou! :---O

Nice work, LotBlind! (y)

I also found something strange. A whole new route, maybe? I started the game normally, took the lamp and went downstairs. I then tried to skip the broken floor death trap by standing very close to it and taking small steps around it. It was a difficult task and I sort of lost my sense of time, but then the floor gave way at last, and I slid gaspingly down into the nighted chamber below, choking with cobwebs and half swooning with terror. The green moon, shining through broken windows, shewed me the hall door half open; and as I rose from the plaster-strown floor and twisted myself free from the sagged ceilings, I saw sweep past it an awful torrent of blackness, with scores of baleful eyes glowing in it. It was seeking the door to the cellar, and when it found it, it vanished therein. I now felt the floor of this lower room giving as that of the upper chamber had done, and once a crashing above had been followed by the fall past the west window of something which must have been the cupola. Now liberated for the instant from the wreckage, I rushed through the hall to the front door; and finding myself unable to open it, seized a chair and broke a window, climbing frenziedly out upon the unkempt lawn where moonlight danced over yard-high grass and weeds. The wall was high, and all the gates were locked; but moving a pile of boxes in a corner I managed to gain the top and cling to the great stone urn set there.
Edit history:
tigrou: 2016-01-16 10:53:57 am
tigrou: 2016-01-16 10:53:35 am
tigrou: 2016-01-16 10:52:42 am
tigrou: 2016-01-16 10:52:19 am
tigrou: 2016-01-16 09:47:31 am
tigrou: 2016-01-16 08:20:01 am
tigrou: 2016-01-16 08:19:36 am
tigrou: 2016-01-16 05:14:10 am
tigrou: 2016-01-16 05:13:37 am
I'm back!

1) I have updated the viewer. Here is the changes :

- it is now possible to switch rooms while the viewer is linked to DOSBOX.
- pressing "L" will alternatively link/unlink viewer with DOSBOX.
- current room and floor are now shown as ExRx. so we have a unique way to reference rooms.
- there is an arrow on top of the player to indicate orientation
- when in orthographic mode, player box is always drawn above everything else (eg : useful for OOB)
- player 3D position and angle (in degrees) are shown in top right corner

2) I made a 2D map of the whole game, by sticking pieces together.
It felt like doing a puzzle "where should that room go?". the underground part was quite hard to do.
Check png files in the viewer archive.

Some interesting things I found while making the map :
- the hidden room that we already know (wireframe room and pink sofa room with black background) is actually a small corridor that connect E2R7 (room with fake book) and E2R9 (room with ghost). It was removed at some point, probably to make game harder (so then there would be only one way to go to E2R7). Then they probably added the indian cover and arrows puzzle.

- E3R6 was supposed to be a intermediate room to go to the cellar. Same for stairs in E4R1. It was probably removed because it added zero value to the game and slowed down the gameplay.

- all the rooms sticks perfectly, not overlaps, no gaps. if you look at E1R7 room, you will see there is some parts at bottom which connect with the lower floor. it looks like first they first make a full 3D model of the house, then it was cut into parts (because of memory and CPU constraints).

3) About the game : as you noticed, the camera views are not switched by the red box triggers. That info must be stored somewhere else.
I suspect the second binary file in ETAGEXX folder to contain such data and also scripts, position of 3D objects in the room etc... The first binary file is fully parsed know (it contain the boxes shown by the viewer)

The doors does not need custom trigger boxes (eg : red boxes), they are 3D objects and have their own bounding boxes (usually slightly bigger than the 3D object itself). Same goes for enemies, inventory items etc...

4) Question : does anyone knows where the trigger for hidden room (as shown in this video ) is located ?

EDIT : @Aqfaq : I have updated the maps with additional info. just re-download the zip to get them.
Edit history:
Aqfaq: 2016-01-16 07:08:40 am
Cool to have complete maps, finally!


The strange "shortcut" tunnel just above E5R2 can be passed through if you come from north to south. I can't get through it from south to north, though. It looks like it might be clippable by using a bird corpse to hug against. Might be slow, though.

I grabbed the book accidentally, when the PC was nowhere near it, so I saved a screenshot just in case:
Edit history:
LotBlind: 2016-01-16 12:45:33 pm
Just for clarity, it doesn't seem to be legitimate to use the room viewer for any actual runs. Gotta memorize it all! If you have a new full-game route to demonstrate, remember to mark it as a demonstration, not a run.


My computer is detecting a virus in the room viewer.exe! Could you please make sure it's okay?

Awesome changes once again! You did everything I asked for Smiley I think it's probably good enough for all of our purposes now, except if there was a way to display those objects as well , because that might help with doing the arrow grab or something like that, but I don't know how easy or hard that is to do so don't feel obliged dude! Also I'm sure we'll figure it out without it. All this will produce a faster run in the end I'm sure, and we'll get to showcase more OOB things.

Thanks for the map as well. It wouldn't have been difficult for me to put everything together from having all the pieces because I know the game so well but I've never done the rest of the process.

My current project with this game is finding all the various spots where you can go OOB with some notes about where you can go to from there. I've started to update the old "clips" table (in the guide) and will focus on that, but it will take me a few weeks because I'm also doing verifications etc. Anyway you don't wanna hear all that.

- Hidden room: Yes, I told you that's what it was XD
- E3R6 and E4R1: for all we know it could have been they needed to dump a little bit of data at the last moment Smiley
- I also haven't seen any places where the trigger boxes overlap moving between two areas: this is obviously because if they did they'd cause an endless loop.

Feel free to use the hidden tag for videos btw.

4) That video might not show you the optimal way to reach it, but getting the view to change first is required. What the video shows you is all we know.

The map: I see you've changed the orientation? Super-cool to see these! It's weird when you see stuff like E1R5 and E1R6 hugging each other when it feels like there's a space in-between (because that's a place you can visit OOB), but ofc it's just the R5 architecture being missing.

If you want any feedback on the maps:
-I'd change it so every room just says "R0, R1" etc. and "E1" is above everything up top. Then you could rotate everything so North is actually always in the North. It's going to be quite confusing otherwise.
-The file names should probably say "Etage0" etc. instead of Floor.

Aqfaq: You should read all the posts to find out what's already known. If you can do the clip, please make a video.

Where were you when that "wrong" pick-up happened? What was happening?

There's so much to look into once again! I think I'll just post this now...

EDIT: Tigrou: if you edit the map again, I recommend to keep all versions of it! Without the texts as well as with, because someone might wanna edit them more later.
Edit history:
tigrou: 2016-01-17 11:11:26 am
tigrou: 2016-01-17 11:10:58 am
tigrou: 2016-01-17 11:10:34 am
tigrou: 2016-01-16 04:00:22 pm
tigrou: 2016-01-16 03:54:17 pm
tigrou: 2016-01-16 03:53:51 pm
tigrou: 2016-01-16 03:52:57 pm
tigrou: 2016-01-16 03:35:12 pm
tigrou: 2016-01-16 03:34:39 pm
tigrou: 2016-01-16 02:46:43 pm
tigrou: 2016-01-16 02:45:59 pm
tigrou: 2016-01-16 02:45:44 pm
tigrou: 2016-01-16 02:45:34 pm
tigrou: 2016-01-16 02:44:16 pm
tigrou: 2016-01-16 01:22:11 pm
tigrou: 2016-01-16 01:20:02 pm
tigrou: 2016-01-16 01:19:49 pm
tigrou: 2016-01-16 01:19:11 pm
tigrou: 2016-01-16 01:18:54 pm
tigrou: 2016-01-16 01:18:17 pm
tigrou: 2016-01-16 01:14:15 pm
tigrou: 2016-01-16 01:12:42 pm
tigrou: 2016-01-16 01:12:05 pm
- using the room viewer in runs : I don't know what are the rules for AITD runs. A tool that monitor game memory and helps to improve the run is something very common in TAS (tool assisted speedrun). The only rule is it should not modify anything to the game (eg : write value to the game memory to get infinite ammo is forbidden).

- antivirus : it is a Unity5 executable and should not be detected by antivirus. The problem might be it use ReadProcessMemory() and OpenProcess() APIs to be able to read DOSBOX memory (which your antivirus might think is used for other purposes). That API was already used before so your antivirus should have triggered last time then. I have uploaded the exe to virustotal and nothing was found :

- I have no plan to decipher the second data file with 3D objects position data, scripts etc... because it look very complex and it would require a tremendous effort. I did this for the first file (with physic boxes and triggers) since format was quite simple. Someone could draw these objects himself over the maps (although it would be less precise than data extracted from the game).

maps :
- i made the maps so it could be useful for someone to draw potential OOB on it, path for the run etc...
- they are rotated that way because I wanted all maps to be oriented the same way (eg : stairs are always at the north). As it is now, they looks like if you would be outside and you would look at the house which is front of you.
- I put full room information (eg : E5R1 and not just R1) because in underground you have a mix between floor 5 and floor 6.
- By "overlap" I meant that once put again together the rooms and their walls fits perfectly. It would have been the case if designers would have done each room separately.

I will see for the other suggestions Smiley

EDIT : I just realized that on saturday (16/01) i have uploaded the zip file to the wrong ftp folder, thus you guys got a old version of the maps. I fixed this today. I have also added a new feature to viewer: a camera mode that always follow player (press "F").
Edit history:
Aqfaq: 2016-01-17 04:46:08 pm
This should be a faster escape route after defeating the final boss:
Edit history:
LotBlind: 2016-01-19 10:40:37 am

Okay, I'll just see what I can do to make my AV not keep deleting the .exe Cheesy

Yes, I know about TASing, and on SDA too you may do anything you like outside of actual recorded attempts.

The objects that are stationary aren't terribly useful to know about. They'd make the map more complete so I might do that sometime later, but really it's the positions of the arrows etc. that could do us something. Anyway I don't blame you!

If you draw OOB routes on the map it's going to look SO funny XD it'll look like some drunk guy drew them cause they're going all over the place seemingly ignoring walls etc.

Rotating them is not smart because the in-game logic is the most important: secondly, this causes a discrepancy between the room viewer and the maps.

I see what you mean about E5R1 etc. It is pretty cool seeing the whole caverns in one map despite having technically two "floors".


Ah, yes! That's certainly better than what I thought you had to do. Shows you the power of maps... Good thing too, that was going to be the boring part. It also mitigates the effect of doing the worm skip because the boulder isn't blocking you. If you did enter through study, might be the normal exit is still a bit faster? The jumping might slow you down after all.
this causes a discrepancy between the room viewer and the maps.

It is possible to rotate the rooms inside the viewer (see readme.txt). Or you could just rotate the maps inside any image editing program.

but really it's the positions of the arrows etc. that could do us something.

what do you mean by arrows? the ones thrown in the gallery ? not sure to understand
Edit history:
Aqfaq: 2016-01-20 12:49:03 pm
Aqfaq: 2016-01-20 12:48:48 pm
Oh, indeed, knowing the coordinates of projectiles (arrows, axes, thrown items, boss fireballs) would be useful when attempting to grab the talisman with an arrow, or for glitch hunting in general.

tigrou, as a coder would you be interested in improving existing emulators? Currently, the only option for TASing DOS games is JPC-RR, which is a bit difficult to use. It would be interesting to TAS AITD, but the current tools make a project like that a pain in the ass. Or maybe I am just bad at using the emulator... Would you perhaps TAS AITD yourself someday?
Edit history:
tigrou: 2016-05-03 08:49:40 am
tigrou: 2016-01-22 05:04:11 pm
tigrou: 2016-01-22 05:03:32 pm
tigrou: 2016-01-22 05:01:49 pm
tigrou: 2016-01-22 04:59:53 pm
tigrou: 2016-01-22 04:59:12 pm
tigrou: 2016-01-22 04:58:12 pm
I would love to TAS AITD. I did not know about JPC-RR utility.

It seems a (hacked) version of DOSBOX (with TAS features) exists as well :

But (like JPC-RR) it is not very stable. As anyone tried it with AITD ?

Now for something else :

1) some screenshots of the AITD beta :

2) The scripting system that animate the game is called "Life engine". It's probably called like that because it gaves life to the game.
If you take a look at game data, LISTLIFE.PAK is the file containing all these scripts.

Here is an example of one (in the attic):

DEF_OBJ zombie_of_the_trap
	BODY_FILE zombie_body monstres\m2
	ANIM_FILE rien monstres\M2_RIEN
	ANIM_FILE marche monstres\M2_march
	ANIM_FILE choc monstres\M2_choc
	ANIM_FILE attaque monstres\M2_attac
	ANIM_FILE meurt monstres\M2_mort
	ANIM_FILE monte monstres\M2_Monte
	BODY zombie_body
	ANIM -1
	POS -5600 3000 2000
	ANGLE 0 0 0
	LIFE wait_life
	DEF_VAR pointsdevie 10

	DEF_LIFE wait_life
		Body -1
		if Var ( Poulet_Grenier ) mort == TRUE
			if Chrono >= 20
				if Var flag == FALSE
					Life( trappe_grenier ) ouverture
					Var flag = TRUE
				if Alpha( trappe_grenier ) == 700
					LIFE life_arrive
					Rnd_Freq 0
					Music 13
					Next_Music 5
					Camera_Target zombie_of_the_trap
					MOVE TRACK entree_trappe
					Body zombie_body
					Anim monte Repeat
					Inc (Perso) nb_monsters
Yes, you can rotate them but I'm saying if you're going to have maps they might as well point the right way. Just an IFI.

Yes, the arrows shot by the Indian. The stuff Aqfaq mentioned... Read about the trick called "Arrow grab" in the guide. Maybe their coordinates are possible to find via memory watch? Anyway that's fine if you don't wanna do that. But wait for a TAS you definitely have to, because there's a very good chance you can save time with schenanigans like that.

I'm wondering if you can make the room viewer not shut down on pressing "esc", at least not directly. Reason is because I keep hitting esc to try to defocus the game window but sometimes I've actually had the room viewer focused. I tested it again today and it's looking really nice now! The AV doesn't have a problem because I told it off.
As far as I understand it, the Dosbox TAS functionality was hacked in by master Bisqwit so that Starcontrol II was TASable. I don't think it works for other games. JPC-RR should work for most games.
Edit history:
tigrou: 2016-01-26 01:06:37 am
tigrou: 2016-01-25 03:32:56 am
tigrou: 2016-01-25 03:28:07 am
tigrou: 2016-01-25 02:57:18 am
tigrou: 2016-01-25 02:56:14 am
tigrou: 2016-01-25 01:40:47 am
tigrou: 2016-01-24 04:28:20 pm
tigrou: 2016-01-24 04:17:29 pm
tigrou: 2016-01-24 04:15:33 pm
tigrou: 2016-01-24 04:14:49 pm
tigrou: 2016-01-24 04:11:39 pm
tigrou: 2016-01-24 04:11:00 pm
tigrou: 2016-01-24 02:48:09 pm
tigrou: 2016-01-24 02:47:46 pm
tigrou: 2016-01-24 02:43:35 pm
tigrou: 2016-01-24 02:42:55 pm
tigrou: 2016-01-24 02:42:43 pm
tigrou: 2016-01-24 02:42:35 pm
tigrou: 2016-01-24 02:42:00 pm
tigrou: 2016-01-24 02:41:43 pm
Some update:

I was looking at the game code and found (by chance, as I as initially checking something else) where all entities positions are stored in memory.
So i updated the viewer. It is now possible to view (in realtime) position of all game objects : arrows, doors, enemies, inventory items, everything Smiley
They are shown in green in the viewer. What you see are the bounding boxes, that is why things like door opening animation looks a little bit awkward.
It shows active entities for current room but also in rooms nearby. Skipping enemies as  they are still not loaded (as seen in the speedrun with the nightgaunts) should be easier. Same for skipping the Cthonian, etc...

I also made another change : game now show all rooms (for a given floor) at the same time. I found in the game data some info that allows me to connect them together. Pressing H will only show current room (as it was before). Now I realize I spend lot of time making that maps by hand, if i had that feature before, it would save me hours :S

Some trivia : the stairs room (E4R1) that I initially thought would be part of a sequence for going down to the cellar (from E3R6) is actually connected to one cellar wall, behind a shelf. Was it supposed to be a hidden passage to go outside of the house (thus leading to cellar door outside) ?

@LotBlind : the arrow grab (which allow to collect items )might worth some investigation. If we known exactly how it works, using that trick it might be possible to collect any object in the game or even changing game variables/flags (used by the scripts).

Awesome work, tigrou! You have basically done what TASers do with Lua scripts, monitor everything.
Edit history:
LotBlind: 2016-01-25 11:53:02 am
Well that was... fortuitous! :O I'm... wow'd. You've transformed - in the most concrete sense possible - the way we look at this game. Tongue

On wasting time: Imagine how I'd have felt if I had gotten to creating maps by hand with just the game screen as a reference as I intended!

Arrow grab: The current theory is this
-the game's code for following the arrows involves temporarily using the code that switches camera views for the player to track where the arrow is until it's hit the player
-if you dodge it, it'll never stop tracking the arrow
-the arrow can pass through walls and doesn't use the room-load-in code at all, only the camera views code
-because it's the camera view that determines which objects are loaded in, the objects the arrow "sees" are present while those around the player are not... the architecture is the one around the player and the player can still trigger loading zones
-if you get the arrow to fly into the secret room (or book room)... wait

Hey I think I know why it works now... the player's coordinates wherever they are in the room they're actually in overlap where the game sees the objects to be! It's that simple, surely! That would explain a lot of the inconsistencies in our observations with the arrow grab. So with this in mind, if my theory is correct, all you have to do is get the arrow to fly into the secret room while simultaneously finding a spot in whichever room you're at where your coords touch the talisman object and you should be able to grab it! I haven't looked in the viewer for this yet... I want to find out if I can find more spots to go OOB from. I'd like to know where all of them are. Aqfaq, do you think you could do the tunnels, checking all possible corners so we're not missing anything there? I'm finishing up on E2 and moving into E3 next.

If my theory is right, we might also be able to do stuff like pushing the clock out the way and getting the study key without going to the room... hmm...

Another idea I had (also haven't tested) is whether you could use the arrow simply to defocus the secret room door away (should be possible!).
Edit history:
tigrou: 2016-01-28 10:27:55 am
tigrou: 2016-01-28 10:27:28 am
tigrou: 2016-01-28 03:12:07 am
tigrou: 2016-01-28 03:12:01 am
tigrou: 2016-01-28 03:01:16 am
tigrou: 2016-01-28 03:00:55 am
tigrou: 2016-01-28 02:56:07 am
tigrou: 2016-01-28 02:54:20 am
tigrou: 2016-01-28 02:53:55 am
tigrou: 2016-01-28 02:18:00 am
tigrou: 2016-01-28 02:15:09 am
tigrou: 2016-01-28 02:14:58 am
tigrou: 2016-01-28 02:14:24 am
tigrou: 2016-01-28 02:11:55 am
tigrou: 2016-01-28 02:11:29 am
@LotBlind : about arrows : I read your post and took a look at the game yesterday, here is what i found :

It is possible to grab some inventory items without touching them : the talisman or the false book can be taken by just touching the physic box on which they sit down.

The physic boxes have IDs to be able to distinguish them in scripts. The IDs are unique per room but not globally in the game.

The ID of the box on which the false book sit down is 0.
So when camera is set to guest room, touching any box with ID = 0 will give you false book.

By chance, in the gallery, the wall on which the indian guy is firing arrows has also ID = 0.
So if you touch that wall while the arrow is inside the guest room it will gave you false book :

I checked : the talisman is also sitting on a box with ID = 0 Smiley that means it should be possible to grab it while in guest room and touching the box on which the false book is. I was not able to be able to do it, because when the arrow is entering the library secret room , the camera does not switch to it. Maybe I was just unlucky.

There might be other way to grab the talisman anyway. I noticed the library secret door is not loaded when library room is not loaded as well, which is same has the door being open.
Edit history:
LotBlind: 2016-01-29 11:36:26 am
There's objects that are in the same exact place as solids so they flicker or don't show right in the room viewer. I doubt it's anything useful though. E.g. it shows how the piano has an object covering it presumably to give you the "nothing interesting" message. Although that doesn't quite explain them. Ideally I think showing objects over solids would be preferred. But yeah mostly I'm just wondering why they're there because they don't correspond with what actually happens, e.g. you can't pick up the book in the loft from the wrong side even though the box extends that far.

I'd love to be doing more tests on this game but I have to rest my wrists to avoid repetitive strain syndromes. So I will at most do short replies for now.

IDs: That explains the behaviour then... Surely you could be in some other room too, e.g. what if you:
-get indian cover
-get to gallery
-cover settler portrait
-open library door
-attract arrow and enter library
-juke around so the arrow enters the secret room

Where is the wall with id 0 in the library itself? Could you reach that one in time?

Maybe you have to be in the library yourself so the camera trigger to enter the secret room is even available? Which views can load in probably depends on which view you're currently in so the arrow has to take a path through multiple views, and cannot directly go from clock room to secret room. That would explain.

As for the latter option: that's what I meant by "defocusing the secret room door away". Please test if you can.
Edit history:
tigrou: 2016-01-31 04:40:14 am
tigrou: 2016-01-31 04:37:46 am
tigrou: 2016-01-31 04:37:19 am
tigrou: 2016-01-30 01:45:52 pm
tigrou: 2016-01-30 01:44:59 pm
tigrou: 2016-01-30 01:34:15 pm
tigrou: 2016-01-30 01:34:05 pm
tigrou: 2016-01-30 01:31:32 pm
tigrou: 2016-01-30 01:31:20 pm
tigrou: 2016-01-30 01:31:01 pm
tigrou: 2016-01-30 01:30:23 pm
tigrou: 2016-01-30 07:41:45 am
tigrou: 2016-01-30 06:28:09 am
tigrou: 2016-01-30 05:53:35 am
tigrou: 2016-01-30 05:53:22 am
tigrou: 2016-01-30 05:52:37 am
tigrou: 2016-01-30 05:50:50 am
tigrou: 2016-01-30 05:50:30 am
tigrou: 2016-01-30 05:26:21 am
tigrou: 2016-01-30 05:26:00 am
tigrou: 2016-01-30 05:25:11 am
tigrou: 2016-01-30 04:47:56 am
tigrou: 2016-01-30 04:44:02 am
tigrou: 2016-01-30 04:43:31 am
tigrou: 2016-01-30 04:42:46 am
tigrou: 2016-01-30 04:42:27 am
tigrou: 2016-01-30 04:41:39 am
tigrou: 2016-01-30 04:29:16 am
tigrou: 2016-01-30 04:16:56 am
tigrou: 2016-01-30 04:10:38 am
tigrou: 2016-01-30 04:08:54 am
tigrou: 2016-01-30 04:07:40 am
tigrou: 2016-01-29 05:15:10 pm
tigrou: 2016-01-29 05:15:00 pm
tigrou: 2016-01-29 05:14:48 pm
tigrou: 2016-01-29 05:09:54 pm
tigrou: 2016-01-29 05:09:09 pm
tigrou: 2016-01-29 05:06:37 pm
tigrou: 2016-01-29 05:02:35 pm
tigrou: 2016-01-29 04:59:21 pm
tigrou: 2016-01-29 04:58:29 pm
tigrou: 2016-01-29 04:57:19 pm
tigrou: 2016-01-29 04:54:26 pm
tigrou: 2016-01-29 04:50:03 pm
tigrou: 2016-01-29 04:48:33 pm
tigrou: 2016-01-29 04:48:18 pm
tigrou: 2016-01-29 04:48:13 pm
tigrou: 2016-01-29 04:47:28 pm
tigrou: 2016-01-29 04:46:48 pm
tigrou: 2016-01-29 04:44:57 pm
tigrou: 2016-01-29 04:44:26 pm
tigrou: 2016-01-29 04:42:57 pm
tigrou: 2016-01-29 04:41:56 pm
tigrou: 2016-01-29 04:40:27 pm
As you mentioned, some physic boxes (eg : the piano) are covered by unwanted objects. This was a bug and has been fixed.

I understand my explanation with box IDs is rather confusing.
I have put a new room viewer version that display ID of boxes by putting mouse on it. Hope it will help you to understand how the false book glitch works.

Something I forget to explain : in the game data, all boxes (physic or trigger) have a "flag" attribute which act like a tag.

I modified room viewer to display that info :

Physic boxes:
flag = 0 : shown in gray (as before), no player interaction possible.
flag = 4 : shown in blue, they are physic boxes that player can (potentially) interact with. These physic boxes can trigger a script.
Examples of use  :
show message "nothing interesting" , give you item inside furniture (eg : cookie box, knife, medical kit, ...), or help you to grab an item (eg : lantern, lighter, talisman, false book, ...). Without that type of box, the lantern (in the attic) could never be reached, because the bounding box is too small.
You will notice some walls are flagged that way, but i guess theses are mistakes left by game designers in game data.

Trigger boxes :
flag = 0 shown in red : room switch
flag = 9 shown in amber : they are triggers used for special purpose (change foot steps sound, trigger door close, ...)
flag = 10 shown in amber : trigger a floor switch

As before, all green boxes are active objects (enemies, doors, inventory items, projectile etc...). They have an ID which seems to be unique for the whole game.

I fixed the problem with ESC : it will not close the program anymore when in window mode.

EDIT : I took a look at all models of the game (in LISTBODY and LISTBOD2 files). Unfortunately, I did not find anything special (eg : unused models).
I made high resolution screenshots of some of them.
I see. I still can't do much over here...

Ah I see I made a mistake: we need to see what the talisman's ID is and find the corresponding wall in the library, not 0. We won't need the book for anything.

The Wiki guys will be REALLY impressed if they get their hands on those model pictures btw. That looks perfect for the wiki, those look amazing!

Thanks for fixing the ESC thing.
Edit history:
tigrou: 2016-01-31 02:48:36 pm
tigrou: 2016-01-31 01:07:38 pm
The models came from a modified version of the game : on floppy disk game version you have a copy protection screen where you have to select two objects.
I modified it to show on ALL game objects (and not just a few) and to render them to a 320x200 window (instead of small thumbnail). I can send you that modified exe if you want.

About talisman : yes what you wanted to do in the library is not possible because the wall with ID = 0 is probably too far from the secret room.
The best would be to touch box where false book (with ID = 0) is while arrow is in secret room (since box on which talisman is, is also 0)