Roll Eyes
Lips Sealed
page  <- 12345678910 -> <- 1 .. 3 .. 10 ->
List results:
Search options:
Use \ before commas in usernames
Shut up and go back to another earth
Ahah cool trick ! Do you have to put it in the same place or does it work no matter where you drop it ?

I can't think either about a similar situation: taking an item who moves something in the decor. The only situation who is "kinda similar" is the opening of the hidden room in Library, and not only I'm pretty sure you can't grab the fake book again but also the moving desk is not actually moving, it's just disappearing.
Why would there be two different libraries, one with hidden room and another one without? That's like saying there's two different 3rd floor landings, one with the stairs trigger and the other without, when surely it's just being covered up by the nightgaunts and the secret room door respectively? Well, it's possible just the trigger itself gets loaded in I guess and it doesn't cause lag if it's just one thing. But that's clearly not how the nightgaunt skip works.

water monster = deep one... just check the part of the guide that says what everything is called. Some of them are clearly from Lovecraft and using those names you won't have to think of a new name every time. I recently renamed the flying monsters in the caverns "wasps" because I realized they had insect-like wings.

Faster boss room entry: if you could produce a clean version of the trick for the strategy guide (even if you don't start using it in your runs), that would be useful. Mine wasn't so great of course. Maybe even show how small a margin you're working with. I don't trust your systematicity enough to write the trick off completely.

Aqfaq: Do a barrel roll! I made a video of that. Did you know you can just hit ctrl-alt-F5 to shoot a video in DosBox btw? Hit it again to stop it and it puts it in a folder associated with the copy of DB that came with the game called "captures".
Shut up and go back to another earth
As I already said, I found the double library thing interesting at first to explain how impossible it was to reach the hidden room (as if it did not exist before you put the fake book) before remembering that we had some proofs that it's not the case: the arrow who can reach it for exemple. We have to stop to talk about that x) that's not it ! End of the story.

Deep one: Oh come on, you understood me xp Whatever, next time I'll check before talking about a monster 8-)

Faster boss room: So, you want a clean version of the video you showed to us, right ? Without the come back into the maze ? Just to be sure. And what systematicity are you talking about ? I'l try to show the "no climb" way too !
NHG: Yeah I meant if you could create a clean version of entering the boss room fast, that would be great whenever someone is doing a segmented run. And the other method would be interesting to see too! Forget what I said about systematicity, it was just a burn.

I'm naming the screenshots now... I have to go back and take some of them again for consistency.
Aqfaq: How you do get the bird y coords to reset? When exactly do you reload? Can you not produce a video? You've running the GOG version on DosBox aren't you?

Found a new way to pass from the 2GallerySettler (the settler portrait screen) to 2ClockGallery (the same screen the current route enters the clock room at) that seems to take around exactly the same time as the old one:

Feel free to test that. The way you find the right angle (and you have to have the GALLERY loaded in not the corridor) is to make her move along the same straight line the wall on the left is parallel to. I used a ruler Wink It makes all the sense ofc... You obviously have to choose a direction a tiny bit to the left from that so when you wrap around, you're going to appear more close to the clock room.

BTW those names I used for the rooms are the kind of technical tags I want to give every view and room. They might change but I'll do my best to make them simple, unambiguous and short. The 2 means second floor (cellar/caverns gets a 'C' and the loft is just e.g. LoftStart) the next part is the name of the room or area and the last part marks out the thing the view is facing, in this case I might use "Gallery" because it's the clock room view that's facing back towards the gallery. I might also use "Chair" because of the red chair. You see the logic. I'll keep you informed when I've worked on this stuff more. I also want to create a flow chart showing the different zones/rooms/whatever.
Edit history:
Aqfaq: 2015-09-10 06:53:45 pm
Aqfaq: 2015-09-10 06:35:54 pm
Aqfaq: 2015-09-10 06:35:25 pm
Aqfaq: 2015-09-10 06:34:48 pm
Quote from LotBlind:
How you do get the bird y coords to reset?

I noticed that the first bird can't be reseted. It has a different kind of entry. It seems to fly in the air and it always lands inside. The vase room bird is different. I don't know the exact moment, but the view was from the bird's perspective when I saved the game and the bird was very close to getting through. If I recall correctly I heard the glass break before I saved the game. It happened accidentally and I didn't think it would be important, so I didn't pay much attention to it. Sorry about that. I am also too lazy to record videos. Sorry about that, too.

Nice route improvement idea! Looks easier to do than the old method. It looks so easy and fast now that I think even a highly optimized TAS might be slower with the arrow talisman glitch method. That is nice, because the glitch is a bitch to set up. Good work!

Oh, I recently noticed that the indian rug can be taken away after it is placed. The rug is physically located OOB near the painting on the right side of the screen. It is probably useless, but an interesting little detail that I never noticed before. The painting is dead after you take the rug away, so there are no axes and you can steal the rug. Wow, mindblow! This game is about stealing valuable antique stuff for real! The unbroken vase and the indian rug can be taken with you when you leave the house! Who knew? These items must be worth millions! Wait, what's this... I got a different ending when exiting the house with the rug and the unbroken vase: WOW! LOOK AT THIS!

Hey, I got an idea for another category: All items. That would be a challenge to plan and execute. Actually, why not go for true 100% and also kill every monster. That would be entertaining, especially if it was segmented or TASed with high precision. It would be a true action movie. Too bad not many people make DOS TASes, even though it has been possible for years. Even I don't have the motivation for that. It is just too laborious with the current tools available.

I am optimistic that we have not yet found every useful trick and route detail. This game is so great. Looking forward to the next surprise finding. Heh-heh-heh...

Edit: Oh, indeed. I use the GOG version. Is there any difference? I haven't noticed anything, except the music.
Edit history:
LotBlind: 2015-09-11 09:05:10 am
Just hit CTRL-ALT-F5, DosBox starts recording, hit them again, it stops. Look for a file called indark_000.avi. Stick it on Dropbox or something...

Also you low-down troll. I didn't believe it for a second, but I didn't realize you'd revive the most vile and heinous of all the forms of troll for this thread at this time...

I started a Skype group for real-time discussions about the game. Friend me (sviimhoinen) if you'd like to be included. You too creepy lillbrorsan person if you're interested in the game Wink
Since there are three of us, this thread should be titled...

Together in the Dark
Shut up and go back to another earth
God damn it ! Did I... Just got rick-rolled ? You'll be alone in the dark for that Aqfaq :/

I had tons of tests to do but I have to say, none of them were really productive. I'll post a video of what I did though. The other clockroom path is probably better once you got the angle enough. I'll test that but it's probably faster.

Also about that: "Finally:
Probably pointless but tells us you can sometimes be teleported out from the water."

Maybe it's an useless information but I think I got the explanation here. From the room after the boulder to Pregzt room (with the maze between them), the whole section seems cutted from the rest of the basement, like if it was another floor. That's why the game makes come back to the real floor (it works in the other way too), it kinda makes the character appear in a definite spot. The same thing happens when you clip into the maze and then trigger the room behind the rock-door. Also, when the screen shakes after Pregzt death, it stops when you goes out of this "section", and once again it works in the other way too: in my old run I touched ghosts from the ballroom and the screen stopped to shake when I entered into this section. I wonder why this same shake wasn't stopped when I entered in the cavern in the first place though. But anyway, for all those details that's my theory x)
NHG: didn't I already say there's 2 zones in the caverns? Shocked I must have forgotten.

Hmm... so where did the shaking stop in your old old route? I'm curious because I wanna know where the zones are. Maybe there's more than 2.
Edit history:
NHG: 2015-10-13 03:27:46 pm
Shut up and go back to another earth
I tried and recorded the alternative path to the 2clockgallery and indeed it seems pretty the same time but as I said, less risks to make a mistake once you got the good angle to run to. I also tried to record (as you asked me to) the entering to Pregzt room without triggering the maze. My conlusion is that somehow, triggering the maze is required. In your video, you can see a blinking showing that you were in the maze for some frames. Well when I reach the ledge without this blinking, my character does not stop to climb and fall until I eventually touch the maze. Apparently this detail is important. To be sure of that I triggered the angle showing the good ledge first so I was sure of my position. I can climb ten times without never staying up there, but as soon as I'll see the blink meaning that I was into the maze for 2 microsec, THIS TIME the Character won't fall. This may explain why I can't come back into the real room when I try to climb the other platform under the exit rock. Somehow the walls have limit pushing me back but coming from a room between put me behind this limit. In any case I'll try to see if I can optimize a little my move around here without risking being stuck.

About the sahking:

As I said, just after the boulder. But maybe this works differently that we thought. I made some tests. If I trigger a ghost and go to the cavern by the "saber path", the shaking will continue until the boulder. But if I trigger a ghost and use the new way (Chtonian path), it'll stop directly into the cellar and it wont come again into the cavern... Except if I take the falling bridge to come back into the house, and then go down again (except I'll be stuck anyway because the bridge'll be broken). Also, at the end with the Pregzt shaking, when it's gone (by using the exit rock or the pushed boulder), it does not come again even if you return in pregzt room x) Same thing with ghost shaking: when it stops after you reach a room, it goes back only if you come back to the floor where the ghost is. So at the end maybe there are just some access who cancel shakings and some others simply don't. Ghosts keep trigger the shaking as still as they are "alive" and in hunt-mode but Pregzt in another hand only does the shake thing with his death animation, so this one can't come back.

It is really interesting to see how all of this game works but I suddenly realize that I made a serie of tests who took me like an hour and who were perfectly useless for the run x)
Alternative way to boss: I also asked you what happens if you fall into the water from behind the boulder (like you said could happen)? Can you not reach the boss from there? Is it any different if you do Aqfaq's trick first - move through the square room into the next view, then back through the square room and into the pirate maze. Then once again into the square room, but this time intentionally falling into the water. Does that change anything? Ask me in skype if you're not sure what I meant.

If that does somehow make it possible to reach the boss faster, you can pass through a place where the view to the corner of the boss room is shown (cBossCorner), which you also mention doing in your post. Do you really still need to visit the maze first? Okay, I guess that's what you're saying.

I agree that the earthquake effect when P dies is just extra code that does that once. With that example, it's clear that you shift into another zone, but with the vortices for some reason going downstairs through the study doesn't stop it even though it's a new zone for sure... Maybe the code for the shaking stopping and starting is hand-crafted exceptions. I wouldn't be surprised. Anyway it doesn't really prove or add to anything IMO.

No such thing as useless testing... it's elementary. You don't know where you'll find whatever you're after. If you did, you wouldn't need experiments.
I just realized that the twirling ghosts in the game might be a reference to Lovecraft's story called The Colour Out of Space. The strange color entity in the story is described thus:

"the shapeless stream of unplaceable colour"

"the column of unknown colour"

"it spreads on everything organic"

"that riot of luminous amorphousness, that alien and undimensioned rainbow of cryptic poison from the well - seething, feeling, lapping, reaching, scintillating, straining, and malignly bubbling in its cosmic and unrecognizable chromaticism"

The descriptions fit the game quite well:

This illustration by Google looks familiar, at least the colors:

Furthermore, in the (crappy) movie adaptation it is shown how the color escapes dead bodies, similar to what happens when zombies are killed in the game:

So, the zombies are possessed by the color out of space. The colorful balls escape upwards (back to outer space) after monsters are killed. The monster deaths make more sense now.

No such thing as useless testing? Challenge accepted!
The movie came out in 2010...

But yes the vortices (why does everyone call them ghosts?) are reminiscent of that passage from the story.
Did you test choosing "use" before doing anything else so you can do a snap-turn while picking up the lantern? Ofc this is different from the oil canister, but just a thought.

Actually when I tested that I managed to do this after just a few tries:
Not quite perfect. If you time that vs. the old way you should remember to account for already having open/search selected (and half a second from the good clip).

I noticed that unlike I assumed she could, Emily at least can't turn exactly 90 degrees. I can't get her to face a direction that precisely. This further means if there was a trick that required a very precise direction that you're facing in, it would be possible to miss it unless there's ways to get those in-between directions. I added more stuff related to rotation in the guide. Just check for what's been edited.
Edit history:
tigrou: 2015-12-28 01:46:58 pm
tigrou: 2015-12-28 01:41:39 pm
tigrou: 2015-12-28 01:40:12 pm
tigrou: 2015-12-28 01:39:49 pm
tigrou: 2015-12-28 01:24:38 pm
tigrou: 2015-12-28 01:13:17 pm
Hi there,

I recently watched the 8:22 speedrun from NHG and it gave me a few ideas.
One of the main trick is about going trought the walls and skipping some areas.

Would it help to have sort of minimap and on the top of it, main character position, drawn and updated realtime ?

With that minimap utility, we could perhaps skip very large areas (with player going totally offscreen for a long time).

All what is needed to is to find the player position (XYZ values) from game memory (which should not be to hard) and write small utility that renders a map accordingly.

The map could be custom made, or maybe it could be retrieved from the game data itself.

If you look the game data, there is files like ETAGE00.PAK, ETAGE01.PAK, ... ("etage" means floor)

These files are the 3D collision data used by the game.

You can see in this video (at 13:06 and 27:23) what i am talking about :

These files are compressed (PAK) and can be easily depacked using QuickBMS and this script :

Then you got two binary files. the format is unknown but I suspect the first one to be an array of 3D points and the other to describe how these points are combined to form 3D cubes or other primitives.
The hardest part is to reverse engineer the format.
Writing a small utility that render the map (to allow to explore it and find possible holes/tricks) would be very easy (ex : using threeJS)

Rendering that map from top view would be useful for the small utility I was talking about above.
Edit history:
tigrou: 2015-12-29 10:27:26 am
tigrou: 2015-12-29 10:26:56 am
tigrou: 2015-12-29 10:24:43 am
I was able to find out the memory location of the player 3D position.
I monitored that position while playing, however the game does not work as I expected.

When switching from one room to another (even on the same floor), player seems to be teleported : the 3D position is replaced brutally.

My guess is that rooms (i mean their 3D geometry) are not interconnected each other (as it would be in a FPS), instead, only one room is loaded at a time  and when player touch a trigger (usually near a door) the game unload current room, load next room and set player to a given 3D position (where the player should be after the switch)

Because of that i don't think skipping huge areas (as i initially thought) might be possible. Only one room at a time as in the speedrun. For example it might not be possible to directly go to library hidden room by leaving the place where the guy with the sword is.

Here's some notes from earlier:

Emily is wider than she is thick. This means she can only move through very narrow gaps if she's some way sideways (or clipping ofc).

Did anyone try luring the bird in Hartwood's bedroom down the corridor to use them to block an axe or arrow? They're kinda slow but it should be possible to get them to take an axe for you.

I think you can perform the quick turn just out of activating an item dialog without using a command... Is that what you did in the run? It doesn't seem that hard to do.


To respond to you tigrou:

Firstly, did you see our wiki? It has everything we know (and think we know) about the game that seems even potentially relevant to speedrunning it. Feel free to edit it in any way you see fit! In fact I just created the "additional resources" sub-page and linked the program you used and the script.

We did by and large know where the OOB can happen (though there's areas I haven't fully explored, floor 3 and the loft and pretty much done) and a lot about how it works: yes, it's evident the game doesn't keep everything loaded in memory all at once, but what you're saying about the player literally being teleported from location to location should only be true between larger parts of the game, not every single room by any means. For example, we know that the area we call the "gallery" (i.e. art gallery) on the 2nd floor is one "zone", because its architecture and trigger lines get loaded in all at once. That's why the 8:22 triggers the corridor zone first to do the full OOB to get the book: otherwise the gallery walls would get in the way! Then the gallery is triggered when the view changes (which is why he's stuck in the wall) so that you can access the clock room, which otherwise wouldn't exist.

Unrelatedly we know a slightly better way to do that part, just running around the whole plane and wrapping around to the other side while the gallery is in memory.

Other zone changes we have observed: 3rd floor shouldn't have any (but still some walls are not always there and some triggers are unloaded too depending on where you are). 1st floor: hasn't really been tested even though you can OOB on the other side of the staircase so it could be tested if desired (it's just not going to do anything for the run unless you can bypass the door monster which we highly doubt). cellar is a zone of its own. Tunnels have 2 zones: the second one starts when you pass through the opening behind the chest and the boulder. It's possible to recognize them just by looking whether there seems to be anything but black behind the entrance and also you get teleported to the correct z-coordinate even if you were down in the water or something like that.

Having a top-down map for exploring the OOB would certainly be a help! If it could be extracted (I don't know anything about that) that would save a lot of trouble: I literally started doing that manually to get some reference maps, but of course those are always a bit sketchy and might miss something.

And yes, NHG was having a lot of trouble finding the secret room via OOB, suggesting its only trigger line is directly underneath the object that acts as the door (yes, it's an object). Arrows (see Arrow grab in the guide) CAN reach it the way you'd expect them to so that's a bit funny too. You CAN trigger more areas without entering them and them go further with you OOB as I described above. Anyway just read the guide and you'll be up to speed on everything (I hope).
@Lotblind :
Thanks for your answer.
I was able to found out game internal format for rooms and have wrote an application which allow to explore them.
See here:

I hope it will be helpful to improve speed runs and find new tricks or glitches.
Instructions are in the archive.
Edit history:
LotBlind: 2016-01-07 10:29:11 am
LotBlind: 2016-01-07 10:18:44 am
That looks highly interesting! I'm going to take a look straight away and think about how to use it later on when I become more active with this game... You're done lots for us, thanks! Just in case, let me know if you want to mess with this game more and I can give you some leads...

EDIT: Looks like it requires Unity as well, so I'll just add that to its description..

JESUS H.C. Christ this thing is AMAZING! Looks like my hand-made Loft map was very accurate but I can see stuff here that I couldn't have figured out. It's actually missing a lot of triggers such as all the ones that change the camera angles within each room (which are useful to be able to see). Also are each of the rooms present separately in the game files or did you edit the way the maps are presented in any way? It also doesn't have any objects in place but I'm not sure that's that interesting seeing as we don't have any particular uses for them anyway.
I don't even know where to start...

Looks like the house data really has South where we assumed it to be as per the sketch in the library, so from now on I think we can officially use S, E, N and W and we'll be able to see what we meant based on the room viewer data. So far I haven't seen any discrepancies with the way the house's topology is supposed to work and how it looks in Room Viewer.

1) So when the player enters a trigger box, I guess it doesn't matter which side they enter it from. What happens if you spawn inside a box though (i.e. when the room is loaded into memory if you're inside a box you presumably can't trigger its effect without moving out of it and in again)?

2) What is the box over the carpet in the loft? I presume it causes the soft footstep sounds to be played instead of wood (which is probably the default).

3) What we're known from before is you can clip into lots of narrow gaps between different solids (to coin a term for objects that you can't move)... Are some of the solids overlapping though? For example the table and the chair in the loft probably overlap so the table actually prevents the clipping whereas the boxes in the bottom left corner don't overlap. On the other hand there's gaps that look like it's not possible for them to overlap but maybe there's a micro-gap sometimes and absolutely no gap at other times. Is there a way for you to see that?

4) There is no number 4.

5) Looks like every room has giant red boxes next to them that probably load in the next room's architecture.

6) Looks like the area within which you can place the Indian cover is quite big... maybe you don't even have to be looking at the portrait?

7) I think I can see optimizations you could do with NHG's original OOB route through floor 2. It's crazy to be able to see all the trigger boxes that he found and uses for doing it! Sadly it looks like the box that triggers the library coming from the gallery is short on the S side so that's why you can't get the library to spawn before you're beyond the first shelf... maybe you could trigger it from the SE corner of the box so you're inside the E shelf and somehow wiggle your way through to the secret room trigger from there? Not very likely...

8) Another thing I can see is the trigger box for the clock room extends to the N so you could probably trigger it from that side, walk around to get the book faster, then you probably still have to hit the gallery box from the same side and then you can cut the corners a bit more (?) going back into library. This optimization (and cutting corners around the library box) might be enough to make the old route better after all, though not marathon-safe. Smiley

9) Looks like Floor 2 room 9 is empty for some reason, but it's room 10 where you have the hearth room in case you couldn't find that one.

10) Annoyingly, the floors are numbered from top down instead of down-up in the data... :/ Gonna cause some confusion.
I wonder why they always made the room transition boxes that much wider than it looks that they needed to be. :| Weird.

Is there an easy way we could join all the rooms together to produce one coherent map?

Floor 3 (in-game terms): sabre room - looks like you could put the sabre in place from further away, just like the cover on floor 2.

Floor 3 dining room: Wonder what the bottom box is for?? The big one (and the small ones around the W side) is clearly for closing the doors on you, the smaller one around the center is where you place the pot, but the bottom one..? EDIT: looks like you can also place the pot down on that end of the table! Cheesy Lol, I never knew that...

Floor 3 smoke room: The box in the middle is probably where you can use the jug.

Floor 3 room 6: What exactly is this room? Looks like maybe the cellar stairwell? Why does it need to be a room? Alternatively could it be the top part of the staircase that goes up? Why?

Floor 4 (cellar): What is wrong with that staircase? Cheesy

Floor 4 room 1: looks like the staircase leading down from the study... if it is though, it's orientation is wrong - it's supposed to run W-E.

Cellar: what the rooms are in order
0 Bridge
1 just S of bridge
2 This weird section is just N of the boulder area... The passage on the right cannot be accessed from this side, sadly, but it CAN be accessed through the other side, from room 5.
3 Cthonian entrance
4 Part with the bird in it, the box W is for getting the worm to move ahead to block the W entrance to the grotto?
5 This is the first section of the spider pit tunnels. On the left there is a hidden entrance to the tunnel that connects to room 2. You can just walk through the wall to enter it! You can clip through the "door" on the other end to access room 2.
6 Part of the second tunnels with the spider pit.
7 Grotto area
8 Pillars area
9 White spider area (funny how the bottom extends like that)
10 Pirate maze (look how many areas it's had to be divided in :O)
11 Chest and boulder

Could it possibly be faster to backtrack to room 5 (run through the whole pirate maze) to get to room 2 using the hidden entrance? I fear it probably cannot... Still what a find!

Floor 6: rest of the caverns

0 NE part of maze
1 N part of maze
2 NW part of maze
3 W part of maze
4 SW part of maze
5 SE part of maze
6 boss room and connecting areas (this shows clearly how the boss is loaded in when you get into this area, hence the freaky fireball sounds)

In Floor 6 room 6 (boss), you can see the box for placing the talisman right next to the sarcophagus but what's the one to the left of it? On the W side there's lots of boxes for starting the fireballs. You can attempt to climb up through the wall around the N part of the boss room where the lower platform is but the walls prevent it.

Side note: looks like you can do the quick turn when climbing up places, so that might save a tiny bit of time somewhere?
Edit history:
tigrou: 2016-01-09 07:36:31 am
tigrou: 2016-01-08 06:22:02 am
tigrou: 2016-01-08 04:55:45 am
tigrou: 2016-01-07 05:34:37 pm
tigrou: 2016-01-07 03:26:06 pm
tigrou: 2016-01-07 03:25:52 pm
tigrou: 2016-01-07 03:24:15 pm
tigrou: 2016-01-07 03:21:56 pm
tigrou: 2016-01-07 03:20:33 pm
tigrou: 2016-01-07 03:17:52 pm
tigrou: 2016-01-07 03:17:18 pm
tigrou: 2016-01-07 03:14:04 pm
tigrou: 2016-01-07 03:11:00 pm
tigrou: 2016-01-07 03:09:35 pm
tigrou: 2016-01-07 03:08:21 pm
tigrou: 2016-01-07 02:56:37 pm
tigrou: 2016-01-07 02:51:23 pm
tigrou: 2016-01-07 02:49:24 pm
tigrou: 2016-01-07 02:48:38 pm
tigrou: 2016-01-07 02:47:50 pm
tigrou: 2016-01-07 02:47:35 pm
tigrou: 2016-01-07 02:47:17 pm
tigrou: 2016-01-07 02:47:01 pm
@LotBlind: i'm glad you like the app. I put a lot of effort into this. The viewer itself took only a few hours to write, but debugging the game (a 16-bit DOS app) to find out room format was difficult.

To answer your questions :
Are each of the rooms present separately in the game files or did you edit the way the maps are presented in any way?

The rooms are shown in the viewer exactly like they are divided in the game.
The game load a full floor in memory, but to save CPU cycles, it only consider one room at a time.

1) AFAIK the side you enter in the trigger box does not matter. Anyway the game might applying additional logic specific for each box, by using scripts.
It might prevent what you are suggesting so best way is to try.

2) Yes you are right, this is for footsteps.
Each box is associated with a unique ID (identifier). That ID is then referenced in scripts to trigger some specific actions :
Eg: if trigger "5" is activated, spawn monster at position "5300, 1500".
If you look at the GDC video you will see some screenshots of the scripting part (this is only for the game logic, the engine itself is written in C).

That's probably why you can't escape the house without fighting the boss first. The same trigger box is used, behind that box there is probably this logic :
if boss_is_dead then trigger end_game sequence
else spawn worm and trigger dead sequence

3) I don't know exactly how the OOB trick works. I guess it happen because when the player is colliding with a wall, the engine constantly push the player against the wall, sometimes it push it too much and since the wall is thin the player get OOB. Yes some physics boxes overlap themselves. You can also notify there is some boxes added additionally to avoid player being trapped (which might indicate the collision code is far from perfect).  I have added new functionality in the viewer which should allow to inspect each box individually, using the mouse.

5) Yes. These trigger boxes load next room + teleport player somewhere (where he should be after room has switched).
6) Yes I thought the same thing while seeing it. It has to be tried. Maybe it won't work. The script behind that action maybe checks if player angle is in a given range before putting the indian cover (thus only facing the wall would work).

9) this empty room 9 could be a room that was removed before shipping the game. they did not want to adapt the scripts (the smoke room ID would go from 10 to 9), so they make that room empty instead of deleting it. or it could be a room that was left intentionally blank for other purposes.

Is there an easy way we could join all the rooms together to produce one coherent map?

yes, by doing screenshots and copy pasting each screen to a image editor.
I would hide the triggers first (by pressing "t" in the viewer) and set camera as orthographic (press "c").
Simply rendering all rooms at the same time in the viewer won't work : all rooms will overlap (they are all centered around (0,0,0) 3D position)

Note : i have updated the viewer with improved controls and new functionalities. Just re-download the zip file to get the update Smiley

EDIT : AFAIK, the viewer does not require unity to be installed, it's a stand alone exe. which error message did you got ?
That's how I figured the front door probably worked, so I'm doubtful it can be skipped.

We know which room room 9 was going to be! It's clearly the corridor between hearth room and the clock room... it's there in the hidden view you can only see from OOB. It doesn't have any graphics, just a wire frame, but clearly it was in the design at some point.

Okay sorry my bad, I assumed I had to have Unity (I already had it BTW) because it looked like it was loading Unity for me...

I will do the screencap thing and compile a map when I have some energy.
Edit history:
tigrou: 2016-01-09 12:19:51 pm
tigrou: 2016-01-09 12:19:42 pm
tigrou: 2016-01-09 12:18:40 pm
tigrou: 2016-01-09 07:36:47 am
tigrou: 2016-01-08 06:16:02 pm
tigrou: 2016-01-08 06:15:32 pm
tigrou: 2016-01-08 05:59:30 pm
tigrou: 2016-01-08 05:59:09 pm
tigrou: 2016-01-08 05:58:55 pm
tigrou: 2016-01-08 05:57:41 pm
tigrou: 2016-01-08 05:57:19 pm
tigrou: 2016-01-08 05:55:01 pm
tigrou: 2016-01-08 05:41:55 pm
tigrou: 2016-01-08 05:41:20 pm
tigrou: 2016-01-08 05:40:32 pm
tigrou: 2016-01-08 05:39:02 pm
tigrou: 2016-01-08 05:38:04 pm
tigrou: 2016-01-08 05:37:31 pm
tigrou: 2016-01-08 05:37:06 pm
tigrou: 2016-01-08 05:36:23 pm
tigrou: 2016-01-08 05:35:33 pm
tigrou: 2016-01-08 04:24:28 pm
tigrou: 2016-01-08 04:21:38 pm
tigrou: 2016-01-08 04:06:42 pm
tigrou: 2016-01-08 02:31:41 pm
tigrou: 2016-01-08 02:30:41 pm
tigrou: 2016-01-08 02:27:37 pm
tigrou: 2016-01-08 02:27:20 pm
If you watch the GCD 2012 video (which i highly recommend), you will see how they made the rooms in the game:

One guy make a 3D room with only boxes (no texture at all).
He made a wireframe rendering send it to an artist.
The artist paint things over it, using paint deluxe (so the 3D model and the bitmap match perfectly).

The unused room that we know today is actually a room before the painting phase Smiley
I think at first they wanted to use real pictures for the game, but they were never able to rebuild the related 3D models from it. So they went the opposite way.

Some trivia (found while debugging) :

1) The man 3D model is slightly taller than the woman (make sense). However Emily is wider.

Here is XYZ bounds :

Edward : (-266;266 0;1777 -266;266)
Emily :  (-285;285 0;1761 -285;285)

I checked their speed as well but I was not able to tell if one goes faster than the other.
They both seems to run at around 2000 units/sec.

2) I have extracted ALL rooms camera images from the game data (144 views in total). I did not find anything special, expect the hidden room we all know (with wireframe only) and that room :

It looks likes a view from a secret dark room which is adjacent to the guest room where you find the false book (for the library).
Or maybe it was the initial door from which you were supposed to enter that room initially, the artist only painted what you saw inside the door opening, the rest was not painted (that why it is black) and that was cancelled before it's finished ?

3) Look at floor 2 / room 3 with room viewer, you will see in there is a additional block in the wall (where the curtain is supposed to be) :

If you go to that room in the game and make player search in front of the curtain you will hear strange sounds o_0

I have uploaded a new version of the viewer : it is now possible to view player 3D position, updated automatically from DOSBOX. See readme.txt for more info.

It should allow to perform OOB tricks easily, especially when player goes out of the screen.
I'm amazed how last speed run was great, especially the guy has to find those triggers by himself (i mean without any tool).