Username:
B
I
U
S
"
url
img
#
code
sup
sub
font
size
color
smiley
embarassed
thumbsup
happy
Huh?
Angry
Roll Eyes
Undecided
Lips Sealed
Kiss
Cry
Grin
Wink
Tongue
Shocked
Cheesy
Smiley
Sad
1 page
--
--
List results:
Search options:
Use \ before commas in usernames
Starting yesterday, whenever I try to go to any page on twitch other than the homepage, all I get is a black screen with "twitch" in the middle.  I can't get to my stream, profile, following page, manually type in a streamers name, or anything else.  I tried my laptop and get the same results, so it's not just my PC.  I tried deleting cookies, flushing the dns, rebooting the modem, disabling all extensions, even different browsers and still nothing.  I can use outside services such as multitwitch and kadgar to access streams, so I know twitch is still working for others.  Anyone know what might be causing this, or how to fix it?  Here's what I see:

Thread title:  
0-10
In your javascript options, there's now an additional site you'll have to allow before twitch-anything works again. twitch.tv, ttvnw.net, and jtvnw.net are the three that have to be allowed.
Sorry, but I know nothing about javascript.  Where would I find said options?
Edit history:
ymh: 2015-03-04 10:18:29 pm
ymh: 2015-03-04 10:18:11 pm
ymh: 2015-03-04 10:17:09 pm
Quote from Slaughterhouserock:
Sorry, but I know nothing about javascript.  Where would I find said options?

http://enable-javascript.com/#chrome


  1 On the web browser menu click on the "Customize and control Google Chrome" and select "Settings".
  2 In the "Settings" section click on the "Show advanced settings..."
  3 Under the the "Privacy" click on the "Content settings...".
  4 When the dialog window opens, look for the "JavaScript" section and select "Allow all sites to run JavaScript (recommended)".
  5 Click on the "OK" button to close it.
  6 Close the "Settings" tab.
  7 Click on the "Reload this page" button of the web browser to refresh the page.

?
Quote from ymh:
http://enable-javascript.com/#chrome


  1 On the web browser menu click on the "Customize and control Google Chrome" and select "Settings".
  2 In the "Settings" section click on the "Show advanced settings..."
  3 Under the the "Privacy" click on the "Content settings...".
  4 When the dialog window opens, look for the "JavaScript" section and select "Allow all sites to run JavaScript (recommended)".
  5 Click on the "OK" button to close it.
  6 Close the "Settings" tab.
  7 Click on the "Reload this page" button of the web browser to refresh the page.

?


That's already setup to allow all sites, so that's not the problem.  Twitch swears it's a DNS issue even though I've changed over to google's DNS.  My cable company tried a few things, but nothing worked(they say they'll call me back in the next 9-10 days Roll Eyes ).

Any other ideas?

*Edit:  Turns out it was my IP address.  If anyone else has this problem, run a command prompt, type "ipconfig /release" hit enter.  Then type "ipconfig /renew", this will give you a new IP address.  Thanks for the assistance guys.  This has been a pain in the ass, but hopefully it'll help anyone else that has the issue.
This is a common issue, for future reference, see https://twitchtips.com/grey-screen/
Edit history:
Rogen: 2020-07-06 12:21:03 pm
Fix twitch black screen error on Google Chrome

And if you are using Google chrome browser then try below methods :

    Clear browser cache and cookies
    Clear browsing data
    Use incognito mode in Google Chrome
    Disable all Browser extensions and plugins
    Allow Flash player and Javascript for all application
    Update your current browser
    Reset Chrome browser settings to default
    Enable TLS
        Step 1: Open Chrome
        Step 2: Open menu by clicking three vertical dots
        Step 3: Open Settings > Click Advanced Settings
        Step 4: Click System > Click Open proxy settings
        Step 5: Click Advanced tab > check all TLS options > press OK
    Disable VPN or Proxy server
    Use beta.twitch.tv
    Use twitch alternative Multitwitch