Roll Eyes
Lips Sealed
page  <- 123456789101112131415161718 -> <- 1 .. 12 .. 18 ->
List results:
Search options:
Use \ before commas in usernames
I'll give it a try.
I´m using Nestopia+Wsplit and while Nestopia is active, global hotkeys doesn´t work. In other words, while I´m in the game and want to do a split, it won´t let me. Any fixes or workarounds?
Fucking Weeaboo
Well, I'm guessing it's one of two things.

1. You have global hotkeys set up but not turned on. Make sure this is the case.
2. Your global hotkeys conflict with hotkeys in Nestopia. Change them in Wsplit if this is the case.
1. They are enabled (in the same tab where you bind them), if that is what you meant.
2. I´ve tried alot of different keys now. None of which worked.

All keys work when Zelda 2 is not loaded (when Nestopia is opened and selected), but when I load Zelda 2 and select it, all global keybinds stop working. Thanks for the suggestions though.
Lots of games simply don't work with wsplit's global hotkeys. Try using llanfair.
Aww, that´s so unfortunate, I really love how wsplit looks and handles. Thanks either way.
Hello everyone,

I didn’t really know about this topic until recently, I’m sorry some of you had troubles with Llanfair on Mac but hopefully everything should work now?  In any case I just wanted to let you know that I’ve released the 1.3 version of Llanfair today, I thought you might want to know =) I’ve added a few requested features like a pause function, customization of timer fonts, custom goals etc. You can find everything on my blog as always:

I promise I’ll watch over this thread for any suggestions/troubles (although it’s best to post about it on my blog) and keep improving Llanfair.
Hey man thanks.

I know I was harsh in my commentary above, but I've put some serious testing into the version brassmaster linked.

Not one crash yet.
That’s alright, but if I’m not aware of a problem I cannot fix it heh Tongue

I’m glad it works fine now.
torch slug since 2006
i like 1.3. few things i wanna see in the future:

* change font for every text (split names, split times etc. not just the main timer)
* always show last split
* if you make the timer more vertical, show more splits (kinda annoying going in Components to set how many splits)
* change font for every text (split names, split times etc. not just the main timer)

Yeah, I just wonder where I’ll cram all those drop lists and spinner Cheesy

* always show last split

What do you mean? Show the end segment of the run at the bottom of the history list? If so, that’s a possibility.

* if you make the timer more vertical, show more splits (kinda annoying going in Components to set how many splits)

I can’t really agree. I mean, you might want to resize Llanfair without changing how many segments you display. What would be great is the possibility to drag the separator to make the history grow/shrink, but it’s a tough one.
i mightve explained bad.

re: always show last split
lets say you have 20 splits, but you only show 14 of em. i want the last visible split to be the last split, so people dont think that your pb is 3:25, when it really is 5:56. wsplit has an option for this.

re: vertical
ah, so the splits names/times component is called history? okay yeah thats were i confused you.
if you drag the history component to be more vertical, show more splits, is basically what im saying, which you also seem to be saying.
Xunkar, polk suggested i ask this question in the forums, since you are watching this thread.  I have a new iMac with 10.8 on it.  I have installed java to the latest version 1.7 11.  When I double click the .jar file, a small java icon appears in the dock, then disappears.  I ran it from the terminal and these are the errors i am getting.  Does this make any sense to you?

Exception in thread "AWT-EventQueue-0" java.lang.IllegalStateException: cannot register native hook
at org.fenix.llanfair.Llanfair.setBehavior(
at org.fenix.llanfair.Llanfair.<init>(
at org.fenix.llanfair.Llanfair$
at java.awt.event.InvocationEvent.dispatch(
at java.awt.EventQueue.dispatchEventImpl(
at java.awt.EventQueue.access$400(
at java.awt.EventQueue$
at java.awt.EventQueue$
at Method)
at java.awt.EventQueue.dispatchEvent(
at java.awt.EventDispatchThread.pumpOneEventForFilters(
at java.awt.EventDispatchThread.pumpEventsForFilter(
at java.awt.EventDispatchThread.pumpEventsForHierarchy(
at java.awt.EventDispatchThread.pumpEvents(
at java.awt.EventDispatchThread.pumpEvents(
Edit history:
presjpolk: 2013-01-19 09:30:02 pm
Glad you found the thread.  Good luck!
duxcub > unfortunately, but it looks like you're using Llanfair 1.2, 1.3 shouldn't have that kind of message. If you're having that problem with 1.3 then it's a problem with the 3rd party library JNativeHook and I can't do much about it. Keep me posted.

I have now installed and uninstalled both the latest Java from the website, and the official Apple-supported version, and no variation will run the program.  It's a shame, because it looks really neat and Polk has it working on his Mac.  I guess I will just have to live without it Sad

Thanks for trying.
We can either wait for an update from the guys responsible of JNativeHook or try to delve into their sourcecode to jurry-rig something. I'll look into it when I get back from work.

I appreciate any assistance you can offer, but if it becomes too much of a time waste, don't worry about it. 

I am using 1.3, downloaded from your website.

java version "1.6.0_37"
Java(TM) SE Runtime Environment (build 1.6.0_37-b06-434-11M3909)
Java HotSpot(TM) 64-Bit Server VM (build 20.12-b01-434, mixed mode)
How are you checking what java version you're running?
"Java -version" from the terminal. It is the version automatically downloaded from apple the first time you run a java app.
Edit history:
Kiyura: 2013-01-22 09:13:11 am
That's not the latest Java, and you should be downloading it directly from Oracle now. Apple no longer updates theirs.

I'm using 7u10 with Llanfair 1.3 on OS X 10.8 just fine. 7u11 (current) should work as well.
Edit history:
presjpolk: 2013-01-22 09:25:21 am
~> java -version
java version "1.6.0_37"
Java(TM) SE Runtime Environment (build 1.6.0_37-b06-434-11M3909)
Java HotSpot(TM) 64-Bit Server VM (build 20.12-b01-434, mixed mode)

It's not his java version that's causing it, I conclude.

Also, Oracle can stick it.
Llanfair was developed under Java 6u29 and Java has strong backward compatibility (at least when it was handled by Sun, with Oracle now it’s a different world) so there are absolutely no reason for the Java version to be at fault here.

As far as I know the only way this exception could be thrown is if Llanfair is already running and you try to execute a second instance. I don’t know much about Mac or any BSD-based OS but I assume you have some ways to check the running process (maybe even with the ps command) and kill all the javaw processes. The JNativeHook website talks about something on MacOS X called "assistive device" that needs to be turned on, if it helps.
Edit history:
DJS: 2013-01-23 09:12:49 am
DJS: 2013-01-22 11:04:04 am
DJS: 2013-01-22 11:03:36 am
torch slug since 2006
yep the assistive device thing is the problem. i tried on my own mac, with it disabled, Llanfair doesnt even pop up or anything, and with it enabled, it works!

system preferences > universal access/accessibility/where you go if you have some kind of handicap > its one of the checkboxes at the bottom of the window
Thanks for working on this everyone.  DJS, that totally solved it!  I went to System Preferences>Accessibility  At the bottom is a checkbox "Enable access for assistive devices."  I checked it, ran llanfair 1.3 and it popped up immediately!  Awesome Smiley