Username:
B
I
U
S
"
url
img
#
code
sup
sub
font
size
color
smiley
embarassed
thumbsup
happy
Huh?
Angry
Roll Eyes
Undecided
Lips Sealed
Kiss
Cry
Grin
Wink
Tongue
Shocked
Cheesy
Smiley
Sad
1 page
--
--
List results:
Search options:
Use \ before commas in usernames
JWILD28:
registered on 2010-11-04 06:57:49 pm.
 
Crazy-JWILD is a crazy mofo
Hey all,

I have been practicing for a semi-casual/semi-serious Super Mario Bros. run (currently aiming for 5:05 with warps, glitches, and walljump). I have been playing on both my NES (with DVD recorder hooked up) and on my Toshiba Satellite laptop with the FCEUX emulator and a Retrolink USB NES-style controller. I practice on the laptop for the tricky parts (walljump, alternate pipe glitch on 4-2 etc.) using save states. The problem is that the lag on the laptop-emulator-usb controller-system is...well just enough to make it frustrating.
Anyone know how to reduce this type of lag? Is there something I can do within FCEUX? Do I need a better ROM? Is it a product of using that type of input (USB controller)? I do not use PAL emulation...(I'm not sure what I use but when I turn PAL on the game runs at half-speed)...maybe the answer lies somewhere within that. Any help is much appreciated!
-JWILD
Thread title:  
honorableJay:
is in the group Wiki ops.
registered on 2006-04-13 02:29:03 am.
 
Gender: male
Location: Albany, NY
Be the Batman....
Your best bet to get a solid answer would be to try here: http://tasvideos.org  In the forums you'll find a section dedicated to that specific emulator. Btw, NTSC mode runs at 60hz/60fps while PAL runs at 50hz/50fps. NTSC is the standard display setup for North America/Japan, while PAL is the standard for most European countries. The emulator should automatically select the correct mode for your rom when you load it up.

As for the input lag, there are a few things I can think of:
1) The controller itself is the cause. In this case, you'll just need to use another controller.

2) The usb hub the controller is hooked to is saturated. Usually this happens when you either have a lot of devices on one hub or a high bandwidth device (external hd/cd-rom) on the same hub as the controller. If you have any other usb devices hooked up, disconnect them. If not, try other usb ports and see if that fixes the issue. Since you're using a laptop though it might not fix the issue (since the amount of available ports on laptops is usually 2-3).

3) The emulator itself is lagging. This can happen if you've enabled rendering enhancements (hqx, 2xSal, etc) or have the resolution set too high. Other times it could simply be that your laptop can't run the emulator at full speed to begin with. The first thing to do is make sure all video enhancements are turned off, then set the resolution to around 640x480. If that doesn't work, try enabling auto-frameskip. If you get rock solid 60fps in NTSC mode with everything cranked then it's probably not the emulator running too slowly.
JWILD28:
registered on 2010-11-04 06:57:49 pm.
 
Crazy-JWILD is a crazy mofo
@honorableJay
Awesome. I will try these things and let you know what happens. Thank you.