<- 12345 ->
--
--
List results:
Search options:
Use \ before commas in usernames
TASer
Quote:
I couldn't get that trick to work either - I was thinking it was because my PC is too fast! This game probably was made to run on a 300 MHz PC back in the day, so it may have only worked at those speeds. The Telekinesis trick sounds interesting though, but I can't think of anywhere to use it on my route offhand. If you can find a way of making this trick work it would take minutes off the final time.

I used this trick to enter Escaton's room without unlocking the last door. I don't know how much time this saves, I'm not even sure if the locked door is just a clickable one or has to be unlocked by activating switches..
Edit history:
MUGG: 2015-07-02 05:04:42 am
MUGG: 2015-07-01 06:19:51 pm
MUGG: 2015-07-01 05:29:46 pm
MUGG: 2015-07-01 05:25:25 pm
MUGG: 2015-07-01 05:25:17 pm
MUGG: 2015-07-01 04:09:05 pm
MUGG: 2015-07-01 04:06:37 pm
TASer
I would be interested in a single segment "become acromage champion" run.
Or if nobody wants to run it, maybe someone wants to route it. Tongue
Here is a list of all taverns: http://telp.org/mm8/answers/arcoquestp.html

What would be the fastest way to get to regna? Looks like you have to play the whole alliance thing, which sucks. The only way around this that I see is if the game allows access to regna ships or it makes the outpost on daggerwound appear after forming the conflux key.

Also question: When you save outside of a shop, are the items up for sale already decided or do they get decided as you enter the shop?

Also, I'm getting some kind of lag and audio stuttering in acromage, most noticeably after playing a card or after the opponent is done playing his cards. You can hear audio stuttering. Sometimes my turn takes less long. I believe there is some kind of framerate bug.
Does this happen for anyone else?

edit: turns out you have to not only form the alliance to get to regna, you have to complete all of regna because otherwise the door in ravenshore to become acromage champion won't open. (All doors are locked in ravenshore until regna is done)
Edit history:
Yagamoth: 2015-07-02 07:57:11 am
INTJ
The Arcomage lag is caused by the sound as well from all I remember reading. When people muted the sound, it usually didn't lag at all anymore (quoting from memory.. Might not be entirely true)

Also I'm pretty sure the shops contents are determined the first time you enter it. After that it will remain the same until the inventory gets replaced

In a way, arcomage champion sounds quite interesting ^^
Edit history:
MUGG: 2015-07-02 03:33:55 pm
MUGG: 2015-07-02 03:22:40 pm
MUGG: 2015-07-02 03:08:08 pm
MUGG: 2015-07-02 03:07:16 pm
TASer
I did glitch hunting for a bit. Didn't find anything but saw some interesting little things.

When loading a save and immediately doing something, then the screen may glitch.

E.g. after loading a save, do one of the following immediately
1. clicking on the character portrait of the active character to bring up their inventory and close it
or
2. bring up the spell select screen and close it.

Screen should be glitched now. Worked in Ravenshore, doesn't work in Plane of fire (maybe the game redraws the screen there regardless what happens).

If you move around the glitch fixes itself (game redraws the map). If you do this in front of a door and then try to click at where the door is, nothing happens. You can't click on doors that haven't been drawn on screen. It's kind of interesting..

I noticed the game would crash if you open up the save menu and save on different saves over and over quickly.
Edit history:
MUGG: 2015-07-04 04:09:02 pm
TASer
Oh btw,  I did golden's 12 hour speedrun challenge and played this game any% realtime (no segments). My best time was 28 minutes something and I would have gotten 24 mins if not for some error happening in the game (when I saved, it said the savegame was corrupted).

I had to make a few route changes so what I'm going to write might be interesting to those who want to run this game realtime too. It's not going to be like an indepth guide, but just some thoughts or notes.

- To start off the run, you do the spell glitch and fly to ravenshore
- Instead of selling 2 books at the shop as in the segmented run, I resorted to opening the nearby chest and get 4~5 gold heaps from there. You'd save outside the shop and repeatedly reload until getting one of the two needed scrolls (invis and stone to flesh). If you had to sell 2 books over and over it would turn out to be a bit slower. When going for a record run though, you'd probably still sell the 2 books and just try opening the shop like 4 or 5 times and then reset if the luck sucks.
When you get one of the scrolls but not the other one, you can still savescum (i.e. using savegames a lot) through the other shop since the scrolls have a chance at appearing there too.
- Instead of resting in front of the coach, you want to wait until dawn. Resting = chance of enemies attacking you, whereas waiting is safe but takes 1 sec or so longer.
- Do the air plane like in segmented. Of course a lot of savescumming is needed to get past each enemy. Btw, when saving Cauri you apparently need to click a certain dialogue option for her or you won't get the rescue money (e.g. simply clicking on the statue and then dismissing)
- Grab 200 gold from the well and ride to garotte gorge, head towards Ravage Roaming from there and do water plane, like in segmented.
- Grab 200 gold again, hire Cauri, ride to alvar, get her rescue money, buy spell books "Town Portal", "Invisibility" and "Telekinesis" although the latter isn't required. The rest pretty much is like the segmented run.
- Except that I would do the prisons in the order water-earth-air-fire because I have had a hard time getting out of the fire prison. In fact, I lost some runs because I didn't have enough health to even get through the fire prison to reach the lord. Invis can be cast for both water/earth and then again for air/fire. I didn't try other orders.

There's no "saving, reloading and using telekinesis through a door" kind of trick in Escaton's palace, btw. The way you do that place is just like in segmented.

A lot of time can be lost to enemies just blocking your way in the planes, especially the dudes on the stairs in the earth plane. Those can cost you minutes but sometimes they can just be out of the way if you're lucky.

Edit history:
MUGG: 2015-07-07 01:30:39 pm
MUGG: 2015-07-07 01:17:29 pm
MUGG: 2015-07-07 12:09:41 pm
MUGG: 2015-07-07 08:45:36 am
TASer
turns out you can go through doors after all.

It was rumored you could go through doors (such as in Escaton's palace) by saving in front of them and then reloading while moving forward. Doors would get rendered later so you could pass through. But it didn't work for gammadragon and not for me either.

I found that you could, however, do something else to pass doors.

1) save in front of it
2) load and hold forward & hold spell book hotkey (other hotkeys may work too)
3) let go of forward and close the spell book screen

you will be inside the door partially. It takes about 5 ~ 7 times of this procedure to get through.
Could save time in Escaton, I'm going to time it.


EDIT: You can go the left way and pass 2 doors like that, then save/reload and telekinesis through the last door. It's still problematic though, because how do you get back? Passing doors takes time and if you go back the same way you came in, you would pass 4 doors (32~40 save/reloads required), also there are enemies in the way. In segmented they could be bypassed but in RTA, they may stall the run for seconds.

Also if you clip into a door, you can sometimes stand on top of it and partially clip inside nearby walls and walk around like that. You can see rooms in the distance when out of bounds but I wasn't able to see and telekinesis to Escaton's room with a lot of testing.

EDIT:

When on top of a door, you are basicly out of bounds and the game won't re-render certain parts of the screen.
This can cause items on the screen to not be removed after taking them. If you do this on a gold heap, it won't be exhausted and you can basicly get infinite money with this.
I tried it on an artifact and the 2nd time I obtained it it said "found an item (null)" and I got nothing.

EDIT:

One last thing: Looking back at the segmented run, wouldn't it be faster after the spell book purchases in Alvar, to take a coach to shadowspire and then one to ironsand? That would set you closer to the plane of fire.
Here is a list of travel possibilities http://www.mightandmagicworld.de/mm8/Reisen.shtml (ger)
Might be magic...
Wow, there's been quite a bit of activity here recently Smiley

I'd definitely be keen to see the single-segment run.

You're quite possibly right about the coach route to Ironsand too. Worth investigating!
Edit history:
MUGG: 2015-07-12 02:44:11 am
MUGG: 2015-07-09 03:45:10 pm
TASer
Fix crash in escaton's palace
Go to the game's music folder and add a 16.mp3.
If it still crashes, add a 1.mp3.
If it still crashes, please post in this topic.

Use keys the game doesn't recognize
If you want to use, say, Right-Shift but the game considers it a No-key, you can't normally use it in the game.
But if you edit the registry, you can map any key to any other key and then assign that key in the game.
I used https://sharpkeys.codeplex.com/ and mapped "Right-Shift" to "."
I assigned "." as a key in the game. Now if I can effectively use the "Right-Shift" key in the game.
Hacky and dirty, but not cheating in the game. It's like using a different controller.


If the game becomes permanently really laggy
Sometimes the game becomes laggy and I can't fix it even when I restart the game or reboot. This problem is noticeable for example when you cast Fly and try to ascend or turn around - it will sometimes move slower than it should. I'm just noting what you can do if this should happen to you.
- Reinstalling
- Using the Rel version
- If you run the game from a shortcut created with the mouse cursor lock software, make a new shortcut after reinstalling mm8
Edit history:
MUGG: 2015-07-12 11:36:53 am
MUGG: 2015-07-12 11:36:27 am
MUGG: 2015-07-11 07:40:14 am
TASer
My best time glitched rta is now 23:12 22:32 (and I had so many mistakes, 20:00 definitely viable)

My time when I played glitchless was a little over 2 hours but I played for fun and didn't route it or practise it.
More interestingly, I want to do a playthrough without invis and without glitches.

My stream is here http://www.twitch.tv/mugg1991 I apologize in advance for my swearing or if the stream is boring :p
TASer
Fix audio stuttering
It seems in order to get rid of acromage audio lag / travel loading bar audio lag, you simply have to run the game in compatibility mode for win xp service pack 3. At least that has worked for me.
I had previously run the game in win 95 mode and didn't realize that that was the problem.


Btw, I just won an acromage game by escaping it before it was over... I will try to investigate it.

And also, when I load a savegame now and enter acromage and play a card, it will be discarded (even though I left-click on it).....

strange

Also, I tried to come up with a fancy jump strat in earth plane and it turned out way too slow.. lol.
Edit history:
MUGG: 2015-07-19 01:52:38 pm
MUGG: 2015-07-19 01:05:52 pm
TASer
My best run is now 21:43 http://www.twitch.tv/mugg1991/v/8010148
I messed up in a few places, but had good luck.. I was actually surprised I only got 21:43 and not better.

oh btw, you don't have to write prison and inside. You can just write jail and in.

would it be allowed to use a macro to write those?
Might be magic...
Quote from MUGG:
oh btw, you don't have to write prison and inside. You can just write jail and in.

would it be allowed to use a macro to write those?


Awesome, I had no idea about that... good find Smiley

I think SDA rules disallow using macros unfortunately.

I watched your latest single-segment run, it's starting to look really polished. You definitely took many less attempts than I did! Also better at using the interface, so I wouldn't be surprised if you eventually beat my time Cheesy
Edit history:
Yagamoth: 2015-07-20 06:00:47 am
INTJ
This is really awesome. I should've checked this thread earlier already Cheesy

Definitely looking forward to watching some of your attempts MUGG Smiley

The out of bounds sounds very interesting to me. Did you manage to find more applications for it? Do you know, whether all rooms are technically loaded or connected maybe? I'm thinking of Zelda MM, where all the faerie fountains are connected and you can travel out of bounds between them. What happens if you go out of bounds entirely? I can see a lot of potential in this *_*

Edit: I have two more questions:
- Are there any lichs you could recruit relatively quickly after you obtain the elemental key? (As in, you are now respected enough maybe?)
- Can you use Lloyds Beacon inside buildings to gets outside?

Obviously if both questions would be answered with "yes", this would result in being able to cut down on the walking outside in the elemental planes buildings by a fair amount I imagine.
Edit history:
MUGG: 2015-07-20 04:03:05 pm
MUGG: 2015-07-20 01:58:58 pm
MUGG: 2015-07-20 01:47:02 pm
MUGG: 2015-07-20 01:45:08 pm
MUGG: 2015-07-20 01:43:47 pm
MUGG: 2015-07-20 01:43:30 pm
MUGG: 2015-07-20 01:43:20 pm
TASer
gammadragon, I will never be able to beat your segmented time. There is too much potential time loss with bad luck, and having to rely on safer strats in a full length run (doing fire prison last, waiting instead of resting, save scumming). But I think that a 19: time is doable, so that will be my goal. That 21:43 run was so bad in hindsight...

Yagamoth, you cannot really pass through walls. The only thing I found is with Escaton's palace that you can stand on doors and cast jump to jump up, but you can still not jump out of the map or anything. It's kind of weird, I should make a video soon. This would only be really cool if you could cast telekinesis on escaton's door while standing on a nearby door, but I couldn't do it after quite a bit of testing.

I will look into the recruiting thing, although I think that it may be too slow. Then again, Escaton's palace is so slow... Save/loading through two doors and then casting telekinesis to reach Escaton, and then using the beacon to go to the entrance might be viable.

You can probably just die and then cast the beacon (if you are restricted by nearby enemies or being indoors).



I found that there is apparently a PS2 version of this game, which was released only in Japan. It seems to be mostly the same game but with some differences (maps are smaller, introductory level, different music tracks in each region, etc.). I was wondering if there were more differences, and if the glitches work on that version.

By the way guys, I would be happy if you or others do these full length runs too, so I get a little competition Wink I already requested a leaderboard to be added to speedrun.com

EDIT: It got approved. http://www.speedrun.com/Might_and_Magic_VIII_Day_of_the_Destroyer
The link might change though, but you can find it by searching the game name.

---

Lastly, what should be the consensus about saving over savegames that aren't from the current run?
E.g. You can't click on an "Empty" file, so you have to either write one character or remove the "y" before you can save.
But if savegames were already present, you could just click those and save immediately. I sometimes forget to wipe my savegames.
Do you think saving over non-run savegames is ok or does it invalidate the run?
Might be magic...
That Japanese PS2 MM8 find is interesting, looks slightly different to the PC version as well. Seems like they added a tutorial section to the beginning and who knows what else they changed.

I think the savegame name thing is fine - time in menus is supposed to not get counted in SDA final time anyway.
Edit history:
MUGG: 2015-07-21 07:00:12 am
TASer

door glitches in escaton's palace

I don't think you can recruit level 50s after the conflux key, since the alliance hasn't been formed.

I don't know if beacon scrolls appear in the shops.

You can save 1 second in fireplane by using telekinesis on the entrance, and then flying slightly left direction and casting invis again. But I think it's too risky for RTA, since you can get hit sometimes, resulting in possible death of the fly caster.
INTJ
This out of bounds looks really interesting... I wonder - are those items regularly obtainable in this place? Or are those juts some oob leftovers?

It looks really odd to me oô.. I like it
TASer
You know how there are artifacts in this game that appear in certain places?
Part of the artifacts are fixed and the other part is random. The random artifacts are drawn from a pool which is 31 or so items and when it's used up no more artifacts appear.
When you get to the palace before they are used up they appear on the floor. Those are items you can see there.
TASer
Lost my motivation to run this game. Go figure. (I lose my motivation always before I'm actually done with something)

I tested Escaton skip again and still couldn't get it to work. I however found that the skipping through doors route was more reliable than I thought and had potential of saving about 30 sec. Will do a comparison video of some sort later.

If you use telekinesis at the last door, you will not have to skip back through that door but you won't be invis anymore. You risk getting pummeled to below a health that you can't survive fire prison.
Might be magic...
That's a shame - a single-segment run would have been pretty awesome. Hope you return to it soon!
TASer
I'm uploading the comparison video of escaton door route.



it should be up in like 2 hours. I'm uploading it right now.
Might be magic...
Brilliant - a really clear comparison of the two approaches.
Edit history:
MUGG: 2017-04-21 08:33:25 am
TASer
Someone made a new run.

I posted my thoughts as a comment on the video, if you're interested.

Might be magic...
Cheers Mugg, I added a couple of comments too. Seems like some good improvements using the door glitch that I couldn't get to work, but I'm slightly doubtful about some of the other parts, like the shopping and some other highly unlikely random events which would probably have required a few saves. I didn't see them included but maybe they were just edited out of the youtube version.
Edit history:
Snabel: 2017-05-09 02:54:06 am
Hello guys!

I have gotten a lot of inspiration from here and I just uploaded a run on youtube where I beat the game in around 15 minutes, feel free to check it out: