Username:
B
I
U
S
"
url
img
#
code
sup
sub
font
size
color
smiley
embarassed
thumbsup
happy
Huh?
Angry
Roll Eyes
Undecided
Lips Sealed
Kiss
Cry
Grin
Wink
Tongue
Shocked
Cheesy
Smiley
Sad
<- 12345678 ->
--
--
List results:
Search options:
Use \ before commas in usernames
Run looks pretty good. I was wondering how you did the Door skip. I'm at that point in a casual playthrough so I'm probably going to test that out later. Wondering what the best route for a mainline% speedrun would be (i.e. not skipping Alliance). I'll have to test some of those dungeons.
Okay, so doing a test of Mainline% this is the route I worked on briefly. 1) Start on Dagger Wound as normal, get the quest to report to the guild hall in Ravenshore. Renegade-cast fly to boat, sail to Ravenshore. 2) Deliver letter, get quest to blackmail Arian Hunter.  Wait until morning + 1 hour to take coach to Alvar. 3) Get scroll of invisibility from the magic shop, sell starting books/rings. quest quest to find Cauri  and buy a book of, originally I did Invisibility but Town Portal might be better. 4) Renegade cast fly, go to Murmurwoods, rescue Cauri and use scroll of invisibility to get Air Heartstone as in any%. 5) Recruit Cauri, teach Invisibility. If you bought TP cast to Alvar and get Invisibility then TP back to Ravenshore. Sneak through and blackmail Arian Hunter. Report Blackmail and go to Alvar. 6) In Alvar get Town Portal (if not already obtained), get quest to find survivor of ironsand. 7) Travel to Ironsand and perform the Vilecrawler quests. Afterwards fly over to the plane of fire and obtain fire heartstone (I was in no condition to do this in my testthrough). 8) Start alliance quest.

HERES WHERE I'M HAVING DEBATE ABOUT THE ROUTE BUT THIS IS WHAT I THINK MIGHT BE BEST:
9)Travel to Ravage Roaming. Sneak into the Barbarian Fortress and grab the dragon egg, get killed. 10) Travel to Shadowspire, drink from the town well, get the quest to obtain nightshade brazier. 11) TP back to Ravenshore then travel to Garrote Gorge. 11) Add Ithilgore to your party, give egg to Dragons [This bit is debateable again, this is what I think provides the best safety performance.] Travel to Murmurwoods. 12) Cast invisibility, sneak into temple of Sun, right before grabbing the Brazier enter TBC, select Cauri then grab the brazier and cast Town Portal. Since the Clerics don't know that you are there yet they will not be hostile and she can cast TP. If the spell fails it will still be her turn, cast it until successful and teleport back to shadowspire. 13) Turn in the Brazier and then spend all your money leveling people up in shadowspire [Again, debateable, but this is what I think I have to do due to safety for pathing.] Put all skill points in melee weaponry. 14) Go back to Ravage Roaming and do the Labyrinth quest, I have no been able to maintain invisibility without running into tritons, hence the safety of leveling up in order to try and beat them back with sticks (Ithilgore will probably be heavy hitter if you put all his points into Dragon Skill.) 15) With Balthazaar's lair cleared return to Alvar. Get the Regnan quest. 16) Proceed through the Regnan quest, after blowing up the fleet Finish the run as if it was any%.
Edit history:
MUGG: 2018-01-18 09:00:53 am
MUGG: 2018-01-17 02:11:10 pm
MUGG: 2018-01-17 01:44:41 pm
TASer
I did some derust runs today. But I ran into the same problems as before (game starts randomly going slow, most noticeable when flying up and down)...

And I can't do door skip with just one save like in the segmented 15 minute run. I need 3 or 4 saves.
Idk if it's because of the computer, or the greyface patch.

I got two 26 minute times, with bad play and luck all over the place so I'd be confident to get really good, but the lag issue is holding me back. (...)

@ZevVeli, I did full playthroughs long ago, but I can't really help, sorry. I think I used Cauri and the 1st character like the any%, and invisi-cheesed my way through the game.
Edit history:
MUGG: 2018-01-18 09:02:04 am
MUGG: 2018-01-18 09:01:43 am
TASer
I made a video of my recent findings
That's the single best production values on what's a little bit of research.

Couldn't you get more than one double bind bound at the same time by assigning multiple keys to the win key? You're probably not saying you couldn't.

Game feels like brokenness isn't entirely unexpected in these complex CRPGs. We're still a bit unclear about the Grayface patch so if you happen to find there's some major gameplay alternation no-one pointed out in the verification thread, do point it out and we'll see if there's cause to change the verdict on it (not necessarily the run).
Edit history:
MUGG: 2018-01-19 03:01:20 pm
TASer
I have got a 21:40 time now, 2 seconds better than my old PB.
That's with 22 sec slower shopping at the beginning, a death in plane of Water, and the "game is laggy" problem. So there is room for improvement.

@LotBlind:

If you use the same win key, it won't work. But it will work if you use different win keys. That will result in multiple double binds. I'm more interested in if there could be a weird effect if you try two things at once. But I haven't found anything.
Yeah, double binds like that won't do anything you couldn't otherwise because it's no different from the game's point of view to receiving both inputs from different key presses. As far as I can tell.

There's always elusive one-frame simultaneous action -type tricks. Tongue
Edit history:
MUGG: 2018-01-21 03:54:25 am
TASer
I'm considering to change the route a bit.

Old:
AIR --> WATER --> FIRE --> EARTH

New:
AIR --> FIRE --> WATER --> EARTH

In the new route, you get Cauri earlier, after getting the heart of Air.
In Ravenshore, instead of waiting 1 day and riding to Garotte to get the heart of Water,
you'd go to Alvar again, get Cauri's rescue money, teach Cauri spells, wait 1 day and ride from Alvar to Shadowspire,
wait 1 day again, ride from Shadowspire to Ironsand.

The downside is that, going to the Water plane takes a bit longer (Ride to Alvar, wait 1 day, ride to Garotte).

Riding to Ironsand saves 9 seconds over travelling.
This more than makes up for the slower way to Garotte.
And since you have Cauri earlier, you can telekinesis on the entrance of Water plane and Fire plane to save 5 seconds each.

(I'm doing invis spell inside of Fire plane. You need to renegade Fly on Cauri to survive through the initial fire elementaries, make a very slight flight detour to the left where there are no enemies and then invis spell.)
Edit history:
MUGG: 2018-01-21 09:07:16 am
MUGG: 2018-01-21 09:07:02 am
MUGG: 2018-01-21 08:59:38 am
MUGG: 2018-01-21 08:31:03 am
MUGG: 2018-01-21 08:12:53 am
MUGG: 2018-01-21 08:04:07 am
TASer
I finished two 19 minute runs today! I'm really happy

19:34 and 19:56.
The former was bad execution but really good luck (with Earthplane especially, I could just walk straight through everything).

Quote:
We're still a bit unclear about the Grayface patch so if you happen to find there's some major gameplay alternation no-one pointed out in the verification thread, do point it out and we'll see if there's cause to change the verdict on it (not necessarily the run).

It is worth noting, that the Grayface patch is said to add features such as Quicksaving. I cannot tell if the runner used quicksaving or if the saving/loading parts have been cut out... Either way, quicksaving should not be used as it isn't part of the normal game.
Yes, quicksaving was used, but so long as that's the only difference, we decided it was okay for convenience. Here's the two verifications for Snabel's runs so you can see what was brought up before:
https://forum.speeddemosarchive.com/post/might_and_magic_viii_day_of_the_destroyer__may_30_2017.html
https://forum.speeddemosarchive.com/post/might_and_magic_viii_day_of_the_destroyer__june_27_2017.html
Might be magic...
Nice progress Mugg! I'll be keeping an eye on the new runs Smiley
Edit history:
MUGG: 2018-01-31 02:44:18 pm
MUGG: 2018-01-31 02:39:36 pm
MUGG: 2018-01-31 02:33:03 pm
MUGG: 2018-01-31 02:14:10 pm
MUGG: 2018-01-31 02:12:03 pm
MUGG: 2018-01-31 02:01:02 pm
MUGG: 2018-01-31 01:58:17 pm
MUGG: 2018-01-31 01:55:28 pm
MUGG: 2018-01-31 01:52:32 pm
MUGG: 2018-01-31 01:52:22 pm
MUGG: 2018-01-31 01:48:51 pm
TASer
So looks like it's possible to buffer mouse clicks on loading screens which can do this:



EDIT: My testings
- I stood in front of a white barrel and a test of speed, respectively, in Ravenshore and did the same thing. The game then said I'm facing an empty barrel (it didn't give any bonus or anything).
- I stood in front of a blue reagent and did the trick and it gave me a plate armor Huh?
This is looking to become a trick that lets you get the hearts right after entering a plane. It doesn't work with interiors/doors yet, but maybe it can allow you to enter Escaton's room early, too. I will test more.


Also I finished a fullgame in about 2 hours (it was extremely casual, it should be possible to do it in 40-50 minutes).
Rules:
- No glitches (alliance skip, renegade spells, door skip)
- Savescumming is allowed
- Invisibility is allowed
- Getting Cauri early is allowed
- Getting Hearts earlier is allowed as long as you don't trigger the conflux key cutscene earlier than intended

Please feel free to revise and make changes to these rules.
Edit history:
MUGG: 2018-02-01 11:40:46 am
MUGG: 2018-02-01 11:23:08 am
MUGG: 2018-02-01 11:22:07 am
TASer


This run goes to the Ravenshore library, throws a book (it can be any other item). This occupies item slot #1 (in my theory).
If you click buffer this item while in the Air, Earth and Fire dungeons, you can collect the heart without going through those dungeons.
The trick only works when loading a save going from exterior/interior --> interior, so you cannot collect the water heart earlier.

You also cannot collect the keys from Escaton earlier. The keys occupy slot 8, and doing the trick with an 8th active item on the map doesn't do anything. It only collects the key once it is active, at which point you have it anyway. Same is probably true for the conflux key, too.
Sounds like your proposed glitchless category might have a slightly convoluted definition? If we look at it from an SDA point of view:

-saving and loading is always allowed provided it's not supposed to use in-game timing
-is the list of glitches comprehensive? Are those three things you mentioned very clearly of a different, "major", nature than other things you could do (that you currently know of)?

gammadragon has been around so I'm sure he can comment on those better than I can. I see you're actually an old-timer yourself... Anyway looks like you've got the mindset for testing games well. I'm sure you can find tons of stuff in a complex RPG like this.
Edit history:
Snabel: 2018-02-01 02:20:57 pm
Snabel: 2018-02-01 02:19:40 pm
Snabel: 2018-02-01 02:19:15 pm
Hey Mugg, my question is why i cannot do the bug, i will describe what i do:

I take a book from my inventory (still not sure if it has to be a book or if i can pick up any item)
I go into the house on ravenshore and throw the book infront of me (its not as much up in my face as on your video, but it covers a good portion of the middle of the screen)
While the book is in the air, infront of me, i save the game
I then reload the game from autosave and throw the book away
Now i go to the air plane and when i enter the building with the elemental stone i save the game
I then reload the save with the book infront of me, when it has loaded i hit escape and load the save from the air plane
While the loading screen is active i click the middle of my screen once with the mouse (where the book is located on my other save)
The save loads and nothing happens

what do i do wrong?
Edit history:
MUGG: 2018-02-01 02:47:02 pm
MUGG: 2018-02-01 02:46:47 pm
MUGG: 2018-02-01 02:38:52 pm
TASer
Quote:
I take a book from my inventory (still not sure if it has to be a book or if i can pick up any item)

It can be any item, as long as it's the first one that has appeared in the library.

The way you describe it, it should work.
Have you tried doing the procedure multiple times?

And are you on vanilla or on greyface patch?
I'm using the GOG version.

---

edit: Lol I encountered another bug while the game was running in the background and I wrote this post.
I only recorded some of the after effects (might upload later)...
Basicly, I could move around while still on the "do you want to exit this dungeon?" screen, which caused the game to glitch in some ways...

Currently trying to recreate the bug...
Will it only be the first item that appears in the library if i already have it out? (by that i mean, that i dont have to go into the inventory to get it)
That question is just out of curiousity cause i did bring it out before i entered the library (just as you did in the video)

I did try loading the save with the book and then reloading inside the air plane multiple times, none of them worked

And yes i do have the greyface patch installed (GOG version aswell), I dont see how this can have an effect though SINCE i can buffer the spellbook and the menu in the loading screens.
Maybe my computer is too fast for this to work?
Edit history:
MUGG: 2018-02-01 02:52:09 pm
TASer
I think if you can get the bug to work, you will understand the mechanics behind it easily.

In your run, you did door skip really fast, though I don't know how many quicksaves it requires each time... I need to use 3~6 manual saves & reloads each time. My PC is from 2011, Windows 7 64bit.

Please keep trying to see if you can get it to work.
Maybe try to make a different "book savegame".
the door skip is easy once you get the hang of it. It actually depends a lot on how you face the door, i found that walking to the edge of the door and then positioning the camera half on the door and half on the wall, works best. Also i think someone said that it works better if you open the spellbook, i can confirm that this isnt true, it works just as well without opening it. It is all about how you position and a bit of luck.

Can i also hit space (to pick up the heart) or do i have to utilize a mouseclick? and do i have to click where the book is on the save or does it even matter where i click as long as i do the save/load/load/ thing?
TASer
It doesn't work with the trigger hotkey. You need to mouse click.

It matters where you click. The click has to be where the book(or other item) was.
do i have to be quick when i load the book-save and then wanna reload the other save again? i.e. not allow the book to hit the floor
or does the bug work as long as the save is done where the book is infront of me?
if that makes sense
TASer
It doesn't matter how long you wait while in the library. You just have to land the click on the book(or other item) while loading the other savegame.

If you want I can livestream it and show it, if it helps.
Well if you want to you can livestream it, if it isnt too annoying on you. You can just send me a link and i will come.
Edit history:
MUGG: 2018-02-01 04:08:30 pm
MUGG: 2018-02-01 04:06:49 pm
TASer
http://www.twitch.tv/mugg1991

---

Here is a new bug I found (as described in my edited post):


Let go of the mouse click, when clicking on the Close button + press Trigger key at the same time. It's really precise but when done right, the bug happens.

I will do research on it. And maybe the trick itself can be done with other buttons and stuff. If you do it with the "Ok" button when leaving the dungeon, the game crashes sometimes.
Edit history:
Snabel: 2018-02-01 04:29:49 pm
Snabel: 2018-02-01 04:29:31 pm
lol you are on fire with all of these bugs haha

I tried to reinstall the game, but for some reason i am still able to quicksave with the vanilla version, can you confirm if this is possible in this version aswell? i thought it was greyface only
Also I still cant get the bug to work with the heartstones :/