Roll Eyes
Lips Sealed
page  <- 123456789101112 <- 1 ... 12
List results:
Search options:
Use \ before commas in usernames
Edit history:
TheMG2: 2017-01-14 07:18:39 pm
oh wait what? interesting, I've tried to get an angle to let me do that before but never succeeded, good to know it's possible
Here you go. Sorry for the lack of audio, and the strange artifacting, my capture card is acting up.

It's not 100% consistent, sometimes it doesn't take me through the very last wall, and I'm stuck at the area right before it. Either way saves a bunch of time.
I think it might save a good amount of time for TAS but I currently setup a teleport launch in this area so idk?

Either way, I'll look into a more consistent setup.
A gotcha, haven't actually watched the TAS in a while, I should really do that again.

Another bonus of this skip (though not for TAS), is that if you do it perfectly you don't agro the green bird at the end, which makes it easier to do the last fling.
So I've done some playing around with the fling, and it's not that precise. You just need to line up the placement of the launcher with the part of the wall where the two walls meet. And then more importantly you must be slightly to the left of the crook in the wall when you release. I've found the second half of this is what really screws it up. And depending on your health at the time it can be a pretty terrible run ender as you are brought into a corner trapped between the explosive beatles. But with a bit of practice it should be pretty consistent.
Thanks for the info. Still want to look into it myself tomorrow.

I plan on redoing the TAS sometime this summer, I already saved a bunch of frames in the beach and in Onu-Koro like a year ago but decided to take a long break from the game because I didn't feel like doing the first dark section. I might take some more time/entertainment tradeoffs in this TAS: I'd collect the staff before the second dark section and do the glitched ending. Not sure what else.
Yeah I gotcha.

Sounds cool, I can't imagine TASing the caves in the dark would be much fun. I succesfully made it through once without bonking to turn on the lights, but it took forever.
Edit history:
TheMG2: 2017-01-15 10:36:56 am
TheMG2: 2017-01-15 10:33:45 am
TheMG2: 2017-01-15 10:15:40 am
How I usually TAS the dark caves is I edit my inventory temporarily to have staff when I figure out the inputs, and use the same inputs except without the lights. It's not the best method in the world but it works (though it could potentially affect lag stuff which is a concern).

I messed around with the skip, as long as the launcher sphere position is good you should easily get it regardless of where you stand. Starting holding l or r from further right seems to save time over moving more left. Additionally, you want to hold up before activating the launcher drag (but don't accidentally touch the drill before the drag). Doing so saves like a quarter of a second due to the higher initial Y-speed.

If you want, you can also tap a after shooting out the launcher sphere to be able to long jump to the drill, but that passage way is kinda twisty and narrow so it might not be that good of an idea.

I'll make my own video of the skip in a few, if only for good quality.

EDIT: Holding up+left on all systems or doing a up and left rotation walk on GameBoy Player and then pressing the launcher button (while still holding a direction) lets you round the corner a little faster.

EDIT2: More optimized skip with higher quality and actual audio:

EDIT 3: Something I forgot to mention, somebody started to learn this game on gameboy player, and confirmed that you can rotation walk and curve jump by using both control stick and dpad. However he found the game was too difficult to control and gave up. Somebody else also plans on learning the game on gameboy player I'll see if they actually stick with it once they start learning.
Did he comment on how easy it is to curve jump? Because that would save some serious time RTA. Right now I can do them semi consistently, but I leave them out of my runs because it's just to much variance.
Edit history:
TheMG2: 2017-01-15 11:04:42 am
Curve jumping is free on gameboy player and he said as such as soon as he understood how it worked. Just tap one direction on d-pad while holding a different direction on the control stick. When you let go of the dpad direction press jump. Easy as that.
OH! I was thinking you were rolling your finger on the control stick or something. That makes way more sense.
Rotation walking works about the same way: hold one direction on the control stick and mash a different direction on the dpad, and you should be moving faster diagonally than you could with simple long jumps.
Edit history:
Vibex: 2017-01-15 11:36:38 am
Vibex: 2017-01-15 11:15:03 am
Not that it really matters since I'm the only one running it right now, but we might want to keep gamecube player and gameboy as separate categories. Just cause of how much of a difference having two movement controls will have.

EDIT: Though I guess the same can be said for some international versions of games. I don't know, I guess we should make that decision once there are other runners.

EDIT: One other thing I forgot to mention when doing the text fling, is if you use the drill while in the middle of the fling, your location and the digging sprite seem to become disconnected. Doesn't really seem to do anything, but I figured I would mention it since it seems weird that the digging sprite wouldn't be set to the player location.
I think the digging animation stuff might have to do with your expected next position based on your speed, rather than your actual position. The game won't put the player into a wall based on your speed (it can put the player past the wall though), but the digging animation may not play by that same rule. It's been a while since I messed with that though.
That makes sense.

I was also playing around with the drill text fling and was able to get outside of the map. Couldn't do anything out there, but it might lead to something interesting. Having trouble recreating it, and sadly wasn't recording at the time.
I've gotten outside the map with, text slides, the lavaboard glitch, plant teleports, and using a teleported tree to just walk through the boundary. As far as I know there's nothing interesting out there.
Thats not all that surprising, but still kinda sad. Oh well. Guess I'll keep glitch hunting somewhere else.
I'm going to be learning about assembly this semester, hopefully it could help me understand this game better. There are a couple of glitches that I'd really like a better grip on. Namely the launch storage glitch and the detached launcher projectile glitch.
Good luck with that. I tried to learn a bit about assembly, but it was just to far out of my league. Would love to see those glitches get used in the run. The launcher storage is particularly interesting.
Indeed, but don't underestimate what the detached launcher projectile glitch is actually doing: it's swapping between sprites due to a sprite getting erased. This could have some powerful implications about the game that could result in stuff like arbitrary code execution.
Yeah the main reason I'm more interested in launcher storage is that I could actually play around with and help discover new things. If were going into arbitrary code execution, I'll just be staring blankly while you do awesome shit.
I know this thread's long dead but I figured this should be documented somewhere more public than the Bionicle speedrunning discord.

Tapping the shoulder buttons while holding select allows you to cycle between all 13 items, including ones you haven't picked up yet. This doesn't work in menus or the inventory screen, but does work in a variety of states, including
• during the opening cutscene
• during minigames
• while a text box is displayed
• whether the HUD is visible or not

In the video, I press then press+hold select. In a run, it might be faster to press start to bring up the menu, hold select, then press start again.

Of course none of this answers the question of why this works in the first place. My best guess is it's a function meant for testing that they just... didn't remove from the final game??