Roll Eyes
Lips Sealed
page  <- 123456789101112 -> <- 1 .. 10 .. 12 ->
List results:
Search options:
Use \ before commas in usernames
Edit history:
TheMG2: 2015-10-29 01:05:14 pm
TheMG2: 2015-10-29 12:27:32 pm
TheMG2: 2015-10-29 12:23:10 pm
TheMG2: 2015-10-29 12:11:58 pm
TheMG2: 2015-10-29 12:07:34 pm
TheMG2: 2015-10-29 12:02:05 pm
TheMG2: 2015-10-29 11:55:20 am
I think position is pretty important for this. I messed around with slight alterations to the movie, and it seems that where I move affected when to pop out. In particular, vertical position seems important. Horizontal position doesn't seem to really matter.

EDIT: even more footage:

this confirms to me that the other scorpion isn't a factor. Will mess around a lot with this one.

EDIT 2: From testing, horizontal position might matter? This is strange.

EDIT 3: I'm even more positive now that what is happening is a double hit of sorts. The scorpion will only fly in whatever direction he is facing when you hit him. However, if you get the quick kill, he flies up.

EDIT 4: Turns out a bunch of the movies I thought didn't save actually did and I wasn't waiting long enough before trying to play them again or looking in the wrong place.

EDIT 5: My current theory is that the scorpion still has a facing direction of sorts when attacking a boulder. When you get the quick kill, you are hitting it when it's direction is shifting to face you.
EDIT 6: Some more videos I have of it:

EDIT 7: I'm almost positive that what it is is that you hit the scorpion on both the top and bottom or left and right sides of it. You want to pop out of the ground right as you are passing over the imaginary line that divides the sections. Keep in mind that momentum is a thing.
Edit history:
TheMG2: 2015-10-29 11:01:21 pm
TheMG2: 2015-10-29 02:33:26 pm
Went looking into memory addresses, found something to do with your walking state such as direction and whether or not you're walking. I also found camera position, a bunch of sprite layer stuff, but best of all, I found the memory addresses that determine the teleport glitch. If you want me to send any of them to you, just tell me.

EDIT: Found a bunch of other ones, including a bunch of the inventory and some things that might? relate to position. Going to take a break for now, but will continue on this.
Edit history:
TheMG2: 2015-10-31 02:28:37 pm
TheMG2: 2015-10-30 11:12:22 pm
TheMG2: 2015-10-30 10:37:48 pm
TheMG2: 2015-10-30 10:19:39 pm

So this guarantees your position will be correct to get the quick kill, the problem is that you need to popout the frame after your y-coordinate is 605. So it's still frame perfect.

Also I'm not sure if this saves time over doing it normally.

I'll look into faster setups.

EDIT: I'm having trouble finding better setups, what I did was basically get myself kinda lodged into corners so I could have guaranteed positions, controlling both the scorpion's position and my own. Unfortunately, your options are a little limited on what corners you can use.

Actually I just had an idea.


It's important to pull from a distance like I did.

EDIT 3: If you want to go for it without a slower setup that requires corners, the best way to do it would probably be to go for it like this:

I believe approaching it from the side like this gives you the best visual cue: when you're stopped, you should be at the same y-level as the right claw. Then you need to popout when passing underneath the claw. This is pretty precise and you're not guaranteed to be at the right y-coordinate at all. But it would probably waste less time if you fail the frame perfect or any other aspect compared to the other setups.
Edit history:
TheMG2: 2015-11-01 05:10:03 pm
TheMG2: 2015-11-01 03:47:04 pm
TheMG2: 2015-11-01 03:45:18 pm
TheMG2: 2015-10-31 06:17:31 pm
Massive post on position and teleporting:

When I was messing around with memory, I was having trouble finding a singular "character position" address. It seemed different addresses controlled different things, and they were not necessarily dependent on each other. You could seemingly alter your position when individual addresses were frozen. In addition, if you poke certain ones, they might readjust after you move again.

I'm starting to think there is not necessarily a master position address. Instead, the game looks at various pieces of and adjusts other pieces as necessary. For example your position as it relates to placing your sprite might be one thing, your position as it relates to the camera and screen positions could be something else, and your position as it relates to collision be yet another thing. I think your hitbox and other things are also pieces. They do interact with each other, but it isn't so simple as controlling one lets you control the rest. Even if you change one address manually, the others can revert that depending on what actions you take.

I believe this not only holds to your character, this holds to enemies and objects as well.

When you attach the launcher projectile to an object or enemy you can drag, two addresses are set to zero. When you start to drag it, these addresses are set to the position of what you are dragging. I believe this basically controls where the enemy you are dragging is. If you let go of the launcher button or if the object is blocked by a wall or something, the addresses are set to zero and everything is normal. However, if the object hits you, the values of the addresses are NOT set back to zero. I'm guessing that this cancels the drag in a way that the developers didn't think of.

When you do the teleport glitch, it simulates what happens when you drag an enemy into you and thus modifies their position... Or so I thought. Now I realize that it changes only specific components of position and which components depends on the enemy or object and how you're running into them. Sometimes their collision gets teleported with their sprite. Other times it doesn't. Sometimes how you interact with the object is moved with it. Other times it's just the sprite that has moved. A pretty key characteristic of teleporting anything is the sprite changing location. I believe how the other components of position interact with this component is how things behave when teleported. Why does it vary? I don't know. I just know that it does.

It seems that when an enemy starts to move after teleporting, some of their addresses get corrected and it gets sent back to where it came from. I think the boulders don't because you interacting with their hitbox controls their collision.

In summary, there are multiple components of position, and how these components interact determine teleport behavior.

EDIT: Also I kinda didn't really distinctly say this in this huge post, but the position component that controls the camera is also what determines whether you should trigger a screen transition. If a way to manipulate the camera was found, it could mean you are controlling those addresses, and trigger screen transitions.

EDIT 2: I found the addresses for speed, my theory about speed constantly increasing during the lavaboard glitch seems to be correct.

EDIT 3: I also found addresses that seem to relate with position that change while performing the lavaboard glitch. You should be able to wrap around screens but it would take a LONG time.

EDIT 4: Your speed when using the lavaboard appears to be 0 unless you're using the launcher. I guess it's a different address.
Edit history:
TheMG2: 2015-11-02 02:18:52 pm
TheMG2: 2015-11-01 11:50:43 pm
TheMG2: 2015-11-01 11:16:14 pm
TheMG2: 2015-11-01 11:16:14 pm
TheMG2: 2015-11-01 08:18:17 pm
TheMG2: 2015-11-01 08:11:36 pm
TheMG2: 2015-11-01 07:58:35 pm
Speed values:

Not moving: 0 in both x and y

Walking right: 2 in x
Walking left: -2 in x
Walking down: 1.333333 in y
Walking up: -1.333333 in y
Walking down right: 0.7559289 in y, 1.309307 in x

same for other diagonals, just change negative signs

When switching from a diagonal to a nondiagonal direction, there is a two frame period where your speed is nothing. That's why you sometimes short hop for no reason.

Horizontal short hop: 1.8 in x
Vertical short hop: 1.2 in y
diagonal short hop: 0.6803361 in y, 1.178377 in x

For short hops in non-diagonal directions, there is a frame where your speed will be 0 after you land if you are holding a direction. For diagonals, that is two frames unless you are holding a diagonal, in which case it is one frame.

Long jumps:
horizontal: 2.2 in x
vertical: 1.46667 in y
diagonal: 0.8315219 in y, 1.440238 in x

Same thing with the frames after you land as the short hops.

If you change directions on the dpad without hitting a diagonal, the direction before will slowly decrease to 0 as opposed to immediately. However, if you ever stop moving it will immediately reach 0. This is how curve jumps work as well. Note that if you hold a, it will slowly decrease as well, if you hold a direction out of that, you will have a slight bit of the previous speed.

Now if you pause while moving slowly with this is NOT the case. Instead if you change directions on the dpad, the direction you hit before will REMAIN AT MAX WALKING SPEED AS LONG AS YOU ARE MOVING. Note that you don't have to change directions without hoping for a diagonal. If you hold a while walking in a direction, change the direction you're holding and let go of A, you will be moving in both directions at full walking speed. You can combine this with long jumps too, but as mentioned before, you will go to 0 for a frame, and thus the sideways momentum will be lost at the end.

EDIT: By doing this you move at 2.0 in x and 1.333333 in y as opposed to when you walk diagonally normally you only move 0.7559289 in y, 1.309307 in x

EDIT 2: also you need to be like moving at like 70 speed to move through a relatively thin wall, and the fastest I saw while using the launcher normally was about 19.

EDIT3: You have to be moving at about 31 to pass through the villager blocking the way to Le-Koro in Po-Koro, but good luck getting that fast without items.

EDIT4: I noticed whenever I edited my speed to be over a certain amount I sorta slid before stopping. I think what happens with the launcher slides is that it's the exact same glitch as the momentum lock walking. Once you go over a certain speed you get momentum, the pause locks the momentum.

EDIT5: I did some math: 1 frame after you hit the long jump inputs, you are still going at walking speed, for the next 39 frames you are moving at long jump speed. Then the 41st frame you are moving at 0.

You gain 5.8 more x distance for long jumping horizontally vs walking in that direction for the same amount of frames. You save 2.9 frames whenever you long jump horizontally as opposed to walk assuming you need to go the full distance. You travel a total of 87.8 distance per long jump.

For vertical, you gain 3.866693 more y distance vs walking. You save 2.900020475 frames per long jump. You travel 58.533346 distance over the course of 41 frames.

Diagonally you go 33.185283 in the y direction, 57.478589 in the x, an extra distance over walking diagonally of 2.1921981 in y and 3.797002 in y and save approximately 2.9 frames over normal diagonal walking. (It's slower than momentum lock walking though)

Note that decimals round DOWN to the nearest integer whenever you touch collision.
Edit history:
TheMG2: 2015-11-07 12:42:21 pm
TheMG2: 2015-11-06 07:47:51 pm
TheMG2: 2015-11-06 07:27:58 pm
TheMG2: 2015-11-06 07:25:57 pm
I realized I've been referring to things as x-speed and y-speed this whole time when they're velocities. I'm dumb.

I've decided to redo the tas due to my recent discoveries, part of my progress has been uploaded.

Something I discovered while redoing it is that if you perform an action on the very last frame before the lag frames of an area transition, you will perform that action on the first frame of the next area. For example, if I press up and b on the frame before the lag, you will perform a long jump first frame.

I call this called transition buffering, where your input gets buffered by the transition.

Now, if you are holding a button for at least one frame before that last frame, it will be counted as being held before entering the transition, and will not be performed. If you try to do the same button the first frame after the transition, it won't be performed then either because the game will have detected it as held down.

So while performing long jumps is basically frame perfect through them, if you long jump into a transition, and hold a direction before hitting the transition, if when you are transitioning, change directions and start holding b, you will perform a guaranteed curve jump. This could be a nice little optimization here and there.

EDIT: Welp I have to redo the tas again, this is faster than long jumping diagonally (tas only):

EDIT 2: Small discovery:

If you bonk off the wall before you get hit by the boulder, you avoid taking damage. Hold the direction you want to be knocked back towards when you start the long jump. I believe if you long jump in a cardinal direction, this can be any direction. However if you long jumped diagonally, it can only be another diagonal. I believe holding down is most optimal.

I dunno if this would save time or anything, but it's nice to know about.
Edit history:
TheMG2: 2015-11-12 12:03:12 am
TheMG2: 2015-11-11 08:41:08 pm
TheMG2: 2015-11-10 06:21:41 pm
I have no words:

EDIT: This glitch isn't making much sense to me, it seems to be able to modify various values and I'm not sure which ones it chooses based on what conditions. There is kind of an explanation in the video description, but a lot of the details are not right.

It is definitely able to touch transitions but sometimes only the x-coordinate gets modified, sometimes the other position addresses get modified but not the camera one that I would expect and sometimes none of them get modified but the camera still shifts. Sometimes I seem to get away with manually changing the values, sometimes I don't. I got it to grab the drill of whenua, but idk what else it could grab.

EDIT2: apparently any throwable projectile can cause discs to be grabbed good to know

EDIT3: Turns out you can long jump into boundaries?

Might be related to Ko-Koro skip
Oh man, so much to read up on. I've been watching that weird glitch on repeat. I am so fucking confused.
Edit history:
TheMG2: 2015-11-12 11:53:10 pm
TheMG2: 2015-11-12 11:36:41 pm
TheMG2: 2015-11-12 08:54:43 pm
TheMG2: 2015-11-12 05:20:59 pm
TheMG2: 2015-11-12 11:48:39 am
Basically for one frame your coordinates get set to something completely different if you do what I did. If you start using the launcher, a pair of values start changing. When you stop using it, they don't get reset, and that is what this glitch uses. You need to be inside a berry or health restore, or run up against an enemy and activate the launcher.

EDIT: It seems sadly limited because you have to set it up in matching coordinates (except sometimes your y-position stays the same? There is a bunch of things I don't understand). It and the object teleport glitch seem to stay if you start up a new file, but I feel that if you were to do the glitch on a separate file, the setup time should count against you. However, even that isn't too helpful, the glitch coordinates change every time you use the launcher to drag yourself to an object (note that dragging objects to you and doing object teleports do NOT reset this glitch).

EDIT2: I'm not really able to find a way to incorporate this into the tas at this time, I see the same being true for RTA. This limits your ability to use the launcher too greatly, and the only places I can see you feasibly reaching at this time with this glitch in any% are slower than doing it any other way. However, I could see this being very useful in 100% when you need to return the tree crystals to Ta-Koro. You could set up the coordinates to either return to Ta-Koro very quickly or return to the toa stone room.

EDIT3: TAS has now been uploaded through entering Po-Koro. Now can somebody explain this to me:

EDIT4: Realized I could cut out a pause, so yeah that upload is out of date.
Edit history:
TheMG2: 2015-11-15 08:32:16 pm
TheMG2: 2015-11-15 08:14:53 pm
TheMG2: 2015-11-15 08:14:53 pm
TheMG2: 2015-11-15 08:12:52 pm
TheMG2: 2015-11-15 12:35:21 pm
TheMG2: 2015-11-14 05:35:20 pm
TheMG2: 2015-11-14 03:21:35 pm
TAS is complete:

Final time is about 8:43 by your timing method (I think).

I plan on redoing it at some point, I spent less time on certain things than I should have, and could have planned other things better. But it's pretty good for a first TAS.

Towards the end I found out that if you press select on the last frame possible before entering an area transition, your camera coordinates will remain the same after the transition for 1 frame. However, I wasn't able to really get any good coordinates in the limited testing that I did, so I didn't really incorporate it.

The Toa Stone room had a strat that came about by complete accident. Was not expecting dragging the boulder into the geyser to work like that, but it did. Not sure how viable it is for RTA.

EDIT: A lot of the movement in the TAS will never be comparable to RTA because of how diagonals are dumb.
EDIT2: Went back and checked, it turns out that Ko-Koro Skip was actually a boundary jump all along, except it is done with a long jump. It's extremely lucky you found it at all, the positioning needs to be relatively precise to long jump into a boundary.

EDIT 3: A thing about teleporting the boulders. For whatever reason if you touch a berry while the smaller boulder is in the middle of one of the bigger boulders, the smaller boulder will get placed "on top" and you will grab it before the big boulders. Otherwise you will grab the big boulders.

EDIT4: I don't expect to be able to capitalize on this for a while, basically I tricked a crab to run into the water while the launcher projectile was attached:

I expect some sort of sprite based shenanigans or memory something to be the cause.

EDIT 5: It doesn't look like the strat in the toa stone room is exactly RTA viable. However, throwing the boulder into the geyser before pushing the boulder should be.
What did I get myself into
That TAS was insane. I should really get back to running this. And if I ever have the time to learn how to make a TAS, I'd love to help with that too.
I tried doing the toa stone room like the way you did it, and I almost kind of got it. I don't think I could ever do it consistently though.
Good to know exactly how the Ko-Koro skip works though. Kind of sad that it wasn't some undiscovered new glitch that would let us save more time though.
Edit history:
TheMG2: 2015-11-15 09:09:26 pm
The problem is that it's way too easy to get the teleport coordinates to be that of the geyser and have the big boulder to be stuck in there and have to diagonally pull it out which makes it too slow to get onto the button in time.
Edit history:
TheMG2: 2015-11-21 12:07:48 pm
Created a massive pastebin including explanations of a lot of relevant mechanics and glitches:

EDIT: So I hit pause the frame before the transition began for the escape and:

Reloading the save puts you in the escape, which is less interesting than I was hoping for.
Way more detailed then mine, thanks.
I tried to recreate this bug, but I can't duplicate the weirdness of after you paused.
The pause is when you are touching the edge of the screen to go to the next area. It's frame perfect. To get what I did after that, you just quit game.
I was able to get the frame perfect part, I think I didn't quit though. I'm dumb sometimes. It would probably save time overall if you were bad at the end section (like I used to be) but at this point (or at least the last time I actually played) I was able to do it first try most of the time.
Edit history:
TheMG2: 2015-11-26 11:07:40 am
TheMG2: 2015-11-26 09:52:14 am
Eh, it's something I only explained in my youtube description so I can't blame you there. For whatever reason that's the only option in which something interesting happens.

EDIT: Minor update on the diagonal countdown, it runs when you are facing a diagonal direction, but are not holding a diagonal direction on the dpad. This means that when you are able to change direction after a diagonal long jump will vary depending on how long you are holding the diagonal direction after starting the long jump or if you press it again after that for more than one frame. If you hold it for additional frames the value will stay 0 for longer.

If you hold the diagonal direction for 0 additional frames after starting the long jump, it will be at 0 going to 2 when you land and you must wait 1 additional frame to change direction.

If you hold it for 1 additional frame, it will be at 1 going to 0 when you land and you must wait 2 additional frames to change direction.

If you hold it for 2 additional frames, it will be at 2 going to 1 when you land and you won't need to wait any additional frames to change direction.

It repeats back at the beginning after that.

Now because you won't know how many frames you hold it down for, what this means for RTA is that the window for when you can change directions may vary by up to 2 frames.

I updated the infodump pastebin with this as well.

EDIT 2: apparently pushing/pulling a boulder from the left side results in x-velocities of 1 or -1 unit per frame, as opposed to pushing/pulling from the right or from any diagonal which results in x-speeds of 0.6546537 unit per frame.

Sure why not game.
Edit history:
TheMG2: 2015-11-27 06:55:11 pm
TheMG2: 2015-11-27 06:19:12 pm
TheMG2: 2015-11-27 05:16:33 pm
TheMG2: 2015-11-27 05:13:10 pm
TheMG2: 2015-11-27 05:11:20 pm
TheMG2: 2015-11-27 04:55:55 pm
TheMG2: 2015-11-27 04:44:19 pm
TheMG2: 2015-11-27 04:41:41 pm
TheMG2: 2015-11-27 04:34:58 pm
TheMG2: 2015-11-27 04:29:32 pm
TheMG2: 2015-11-27 04:20:24 pm
TheMG2: 2015-11-27 04:10:25 pm
TheMG2: 2015-11-27 04:01:30 pm
TheMG2: 2015-11-27 02:55:57 pm
TheMG2: 2015-11-27 02:38:16 pm
TheMG2: 2015-11-27 02:38:15 pm
TheMG2: 2015-11-27 01:22:32 pm
TheMG2: 2015-11-27 01:20:05 pm
TheMG2: 2015-11-27 11:33:02 am
A couple of new things. Two of which kinda aren't helpful, the last of which has a bunch of potential.

One: the ice pick actually works like the drill in that for whatever reason when you're holding the button you get slowed down.

Two: Fall respawn set glitch:

By pressing the launcher button while over a pit/water/lava, your respawn position gets set to the point where you hit the launcher button. In most places you must do this before you hit the water. In places where you climb up out of water because they're before the launcher such as the island and the place where you rescue whenua, you are able to press the button after you hit the water. Sadly this is pretty much outclassed by launcher interrupting.

The last glitch and the most useful one:

I've know for a while that if you press select while using the launcher,  then let go of the button and exit the inventory screen, you continue to use the launcher. What I didn't know was that if press and hold the launcher button again, you get sent flying. Your speed is locked at whatever it was when you started holding the launcher button again.

Sometimes when you let go of the button you stop (and can stand on water), other times you don't, I'm not sure why yet. If the launcher projectile has not returned to you yet, you will stop when you let go. If it has returned to you, you will not stop until you bounce off a wall or use the launcher again. I think it actually just puts you on land so you get put into a launcher slide state.

The glitch is kinda similar to that of the launcher slide. The advantage of launcher select flings is that you will pass over objects and pits that you could normally jump over. The downside is that you will bounce off of walls and objects you cannot pass over and it takes longer to exit the inventory then the start menu.

EDIT: Two applications and another glitch that is a side effect of this one.

Both of these applications are very improvable.

Ga-Koro 100% Tree Crystal 1

Ga-Koro Entrance 1:

And now for the new glitch large object drag:

If you do the launcher select thing, when the projectile is attached to a large object/enemy, you will drag them to you once you start holding the launcher button again.

For whatever reason doing this on the venus flytrap enemies crashes the game and the entire emulator, and I got this really weird error message too on mGBA. I also don't have access to a cart at the moment so I can't see what happens on console.

Error message:

This may lead to some form of arbitrary code execution.

If you have the chance to test it on console, it would be greatly appreciated. I will regain access to my cart once the weekend is over, so I can test it myself then.

EDIT2: the ga-koro grasshoppers, snow owls, scorpions, blue po-koro birds also seem to crash the emu when attempting to drag.

The green po-koro bird also crashed the game, but it only seemed to happen when it was about to come back onscreen.

The blue spiders that throw fireballs crash.

Ta-Koro Ostriches crash.

The enemies that reside in the lava crash, rock monsters crash, the enemies that bury in the ground in Ta-Koro and Ko-Koro crash.

Looks like the only enemies that don't crash are the blue spiders and the goats, as far as I can tell.

EDIT3: Teleport is relatively unrelated:

EDIT4: You can skip lowering these, but I doubt it'd be faster:

EDIT5: I collided with one of the buried enemies in Ko-Koro and crashed the emu. I really want to know what happens on console.
Word of warning about the new glitch, if you bonk off of something after the launcher projectile returns to you, but before you exit the fling, you cannot use the launcher again until you either fall into a pit or leave the area.
Edit history:
TheMG2: 2015-12-05 08:02:09 pm
TheMG2: 2015-12-05 05:29:55 pm
TheMG2: 2015-12-04 10:35:42 am
TheMG2: 2015-12-04 10:10:37 am
TheMG2: 2015-12-04 08:48:19 am
TheMG2: 2015-12-04 08:47:42 am
TheMG2: 2015-12-04 12:42:35 am
TheMG2: 2015-12-04 12:15:41 am
TheMG2: 2015-12-04 12:13:22 am
TheMG2: 2015-12-03 11:52:41 pm
Tested console, the things that crash on emu crash on console. It also appears the things that don't crash on emu don't crash on console.

EDIT: I've kinda known about this for a little while but I didn't upload it:


This should save a large amount of time. Uses the text interrupt glitch I uploaded earlier. You need to activate the disc collection with a thrown object, if you touch it while launching, you will take damage instead of entering the glitched state (name not yet decided). You NEED to be using the launcher before the fruit actually hits the disc, otherwise you won't be able to do the skip.

This is technically a 1 try trick, if you aren't in launch state before the fruit hits the launch, you're screwed. You might want to save before trying this idk.

When in the glitched state, your speed will increase to try to get your position to be equal to that of the launcher projectile. Thus you pass through the wall and skip a large part of this area.

Once you're through the wall, press the launcher button again, it will take a little while before your speed is low enough that you regain control, but this should still be really fast.

I've come up with a better setup that I'll record later.

EDIT3: Better setup:

This should get you a better y-position

EDIT 4: I think what happens is that the text box puts you on the ground so that you're able to not bonk off of walls and such. I think I'll call this the ground launch glitch.

This saves around 12 seconds over my old TAS.

EDIT5: I have mentioned before that you are able to teleport small objects/enemies. I have not looked into it really much until now. It seems that when you need to release the launcher button a second time is way stricter compared to large objects. One test was giving me a result of a 2 frame window, but I wouldn't be surprised if that was position dependent. When you want to let go of the button is after it has fired but before it has actually attached to the object. If it is attached to the object, the teleport coordinates get reset.

You cannot seem to attach a launcher projectile to any of the objects/enemies after they have teleported that I have tested so far, and to be honest, at this point in time I can't see this being useful. But I was curious nonetheless.

EDIT: Updated info dump thing with new glitches, check bottom for specific changes.
Edit history:
TheMG2: 2015-12-08 05:18:21 pm
So I've made a big discovery regarding the scorpion quick kill:

It only works every 12 frames, there is no visual cue for this, these 12 frames do not correspond with the scorpion's animation.

Position still matters, but you don't have to be moving when you're doing this. You could sit and wait under the right spot until the right frame (if there was a cue for it).

So basically the scorpion quick kill is luck for console.


There seems to be even more to it, but I'm not understanding it right now.

EDIT: So I did the launcher dupe glitch a lot of times, this is my results so far:

Is not likely to be useful anytime ever cause it's slow.
Something I haven't brought up is the transitions between screens. There are two types of transitions you can get. There is a fade to black transition and a transition where things become all pixelated. The pixelated transition is like 20 frames slower (I forget the exact amount if it's even consistent), however I don't know what causes you to get what transition and if it could be manipulated in a simple fashion. I've had situations where doing the exact same inputs in a screen gets me different transitions, depending on previous screens.

There isn't anything you could do about this, but I just wanted you to be aware that the amount of time spent on a transition depends on luck and that it's really annoying.
Potential new Ga-Koro Entrance 1 launcher fling for RTA, I came up with a similar strategy while working on a new TAS.

Big problem with this strategy is that you lose out on 3 explosive fruit unless you backtrack or something. You could probably find another place to do this from though.
Edit history:
TheMG2: 2015-12-24 07:05:03 pm
TheMG2: 2015-12-24 09:50:13 am
TheMG2: 2015-12-24 09:45:32 am
Finished a new TAS

If you have any questions about what is viable for humans, ask and I'll look into it.

EDIT: I found another way to do the launcher fling/large object drag, I'll probably need to redo the end of the tas because of this. If you have both buttons set to launcher, if you hold 1, and then start holding the other as well, you'll do the glitch.

EDIT2: Updated TAS