Roll Eyes
Lips Sealed
<- 12345 ->
List results:
Search options:
Use \ before commas in usernames
wonder if QAudioInput broke or the api changed or something.
API appears the same.

readyRead fires four times, exactly, then the audioinput goes into Idle state with an underflow error.

Aaand I'd better get some more work done. At least I'm making progress here debugging it. Smiley
oh, take a look at the buffer size. that always seems screwed up under os x ...
On a job hunt starting this week, but last night I rebuilt the dependencies, updated Qt, and today I rebuilt Kumari and tried just messing around with it.

Very odd. Some audio inputs don't work at all (bad format), most underflow, but the built-in microphone works as expected.  In fact I just recorded a video, and I'm betting if I try to stream it'll work, too.

I'll have to figure out what this means.  Possibly that the audio parameters are being figured out wrongly, and so it's underflowing because it's attempting to pull more data from the device than it should rightfully be expecting? Not sure.
did you try messing with the buffer size? i think it's on the QAudioInput object.
Heh, sorry I hadn't done that yet. The above was just a random "I don't feel like redoing my resume just yet, let's diddle around" moment.

But yeah, now that you say it, I deleted the #ifdefed buffer part.  suddenly the error's gone.  Recording is working *great* now.

Now to run down this stream crash I'm still getting...
wonder why they can't get that stable. always seemed to me like the QtMultimedia stuff is not quite up to the standards of the other qt classes. apparently it's no different in qt 5. depressing. then again, i've tried to use apple's apis directly, and they are bad bad bad bad bad. so maybe i should actually be rejoicing that it's possible to uncomment a single line and suddenly be dancing in the street.
Edit history:
presjpolk: 2013-09-11 08:21:45 am
Maybe Qt4 was bad and needed the buffer fix, but Qt5 fixed that and no longer needs it. We can hope. Smiley

EDIT: Streaming's fixed. Sometimes it's the simple things, like needing to add --enable-libmp3lame to the ffmpeg build FailFish

Now to add the other feature I want: scaling.  Then I need to figure out some of the GUI glitches going on,w here I have to resize the window to get some of the buttons to work and stuff like that.  Then, at that point, I'll probably start using my build.
mac users:
a new version of kumari that should be more efficient (less cpu used on unnecessary colorspace conversions) and has the mod 2 width bug fixed (so you can't accidentally get bad videos from setting the width wrong now). i also updated the source with the same stuff presjpolk figured out back in august and september and some other bugs fixed that came from the transition to qt 5, mainly not being able to interact with widgets on the top row of the ui.
Oh you fixed that?  I just kept having to resize the window before those would respond. That was in my queue to fix. I look forward to testing this. Smiley
Edit history:
nate: 2013-10-21 08:36:06 pm
nate: 2013-10-21 08:35:48 pm
yeah, it has to do with hiding a QPushButton after it's added to the layout. i couldn't find much googling so i just changed to a different paradigm for adjusting the ui according to the boolean logic. QStackedLayout caused the exact same problem so i couldn't use it. i realize i should probably be reporting these bugs but i've been extremely busy lately.
updated the link in the first post with a new version of kumari that shouldn't crash under 10.9.
Edit history:
presjpolk: 2013-10-22 06:28:17 pm
I assume that's this which I just got:

Dyld Error Message:
  Library not loaded: /Users/*/QtOpenGL.framework/Versions/5/QtOpenGL
  Referenced from: /Applications/
  Reason: image not found
try now.
That did it, thanks.
torch slug since 2006
curious, why did yua and kumari need this fix, but not norichan?
norichan's version of qt is from before they made the change that caused the crash in 10.9.
Edit history:
DJS: 2013-11-01 04:12:42 pm
torch slug since 2006
is there a possibility that kumari cant pick up certain microphones/audio inputs? my microphone is called "Microsoft LifeChat LX-3000". when i have it selected, and start streaming/recording, the audio level thing doesnt appear, but the stream still starts, without audio.
yeah, it's possible. i didn't write the code that does that and i have no idea how it works.
I encountered an issue a while back.  I tried to stream a video player (VLC) and Kumari went nuts (stream turned into a slideshow).  It handles Norichan and emulators fine but would always freak out with VLC.
wonder if it's a gpu thing. you might try disabling or changing the hardware accelerated display settings in vlc if possible.
Tougher Than Leather
hey i was wondering if this application is crashing on anyone else here, my setup is capturing my capture device preview window, which doesn't look all that bad and has little to no lag, but everytime I try and stream it crashes one me, literally every time, im running on maverick as well, any advice?
can you post a crash dump? i don't even know how to do that in 10.9 though. in 10.8 you could just copy and paste the text in the crash window.