Roll Eyes
Lips Sealed
<- 1234 ->
List results:
Search options:
Use \ before commas in usernames
Edit history:
MauvaisVitrier: 2019-10-27 01:56:43 am
MauvaisVitrier: 2019-06-09 02:46:15 pm
It is faster to use this yeah. 1:40 mn faster to be more precise.
The run I want to submit features the new glitch and the time save, as well as so small optimizations.
I've explored the quick save/load trick in a lot of places but couldn't get the same result, or a something worth exploiting.
I'm going to try and explore further what you just suggested and see if I can find something in that vein somewhere else.

I know the game quite well at this point and if the glitch works as I think it does, there is no other place where it could be useful.
Being teleported outside the map is only useful if there is something out of bounds to get to.

Devlin Mine was the only place left where I hadn't found a way to go out of bounds.
But I'll check just to make sure.

Remember that I'm alone and a rookie in terms of speedrunning experience. I don't have tools at my disposal to make things easier, it just me trying random (not totally random) shit.

EDIT: answering some of your suggestions

- I've the two different presses in Devlin Mine and I get teleported to the exact same location everytime
- I've tried moving around and jumping. this doesn't change anything
- I've tried sending the press back down and save/loading, it only teleports me when my hitbox is squished.
- The environment around these two presses is particular. There is a low ceiling. The other press in Devlin Mine is where the crystal is, but once you activate the press, the game doesn't allow you to jump anymore, probably to avoid players jumping during the cutscene part of the sequence.
- The teleported location is on a different Z-height yes. As you can see in the video however, there is quite a severe screen shake after the first save/load. I have to do it one more time to get unstuck and move on with the run.
- Haven't tried lag or pause buffering

Here are all your questions answered except for the lag, settings change, pause buffering.
I don't know what you mean by tools (RAM watching?) in this case. Most testing is done without advanced tools for games that can't be emulated. Exactly the way you're going about it.

Anyway I don't really have other advice.
Edit history:
MauvaisVitrier: 2019-06-11 02:26:03 pm
MauvaisVitrier: 2019-06-11 02:02:36 pm
MauvaisVitrier: 2019-06-11 12:51:41 pm
MauvaisVitrier: 2019-06-11 01:05:42 am
MauvaisVitrier: 2019-06-11 01:05:18 am
MauvaisVitrier: 2019-06-11 12:50:13 am
Yeah I meant tools to be able to check speeds, player positions (coordinates), get console access, cheats, etc ...
I know some games have big enough communities that some knowledgeable people develop autosplitters, a bunch of cheats and commands to explore the full potential of the game.

I did explore the game with my own means, I did check everything you told me to check.
I even checked that same find on Ether One Redux and it doesn't work (as expected, since we already knew collision was handled in a very different way between UE3 and UE4).

To be honest, I think I'm ready to submit a run for Ether One.
Ether One Redux might need some more tries to see if I can improve that run, but yeah.. Ether One (2014) might be done.

Thanks for all the help you've provided me.

Edit: I just thought of time saves that can only be useful if you exclude load times. Time to implement that into the run.
Edit #2: well this fucks up the timing for a dialogue skip later in the run. This doesn't seem to be worth it right now.
Edit history:
MauvaisVitrier: 2019-06-15 04:25:50 pm
MauvaisVitrier: 2019-06-15 04:24:01 pm
Found a new glitch that sadly won't probably be useful.
It saves 40 seconds, but messes up the triggering of other events later in the level, so you eventually lose time compared to the current Any% route.

Here is the glitch:

If you try quick saving at the very end of the initial load, then quick load, you'll eventually manage to skip the intro cutscene.
I'm not sure how this works exactly but I know what it does. It allows you to save the game in this portion of the game (not normally possible), and it messes up with the Rembrandt sequence at the end of the level. I don't know why that is, but here is the glitch anyway.

Since using this glitch allows you to save in this section of the game, I took the opportunity to try the quick save/load (QSL) collision glitch and see what came of it.
You get teleported out of the map but you end up into the void, there is nothing you can do there, you just fall down and get respawned in the starting elevator.

One more thing as well, I've managed to improve my Any% run again, cutting a minute and 15 something seconds off my previous record.
I managed to find other spots to execute the QSL collision glitch and implemented that in my latest run.

It's pretty much flawless in terms of execution, except some very minor inconveniencies.
RTA is 14:14 (down from 15:32) and w/o loads it's 13:59.

Unless I find a way to make the above Institute QSL glitch work, the 13:59 run will be the one I'll submit to SDA: It's a run I'm proud of.
This category has come a long way from where it was 2 months ago (after being frozen for 5 years)

EDIT #2: I still feel like I'm talking to myself here, I wished there were more people running this game.
Edit history:
LotBlind: 2019-06-16 10:55:39 am
I wasn't lying about saving and loading. Wink

One thing you can try doing is starting a run, then starting a new game in-between, then resuming the run in case that should restore things to normality. The entire thing (minus loading times) is timed though.

We will actually host two categories of runs: with resets (save/loading) and without. This is standard fare. That's separate from actual segmented speedruns, though it sounds like you can do all the tricks in single-segment?

You're doing the right thing posting these updates here. It's just a fact in speedrunning "small" games that if you want it done, you often just have to do it yourself. But that's why we have this site: so at least the finished run will be seen by more casual viewers as well, even ones who don't know anything about the game.
You really weren't lying about saving and loading yeah. I've found a bunch of stuff using while exploring their potential. Not everything is useful of course, but your advice has allowed me to find new tricks/glitches and breathed new life to this game.
I appreciate the help.

I'll check your suggestion. I've tried quitting to the main menu and reloading and quitting the game and reloading: nothing changed. I haven't tried loading a different file or creating a new one, so I will do so.

Well, I don't like double posting, but then again, if you don't double post or triple post when you've made brand new meaningful finds and just edit the last post, then the thread just keeps sinking further and further down.
Even though you don't run the game, you've helped tremendously and I feel like I can explore more technical aspects of Ether One and speedrunning in general.
Maybe, just maybe, some people will find the game interesting. Or maybe, just having everything posted here is a great resource for new runners in the future (still have to consider adding stuff to the Knowledge bank, I know).
A random idea: is there another (optional) trigger in the facility that restores the plot? Or what if you just save the game once and reload once (or not at all) while in the intro? Does that mess the Rembrandt thing up as well or would it enable using s/l'ing to skip a part of it?

I just tried this intro trick... I just saved it once and immediately reloaded and the intro was cut. Of course the intro isn't timed on SDA anyway since you haven't gained control yet. If you want you can still skip it this way. Afterwards, I didn't get the long waiting time in the chamber after just save/loading. It's a bit difficult to tell if that saved any time otherwise since it desyncs the audio and video so much.

A common trick is to bind some key you'd want to spam on the mouse wheel. In most cases it's either "use" or "jump", or both. This way you can consistently use things at the maximum distance, pick them up faster and whatnot. Looks like you can do this in this game as well. Hope you have a free-scrolling mouse... but we won't reject the run if you didn't use one.

Another way to abuse this could be saving. What happens if you chain-save? Are there other places where you can only save it on one frame? Best try this with every available command, and at different times. In fact I used this method to skip the intro faster, in case it's really that precise.

Watching your latest run here...

You should note that strafing left and right while moving forwards is not the best way to avoid obstacles. It causes you to move at a 45-degree angle (in most games), which usually isn't exactly what you need. Instead, it might be good to get into a habit of moving the mouse left and right by the amount called for in each case.

Why do you ring the bell? Just picking up the card causes Phyllis to start talking. Ah, are all her lines a bottleneck before you can do anything in the restoration chamber?

Also do you know how much time it saves if you run into doorways perfectly (i.e. running start like you do with the first door). Can you jump through these doors as they're opening? Since you can save anywhere, it's not like you can't just stop there and practice the timing even if it seems difficult at first. After a few attempts, I think I at least managed to get a consistent running entry through them (maybe jumping is even better?)

2:28 - I'm not saying you're doing it slowly, but the fastest way to place the fuse would be to start somewhere further to the left, so that the angle for using the fusebox becomes accessible as early as possible. Of course you can also line the cursor up using the door texture or something so you're already pointing at the fuse as well. Looks like you can use objects from a surprisingly long way away.

2:47 - Looks like you already have a pretty substantial save/load trick here. Neat! Always fun to look at stuff from an angle you normally can't.

5:45 - The same trick doesn't work with this cutscene? Also what happens if you hit 'T'?

8:10 - What's this save/load for?

Why do you have to visit the church again?

I can't believe you don't have to do anything in the final memory...


Double posting: doesn't matter.
There is only one spot that advances the plot/triggers an event in the Institute and that's the red button you press in the Restoration Chamber.
There is indeed a dialogue bottleneck happening in the Institute. Even if you go to the Restoration Chamber as fast as possible you still have to wait for dialogues to finish so that they give you access to the fuse box.
There are two ways to trigger the first piece of dialogue: clicking on the bell or picking up the keycard. They both take the same time.
Keycard: dialogue triggers immediately but it takes additional time to open the drawer and pick up the card (14.456 seconds)
Bell: dialogue triggers with a delay but it is closer to the player (14.316 seconds)

Okay, I'm dumb. I just realized that I had been timing my run with the intro cutscene included.
I've been looking for a way to skip this intro because I used to include it. But if the starting point is when I take control of my character then there is no use trying to find a way to skip that part, especially if this breaks the rest of the level.

I have jump binded to mwheelup and down but it's not that important to have jump on there in this game. I just have it binded that way because of bhopping habits.

Regarding your comments on the run itself:
I shall take your advice about not strafing.
I usually get a head start on the first elevator door since that's the only one where that matters. The others don't because you have to wait for dialogue to catch up to you in the Restoration chamber.
2:28 - It's tricky to find the perfect spot since you have to take into account the fusebox door opening one way, making the fuse itself unavailable for “longer” than if you stand more or less in.

2:47 – that's the first trick I found after you suggested messing up with saves and loads

5:45 – the same QSL trick doesn't work here no, I've tested it. If you hit “T” you get teleported back to The Case and can't do much more.

8:10 – I quick save and load to reset Phyllis' dialogue. If I save and load before she ends her dialogue, she starts it again. It's a timing thing tied to the next trick about the church.
I implemented the TP in and out of Village in my ribbon route because of faster in game time. When you do that, you interrupt Phyllis' dialogue.

9:05 – I go inside the church to interrupt Phyllis by triggering (look out for the pinwheel loading icon at the bottom right) the Church dialogue (made up of 3 lines, 1 by Jean, 2 by Phyllis). That's “Church Skip”.
Now there is a way to skip 2 of Phyllis' church lines if you click on the music box when Phyllis says the word “Trust”. It's a timing thing.
If you click on the music box at this exact moment, you'll get “church skip” and as the door to the memory core finishes to open, the church dialogue will be interrupted and Phyllis final warning before she opens the door for you.
Now, when you asked me why I quick saved/loaded at 8:10. It's because I need to execute “Trust skip”, so I need Phyllis' dialogue to end at a certain point, an optimal point. So since going for ingame time strats interrupts my carefully planned timing, I need to reload Phyllis' dialogue to get the timing I need

There I hope this was clear enough. I know some of the dialogue manipulation can be quite obscure but it's necessary. I've tried several combinations and that one remains the fastest.

I'll be looking into what you've suggested once more and get back to you if I find anything more.
If I don't, I'll be submitting this run to SDA.

EDIT: I recalculated my time by removing the intro cutscene, starting when I get control of my character and ending when I lose control of it (w/o loads): 13:19.533
2:28 - Right. Just saying that since you're not doing anything else while waiting, you might as well set up the perfect angle to make the runs look cleaner. And save a tenth or two.

So aren't you thinking of binding "use" on mwheeldown or something? To use stuff from the greatest distance?

"going for ingame time strats": To be clear, if you reset (save/load), we don't usually use the IGT since the time can have advanced a little bit in-between but the reloading reverts it.

Assume that the audience will be happy to hear the answers to the same obscure stuff as I have (run comments).
1. Fair enough, I'll look for the best way to open the fusebox.

2. Regarding mwheel binds, what I meant is that I'll set it up to be "use" instead of "jump" because I don't need to spam jump anywhere in this game.

3. Okay sure. What I meant by "ingame time strats" is one instance during the ribbon route, where it's faster to TP out and in Village (because of default spawn location) than to just walk up the several flights of stairs ONLY IF you remove the load times. Check out what happens at 7:25. I leave Village, go back to Village and get spawned up the flights of stairs that are slow to climb. Is that a legit strat ? The loading times are going to be removed right ? Because if they are not, then doing that is slower.
This saves around 4 seconds compared to climbing up the stairs (RTA is similar in both cases)

4. Fair enough !
3. It's somewhat unusual but definitely has to be seen as a legit (and clever) way to abuse saving and loading.

Hmm... since you can't do much to speed up the first part, if I was you, I'd take the opportunity to go dick about a bit before entering the chamber. Cheesy It's a shame you can't throw stuff. Is there nothing cool you can do? A bit of parkour somewhere? Haha...

If you want more advice for the future, grinding out a lot of runs during the testing phase (which tends to be or should be the longest one) is something of a waste of time IMO. You'll practise the necessary skills as you do testing anyway. That way you won't be frustrated before it's finally time to start recording the real thing. You'll never know what's actually going to be relevant after all.

Also, on SDA at least, whatever your exact run time happens to be (the number itself) isn't something most people would find terribly interesting though we of course try to be very precise in timing. It doesn't implicitly mean much. It could be a good run, it could be a bad run.
Mmm, there isn't much you can do in the Institute while waiting no.. There would be something, but that's the QSL glitch, and to be able to save in this section I'd have to skip the intro cutscene that glitches the Rembrandt sequence.
I know of the "entertainement" side of SDA runs, as long as they don't slow the run down. I'll try to think of something.

That's good to know. Even though I'm still always looking for faster times. I never expected to find that many things when I came back to the game. So I run the game as if every run was a WR.
I do a lot of testing though, without necessarily running the game.

I feel like I explored whatever there was to explore in terms of tricks and sequence breaks.
Found a new small 10-second time save at the end of the Village ribbon route.
I used to have the Church Skip followed closely by the Trust Skip. With these you'd cut down dialogue bottleneck quite a bit, but there was still 13 seconds of downtime waiting for dialogue to be over.
Behold the Warning skip (timestamped)

Activating the music box then running to the primary school will trigger a dialogue that cuts off Phyllis warning you that there is no coming back if we enter the Memory Core.
The opening of said Memory Core is tied to that Warning dialogue. So if you manage to interrupt it, the door instantly opens.

Small steps.
How is this coming along?
I don't have time to speedrun games anymore sadly. Not much I can do on that front.
I could post some of the glitches and stuff I've found here, not necessarily related to any%.
I've given everything I've found to the only other runner of this game and they're using it to do what I can not do anymore.
I'm looking at the latest run you posted... the chamber itself goes very smoothly now (it looks really pro! Smiley I can see a few of the mistakes (three times you get caught)... I think that unless that other runner wants to do better than you AND submit on SDA (most people don't know about the site or why they should submit I guess), this could be the best we'll see in a good while then. You could consider submitting and while it's not the cleanest, at least the second time (hopping over the fence) I know isn't entirely easy to do.

Yes, it's good if the resources at least are in the same place even if it's not a full-fledged wiki.
Edit history:
MauvaisVitrier: 2019-10-26 05:58:19 am
MauvaisVitrier: 2019-10-26 05:45:09 am
MauvaisVitrier: 2019-10-26 03:57:46 am
I don't know man. I might come back to running it next summer, or earlier if I find the time and energy to grind again.
I'm not entirely satisfied with submitting the current one.

EDIT: got a new WR, much more entertaining, much more optimized and with a single small 1s "mistake". Uploading to youtube right now. I think I'll submit this one and call it a day.

EDIT: there it is. I've also submitted it via the submit form

Regarding tricks and glitches, here are a few videos:

100% category out of bounds (100% ending)

Return to Devlin out of bounds

Memory Core clip to warp back to the entrance

Industrial center Plaque skip

Industrial center swag (timestamped)
Wow, I'm really impressed! I just didn't want to see another project interrupted half-way through. For me speedruns really only exist when they're up on SDA, which is perhaps not the majority opinion. Wink

I think I'll only watch it in verification seeing as it doesn't sound like you'll need feedback right now.
Edit history:
MauvaisVitrier: 2019-10-27 09:28:08 am
MauvaisVitrier: 2019-10-27 08:52:37 am
MauvaisVitrier: 2019-10-27 08:52:15 am
MauvaisVitrier: 2019-10-26 01:40:38 pm
MauvaisVitrier: 2019-10-26 01:34:07 pm
MauvaisVitrier: 2019-10-26 01:28:58 pm
MauvaisVitrier: 2019-10-26 01:28:44 pm
I've invested a ton of time into this speedrun. It was a way for me to cope with things. I've achieved what I wanted to achieve IRL hence why I don't have any more time lately.
I'm surprised I managed to get that final run without much practice. Like I said, there is a minor 1 second time loss when a door just won't open for some reason; other than that it's pretty good.
During the Devlin QSL skip there are some bits of out of bounds geometry that slow me down a tiny bit, but it's the lottery every time you go through there.

I don't see how I can improve it without grinding it down, and I don't have that kind of time anymore.
The Any% run is done, I think.

I don't know what categories you allow on SDA but there are some cool things to showcase on All Ribbons, 100% and Any% Redux. In a way, it's sad because the Any% run almost skips the entire game, so you don't get to see much of the awesome tricks that exist.

Anyway. I've submitted my run. I should write a commentary I guess, to explain what is going on. I am unable to record an audio one however. I hope this is not a problem.

EDIT: yeah, don't watch it on youtube. Wait for the submission, I've showcased some extra glitches for the hell of it (that don't cost time) in this run. You should be able to appreciate them I reckon

EDIT #2:
Quote from LotBlind:
Wow, I'm really impressed! I just didn't want to see another project interrupted half-way through. For me speedruns really only exist when they're up on SDA, which is perhaps not the majority opinion. Wink

Well, on other platforms runs submitted are works in progress. Having a dynamic leaderboard has its advantages.
Once you're on SDA your run is pretty much set in stone for decades, so you better record a perfect run (which never happens)
I can understand both sides of the argument.

EDIT #3:
I've found a Review Build of the game. I've started exploring that version and I've found two time saves, one which is quite significant.
What's SDA's take on review builds ? (its name is review build, but I'm pretty sure it's version 1.0.0)
Should I cancel my submission and try running on the review build instead ? Or are we considering that off limits ?

EDIT #4:
Video proof for the two new tricks (the second one is at the very end)
Lots of things to discuss...

Yes, you get better at things during times of no practice as well. That's some brain thing.

Categories: I don't know if we can justify All Ribbons since that just sounds like halfway to the 100%, without there being e.g. a different ending. So there's the any% and 100% both in SS and segmented, also you could possibly define a glitchless category (the current any% is probably going to be labeled "with major-skip glitches") but of course that just reverts it into being a walking simulation so I doubt anyone wants to do that. Also depends on if a clean-enough kind of definition can be arrived at. I don't immediately see other categories.

Audio commentary was never compulsory.

I don't know why you think SDA runs are "set in stone for decades". It depends on the frequency of the submissions and if the amount of volunteering is proportional to the number of submissions, we can keep up with much greater numbers of runs. That having been said, I don't think most viewers will watch a "random" run more than once per year or several years even, so in that sense...

Review build: hmm... how is it being distributed? Does it say v. 1.0.0 somewhere?
I haven't been able to find information on builds/patches.

I know the original game was patched a few times, but there is no information anywhere. I've looked on GOG, Steam, White Paper Games sources.
The review build is the version of the game given to journalists.

I have found a pirated version of the game.
However, I was writing for a games website back in 2014 and even interviewed the devs. They had given me a review build. But since I had loved the game so much, I had bought the deluxe version and deleted the review build.

I do understand that other runners might have issues finding that version and running it, so it might not be allowed for me to submit a run on such a build.
It exists though
If there's no official outlet, it seems sketchy. Review builds are often exclusive and aren't supposed to be in distribution outside of that purpose, which makes them seem more like the final beta instead of a 1.0 build. I think the version numbering isn't really the most important, I know other games that weren't widely distributed in 1.0 at all.
I can't find a way to get my hands on previous version of the original 2014 Ether One, even though I played them.
There's no way to roll updates back but I'm almost sure the review build is what players got on day 1.

Would you know of a place where I could find previous versions of games ?
Isn't GOG able to do that ?

EDIT: I have the game on the humble store and it should be the proper version. However, when I launch the game, its starts the redux version of Ether One. Don't know why. Because there are two separate downloads on my humble page for both Classic and Redux
Edit history:
LotBlind: 2019-10-27 12:33:51 pm
Well if you can show that it really is a build that came out and wasn't just for reviewers (tbh an indie game is likely to have shipped the same version compared to AAA), then it's obviously usable. I don't know where you can get old versions of games but the rights to distribute those are the same as the rights to distribute any version of the game. I think some games have specifically the problem of older builds becoming difficult to find and the runners essentially just sharing torrent copies. We don't really care how you get your hands on a copy, just whether it's really a release version and it's available to all runners.

I don't really have any further knowledge that could help you.
Edit history:
MauvaisVitrier: 2019-10-27 01:07:07 pm
MauvaisVitrier: 2019-10-27 01:06:44 pm
I understand what you mean. The only way I could confirm that the review build and first shipping build are the same would be to directly ask the devs, who I am "friends" with ever since.
That wouldn't solve the "availability" issue, but that would confirm that the review build is legit.

Okay, so I did some digging and the game went from v1.0.0 (launch) straight to v.1.0.3 about two weeks later.

What I'm abusing in the review build has been fixed in 1.0.3