Roll Eyes
Lips Sealed
<- 1234 ->
List results:
Search options:
Use \ before commas in usernames
- softlock: I'm just confirming this with the other admins now.

- A/V quality test: see this subforum and the first post for instructions on the quality test. Thanks for taking the time to read all that documentation BTW. Could you just ask nate in the quality test whether he's okay with using "low" settings? He's better-suited for this than me.

- glitch: I really recommend that you put in more hours into just studying the game, take a good look at all the different items and binds and try all kinds of crazy things everywhere. Especially around places of interest. Sorry if this sounds condescending but this isn't the first time I've stumbled onto a previously-unknown glitch or skip after no more than a couple of hours of playing some game. All I did was I tried to climb the collapsed walkway that leads to the floor level where the crystal and crusher were. Just spammed jumping. In all likelihood, you'll find out how this works pretty easily.

Also remember to check for any save/load tricks like in some games the game lags a bit after reloading before starting to properly check for collisions. The more games you've run, the more tricks in your bag I guess. I'd love to stay and help with this game but I've already committed to trying to actually finish a speedrun for once. Still, I'll play the game through normally and report anything unusual.
Thanks for the info.

I haven't put the hours into the redux version of the game at all; I picked it up a few days ago.
However, I have spent a lot of time in the normal version of Ether One.
I do lack some experience and knowledge of automatisms and regular tricks/exploits that can be found across different games.

Thanks for the advice, I'll try to replicate your glitch. It's out of the way of the current any% route, but if you can replicate the same kind of glitch somewhere else, it could be useful. Especially during the last section of the game.
Yes, it's possible that it's a Redux-only trick, however, again, in all likelihood, it was already present in the first version. The other option is they somehow changed the game's input/physics for the Redux version, which can happen of course, but it's just kind of unlikely (did it need patching?). That's why I half-assumed you should find the same trick in the first version, and I hope you will.

I can confirm that we see no problem with the softlock since it happens after timing has ended! Feel free to use it.
Edit history:
MauvaisVitrier: 2019-04-26 02:47:02 am
MauvaisVitrier: 2019-04-25 02:32:54 pm
MauvaisVitrier: 2019-04-25 02:12:31 pm
MauvaisVitrier: 2019-04-25 02:08:20 pm
MauvaisVitrier: 2019-04-25 01:28:44 pm
MauvaisVitrier: 2019-04-25 01:24:02 pm
If I remember well, the normal version was done with UE3 and then they re-made the game from the ground up in UE4 so as to port the game to PS4 as well.
there, I found the source:

softlock: okay great, good to finally be sure.

EDIT: I highly recommend the game by the way, casually, it has a wonderful story and great voice over narration.

EDIT #2: Would it be possible for you to record the glitch please ? or screenshot the exact location where you did it. What are your settings ?
I've tried several things, messing with capped framerate/settings. I bound jump to two keys, spammed them, tried different angles. I was not able to get a double jump or infinite jump. This is very odd.

ps: you are not allowed to jump after having crushed the crystal in the normal version.
Okay, I've installed the original version and will try to reproduce it today. I think I'll first do it again in the Redux though, and post a video.
Thank you LotBlind! I appreciate it!
Here is a bonus:

I explored quick load/save opportunities and found a 1:15 time save.
I noticed that the bug carried over from one save file to the next, so if we can figure out which file it stored it to, I could at least just send it over for now.

Here, has both my two savefiles, but also the config files in case those are corrupt somehow.

Took a brief look at the config files: most of them are empty and the "game" one doesn't seem to have anything of interest. The inputs one shows that I've bound both SPACE and 'L' to jump, but note that I had not bound 'L' when the glitch occurred so that would be a red herring. I don't know if I had some other bind for jumping, other than the keypad button it mentions (I haven't got one plugged in) but I'm sure it would have been the default one.

So next thing I did was backup and delete the two saves, start a new game (without leaving the game), and see if the glitch persisted. It did. After that I exited the game, deleted the new save, restarted it and... the glitch stays. It seems it's really stored outside of the save files.

So next I nuked the config files, started a new game without going to the options screen at all. It's still happening. I'm sure it wasn't doing this when I first started playing because jumping mid-air would have been something I would have tried everywhere, simply because there's little of anything to mess with otherwise. So for now the assumption is the glitch is stored in game files other than the saves AND config. There's nothing else in the "saved stuff" folder at all.

I'll give you this is something new.

To make it even weirder is based on a few minutes of messing around OOB in the starting area, I've found that the glitch CAN stop suddenly, when interacting with floors in certain places (like once when I went to that chamber that you're not supposed to be able to get inside). You just fall helplessly. BUT that doesn't mean it's gone if you reload. Will have to see what happens if you let the game save after the glitch is gone. Would that similarly affect all future save files, not that you'd have any reason to want it to end for speedrunning?

I never asked where you bought your copy. Mine is GOG, and should be the latest patch. There are often some differences between GOG and Steam, though based on the forum posts, both sites should have version 1.04.

Looking for suspicious files here: everything that's in the GOG Games -> Ether One Redux top folder looks to be used by GOG Galaxy AFAICS. Also there's NOTHING in the whole folder that's been modified since I installed the game.

I also can't immediately see any mentions of any bugs related to jumping in the Ether One Redux forums on GOG, nor Steam. Nor videos on YouTube, or even mentions anywhere elsewhere about a "jump bug" or "jump glitch". The last patch seems to be from Nov 2016. I checked all the patch notes I could find on Steam but they don't mention anything jump-related either.

So I tried to reproduce it in Ether One. I couldn't do it either. So clearly my logic of "why would it suddenly appear" doesn't apply in this case since it was such a big overhaul. Looks like they added more invisible walls everywhere as well.

Using the "verify/repair files" feature didn't remove the glitch either, so I'm now re-installing Redux. If it's still there, I'm stumped. Did you already try doing what I described in Redux as well?


Okay, so reinstalled Redux. The bug is still there. Of course some part of the installation could have been left over. At this point I don't know if I'm doing anything else for this. What would the next step even be? Manually delete more files I guess. If you want me to test something in particular, feel free to tell me, but I think I'll just play the game through now.
Edit history:
MauvaisVitrier: 2019-04-27 02:24:44 am
MauvaisVitrier: 2019-04-27 02:03:39 am
MauvaisVitrier: 2019-04-27 01:38:19 am
MauvaisVitrier: 2019-04-27 01:31:11 am
Okay, so, that's a lot of information to process.

I've downloaded your save files, but since you seem to have glitched your game without managing to get rid of it. I've downloaded a DRM-free version of both Ether One and EO Redux.
To answer your question, I have got the games through humble bundle but I used the steam keys. So if they are different "games" (I'm assuming that if steam and humble are different, GOG and humble should be similar) I can test the glitch on both: DRM vs DRM-free and orginal vs redux.

I've looked into bugs and glitches on youtube and forums as well. That is how I found the current Any% Redux Out of Bounds in Devlin Mine. But I have not found anything related to a jumping glitch, that's why I'm so surprised.
The very nature of your glitch and how it remains in the game through save files and after your reinstalled it is super odd. I've kept trying to mess with what told me to do, but I really couldn't even get the impression that it could work.

That's why I'm asking for you to record, so I can replicate what you did exactly and see where the problem lies. That's also why I'm downloading the DRM-free version because you're right, there could be differences between the steam and DRM-free version.

I'll keep you posted ! Thanks for the help by the way.

EDIT: LOL, I did the infinite jump glitch on the DRM-FREE version of the game. I forgot to try it as soon as I went ingame, but I did check at the end the Institute level. All I did inbetween was to mess around with Quick Loads.
So it appears that it is the DRM-Free version that is completely bugged. Oh my, this is going to be fun !

EDIT: So, I tried getting to the end and the game kept crashing at the same place, preventing me from accessing the final sequence of the game. Strange, this version of the game might be completely bugged. It is strange that people wouldn't complain about it on GOG forums though. I hope you can finish your playthrough becasue if our DRM-Free versions of the game are the same, then it's over for you Cheesy

EDIT: Okay so I downloaded the original and redux versions of the game on my humble store account.
There is no need to install the redux version, you can just launch the game and it works (the version with infinite jumping)

I then tried to install the original version from the .exe humble gave me. It installed the game (ver 1.0) just fine, but when I launched it, the game was actually the Ether One Redux version with my save files from Ether One Redux (on steam). I closed the game, went onto steam and launched my Steam Redux version. When I tried launching the exact same save file, the game instantly crashed.
That is mad.
Okay. Do you need my input anymore? I'm also hoping I can finish the game.
Well I don't think I do anymore. Unless you manage to finish the game. Because if you can, that means the DRM-Free version of the game might be run-able.
If you can't, then the infinite jump isn't useful at all. Thanks for the help though, I appreciated it
Do you think you could file a report on GOG or somewhere to give them all the info about the differences you're seeing? I just filed one where I showed them one house in Pinwheel Harbour that crashes every time (I don't think I'll even try to finish on this version :P)
Edit history:
MauvaisVitrier: 2019-04-28 07:38:55 am
MauvaisVitrier: 2019-04-28 07:38:48 am
I can DM the devs on twitter to let them know. Don't know if reporting on GOG or Humble Store would change anything
I noticed that the audio in the 17-minute run above was really quiet. Maybe you've already adjusted it? I watched it because I wanted to see if you use this trick already... you must have noticed you can easily clip through the elevator in the Mill Management in the Industrial Complex, and fall right down to where the mine entrance is, right? Maybe you use this somehow in the 100%.

BTW: feel free to use the Knowledge Base to document the tricks, in case you were to find its wiki format more suitable. The advantages include that anyone can come and edit it instead of belonging to one user. It is possible to embed (small) files like demonstration videos as well.
Yeah I know. My audio setup isn't the most optimal lately, and the audio level in my earbuds is quite high even though the game's volume is low. I realised only too late that we could barely hear dialogues in my videos.
I've discovered even more stuff since I last posted here. Pretty everything I found is in my different runs (plus some extra stuff that is not useful to runs yet, or will likely never be).

Regarding the knowledge base: I'll think about it, it has come across my mind that a kind of wiki would be a better way to share tricks and such. I've used ggdocs posted on forum threads thus far and it's not at all practical.

You can find all WRs on my youtube channel (the Brimclif mine elevator skip is pretty cool in "All Ribbons")
But here is Redux Any% that if not for the 4 seconds fuck up on out of bounds collision, would be almost perfect:

I'll start watching the runs properly only in verification or if you think you need feedback before then. I really don't watch speedruns outside these contexts these days. Gotta keep working on my own run... I've right about finished the game though.
Looks like if you reload a save when you've just entered the last core memory (4) you will instantly fall off the floor. That's not very good QA testing... Assuming you must have noticed.
It's okay, I've posted the runs here for posterity if someone someday comes around here and looks for information.
I didn't know about the reload/save in the last core memory, I only tried that trick in areas where it could be useful. In Any% we go in and out of the last core memory and that's enough to trigger the last sequence.

EDIT: Hope you enjoyed the game. I've moved on to The Occupation, the Ether One devs' next game. It's a super cool game as well, although I've not yet assessed if it's a good speedgame. You can do crazy shit in it, but there are massive limitations (mainly unskippable cutscenes and a whole lot of waiting inbetween short nice game breaking bursts of speedrunning)
Are you not going to actually submit your best runs? That last redux run you posted you said was almost perfect. It might pass verification then.
I might submit one in the future. Right now there's not a single worthy run. I don't wanna submit some half-assed run so I'm looking elsewhere and will come back to it eventually.
I'm glad you're thinking of it. We're happy for all such runs.
I came back to Ether One Redux and found some new strats:

Institute keycard skip. First out of bounds is inconsistent, so this can get pretty reset-heavy.
The second out of bounds has to be credited to TheSkeletonMan (/
I've also added a TP strat that I had used in the All Ribbons category but had forgot to implement in Any%

This new world record could still be improved.
I didn't manage to get the "stupid jump" that could save 3 or 4 seconds
I messed up inputs in the world map in the Case, to TP to Harbour.
Anyway. Here it is.

Okay @LotBlind (don't know if @ someone works here), I have a few questions regarding the game and run submissions.

There are two versions of the game:
- Ether One, Unreal Engine 3, PC, 2014
- Ether One "Redux", Unreal Engine 4, PC/PS4, 2015

I have a question regarding which name to use for each game.
On SRC we tend to name them EOC (Ether One Classic) and EOR (Ether One Redux), so for the sake of consistency I'd suggest using the same naming convention here as well.
If you have any objections, what would you suggest ?
Ether One & Ether One Redux ?
Ether One UE3 & Ether One UE4 ?

I don't remember finding this information out in all the documentation I've read but, do you exclude load times in the way the run is timed ? That could help me suggest a time for my submission.

This might seem like a stupid but as far as uploading is concerned, which files hosting platform would you suggest ?


In other news I have found a massive new skip in the one level that had no major time saves before that.
I'd like to have your opinion on what it looks like to you. Is it a glitch, wrong warp, etc ... ?
I'm going to explain what is going on first before you watch the video

Messing around with the quick save/quick load features on top of one of the presses in Devlin Mine, the game loaded me outside the map.
My guess regarding how it works is that there is a collision conflict when standing on top of the press. Your hitbox might be squished too much for the game. So when you save and reload, the game checks if there is room for your character hitbox to be spawned in where you last saved. The game is confused because you've squished your hitbox where it's not supposed to be, so the game resolves that conflict by teleporting you to outside the map.
The point where you get teleported is the same every time, which leads me to think it's the standard, original 0.0.0 coordinates within this given map.

Sadly @ doesn't work, but I keep an eye out for spam posts anyway so I won't miss it.

The name: I think we'll just go with "Ether One" and "Ether One Redux" as that would be the games'/versions official names. There's other games with the base thing and a later e.g. "HD" or "Director's Cut" version which we treat similarly. Feel free to use those abbreviations in your run comments or elsewhere.

Loading times are indeed left out of PC runs for fair competition. Our timer will do a thorough check but mention any unclear cases in the "submission comments".

File hosting: the uploading is done via torrents (you get the links after submitting). Do you mean which torrent software to use? I haven't ever had to do that yet myself, but I'm sure any which one will do.

Teleportation: If it takes you somewhere far away from the press, then this being some kind of default location would be my first guess as well. This could indeed be some kind of default behaviour if the game's normal ejection routines got absolutely desperate (I don't think I've ever seen something like that btw). Of course I guess typically the origin would be where the map was built around but... it doesn't have to be. As for nomenclature, I guess I'd call it a glitch (these terms aren't really scientific), but in case you suddenly found more places where this can be done, and there was some common factor, you could use that as the basis of naming it. In the end, if you don't know better, just choose a name that's unambiguous and as descriptive as possible in the context of the game in question.

A wrong warp sounds to me like you were supposed to be warped somewhere, but got warped to the wrong location. That happens esp. in NES etc. primitive games.

I'd like to take a quick look myself but I can't afford to. If I were you, I'd look into stuff like this:
- is it EXACTLY the same location or is there any variance
- what if you were trying to move around or jump before you saved?
- what if you tried to induce lag as you were reloading? In some games going to the menu (maybe changing some settings), or taking screenshots could cause the behaviour to change slightly.
- is the location on a different Z-height or otherwise aligned with the press?
- what if the press is not in its highest position yet when you save-load? What if you send it back down first?
- what's different about the architecture or objects around that one press compared to all the other presses? I suppose there might not be a lot of other cases where a part of an object squeezes you against another surface, or are there?
Okay, I'm gonna do the thing. I'm going to submit a run then, encode is ready.

I didn't know the uploading was done via torrent. I had seen mentions of file sharing website but it might have just been for quality tests.

I'll time my run with load times removed and give advice in my submission notes for some of the more confusing parts.

As far as the newest trick is concerned, there are some things I can test myself, but other stuff I'm pretty sure I don't have the proper tools for.
I'll test stuff some more.
Doesn't this new finding make it any faster? I'm guessing not if it doesn't change your route. You're saying you'll submit now, but shouldn't you first check this new trick out in more detail?