Roll Eyes
Lips Sealed
12 ->
List results:
Search options:
Use \ before commas in usernames
Edit history:
honorableJay: 2014-04-14 10:43:36 pm
honorableJay: 2014-03-18 09:35:47 pm
The Dork Knight himself.
There seems to be a huge abundance of people making threads to solve the same issue over and over again, so hopefully this can be a one stop for the most common fixes. Eventually I'll document all known and future fixes to the KB.

As most of us have seen, the Dazzle's audio component is not the easiest to get working. Some programs, like AmarecTv and Virtual Audio Cable, have shown promise in getting the audio natively from the device. When those don't work, hardware workarounds have been used. After hearing about a fix involving running Pinnacle Studio, I decided to test out a temporary fix that I've been using to see if the suggested Pinnacle software could make the fix a little more permanent and less of a pain to setup.

Things to note
This fix involves using Pinnacle software to unlock the Dazzle's audio decoder, but in order for it to work the Dazzle DVC100 Audio device must be seen by whatever capture/stream program you're running (on top of making sure the Pinnacle capture software is installed, apparently it's good for something after all). It's possible that it will work if you don't see it, but I give no guarantees. Also, this fix does not work with XSplit in my experience. Since Amarec does grab the audio for me, the only program I was able to test this in is OBS.

Technical Notes
Recently, OBS was updated with built-in deinterlacing options for video devices. On top of that, each video capture device added now has the option to choose any audio capture device. Initially I was able to choose the Dazzle Audio device but no actual audio would come through. After playing around with a few settings, I found that by tweaking the Dazzle's crossbar and tricking it to enable the "link related streams" function, the audio would work for 1 session (either preview or actual stream). Somehow the crossbar enables/disables the audio decoder in the drivers. This would explain why even though I chose the Dazzle Audio for game audio, nothing initially came through.

The Fix
One of the programs that is installed alongside Pinnacle Studio, AMCAP (Pinnacle Studio > Tools > AM Capture in the start menu) is the program we'll be using.

1. Run the program as an administrator
2. On the main menu, click on Devices and choose the Dazzle Video and Dazzle Audio (audio won't show a check next to it)
3. Rejoice!! Then minimize AMCAP to the taskbar (leave it running)

In the future, just run AMCAP before your program of choice (OBS, etc) and leave it running in the taskbar. One of the interesting quirks of doing things this way is you'll have access to the video crossbar through AMCAP and can make on the fly changes to the video input (s-video or composite) and you can also change advanced video settings (region, color settings, etc) without causing any interruptions to a stream (aside from maybe a quick flash).

Confirmed to work
OBS - initially there's a little static in the audio, but that usually clears up after about 10 seconds

Confirmed to not work
XSplit - until there's a way to force a specific audio device with the Dazzle video, you'll need to rely on programs like Amarec or a y-adapter

Other known fixes
Crossbar Thing (dxtr)

What I need is for other Dazzle users to test this with their own setups to see what programs it does and does not work with, which will be added to the lists. Also, any other solutions to get around the audio issues will be added as others detail the steps (since I don't have to use them, I haven't explored them fully). If any admins have fixes they know of, feel free to edit this post and add them in. Finally, if any admins are good with formatting, for the love of god please edit this post and make things nicer to look at (I can't format to save my life).
Thread title:  
Edit history:
bangerra: 2013-09-29 04:32:40 am
bangerra: 2013-09-29 04:31:12 am
I'm glad someone picked up on my fix Wink because it's the easiest one I've seen around.
AMCAP also works indeed, and not only for sound but also for something else interesting:
Tweeking with its settings a bit you can get PAL60 to work in full colour!
- Run OBS / Amarec (these are the only ones I tested, others may work)
- Run AMCAP (or AM Capture)
- Select device Dazzle DVC100
- Press Options > Video Capture Filter
- Now the important part:  Put the videostandard to NTSC_433  (This will give you a clean B/W image *)
- Then put it to SECAM_B. This will magically keep the 60hz and display the correct colours without noise!

* note: If you don't get image at all with NTSC_433, try changing your capture resoltion to either 720x480, 720x576 or 640x480 in OBS/Amarec.
Once you figure it out, just write it down somewhere so you don't forget  Wink
Love you Jay <3
The results are in
Was Pinnacle Studio supposed to be on the disc you got in the box with the Dazzle? I just got the Instant DVD Recorder
The Dork Knight himself.
What software is on the disc you got? If it came with AM Capture then you should be set. I didn't go for the Instant DVD Recorder software, BUT if it did come with some sort of capture program you could try to substitute that for AM Capture and it might work just the same.
The results are in
The software on the disc is the Pinnacle Instant DVD Recorder, and I couldn't find AMCAP on there.
The Dork Knight himself.
Any chance you could try this fix with the instant dvd recorder software? Just load it up, set it up for the Dazzle, then leave it running in the background (just don't start any captures with it). It's possible that any piece of Pinnacle software could unlock the audio.
The results are in
I'm trying my best, but I haven't made it work yet. I've tried VAC, and I downloaded Pinnacle studio and tried with AMCAP as well but nothing's worked so far.
The Dork Knight himself.
What program are you having a problem getting the audio with specifically?
The results are in
AmaRecTV. Here's what I've been doing.
VAC. Didn't change anything here.

This is as it should be.

Not quite sure about this, but I think this is how it should be.

I haven't tried every single audio option here, and I'm not sure if this is right

Selected both dazzles.

I'm not exactly sure what I should choose here, this just made the most sense to me.

My Graph 3. Not sure if the problem is over here

It's probably just some small thing and me being a retard. Got any ideas?
The Dork Knight himself.
Well since Amarec can actually see the Dazzle's audio component get VAC out of the equation and see if you get sound. On Graph 3 (Live), uncheck the Mixer since it's not needed (in fact it'll stack the audio when streaming). For your capture resolution, if you're running a PAL console you'd stick with 720x576 @ 25fps, but if you're running a NTSC console you'd have to choose 720x480 @ 29.97fps. On the Windows Recording window, do not choose to listen to the recording device since that will (again) stack the audio and can interfere with capturing.

Keep AMCAP closed while testing this to confirm whether or not you get any audio.
The results are in
Ok I made it work now. Thank you so much for your help <3
How come I don't have the "Line 1" audio option? I just have Dazzle DVC100 Audio. I can also only select one format for it, weird..
The Dork Knight himself.
First, the Dazzle audio only has one format that it supports for audio recording, so you'll only have one option. Second, he has the Line 1 option because he was using Virtual Audio Cable to grab the Dazzle audio. VAC supports many different audio formats for capture.
Apologies if I'm posting this in the wrong place.  I'm trying to set my capture card up so I can record runs through Amarec, but it doesn't seem to recognize the Dazzle DVC100 Audio.  It doesn't appear at all in the Audio Capture Device box and neither OBS nor AMCAP recognize it either.  The Device Manager certainly knows it's there, but I'm not seeing it recognized anywhere else.

I've tried disconnecting the device, uninstalling the drivers, then reinstalling and reconnecting everything, but that didn't work.  I've also gone through as many threads as I could find, but I'm not sure that any of them directly address the problem I'm having or offer any solutions when they do.

Anyone have any ideas or had this problem before and know what to do to fix it?  My operating system is Windows 7 32-bit.
The Dork Knight himself.
This is the one problem that has stumped a lot of us for a while. The only thing you can do is uninstall the software, go into device manager and uninstall the device (make sure to check 'delete the driver'), and try again in a completely different port. I'm assuming you've already done this, so it's most likely some problem with Pinnacle's software (which doesn't surprise anybody).

The only thing you can do at this point is get an adapter and hook the audio from your console to the line-in port on your sound card and use that to record. You *could* try to contact Pinnacle support but I doubt you'd get a response worth reading. Btw, did you ever load up the Pinnacle software to see if the audio works? That would definitely nail down the drivers/software as the issue.
Thanks for the response!

First thing I'll do when I have the chance is to check the Pinnacle software.  I haven't really done a thorough check with it yet.  The funny thing is, though, that at some point I'm pretty sure that Dazzle DVC100 Audio did in fact appear under the options and I have no clue why it stopped doing so.

As for hooking the audio from my console to the line-in on the sound card, that's what I currently do as part of my streaming set-up.  My question now, then, is would using line-in for the console audio be acceptable for recording runs for submission?
Line-in is fine for submission, I honestly doubt there's any noticable compression going on when you go from stereo cables to a 3.5mm jack
The Dork Knight himself.
Yes it will be, in fact a lot of runners use the line-in from the soundcard to record audio for the same issue you're running into (gotta luv software that just "works" as advertised).
Ah, great!  That makes things a lot easier!  Thanks for the help everyone!
Sounds like Maverick talk to me.
I havent had this problemuntil today but now my Dazzle DVC100 is not showing up on my computer. It keeps saying check to see if its disconnected etc.

It is connected to my computer.

I have restarted multiple times and its not showing up on Xsplit nor AmarecTV.

What other methods shall I attempt?
The Dork Knight himself.
Sounds like either a driver problem or a device problem. Regardless of what the underlying problem is, you'll have to delete the driver manually from the Device Manager to confirm.

To start, unplug the Dazzle from the USB port, then go into your device manager (right click My Computer > Manage) to delete the driver. Find every entry that lists Dazzle (you should have 2, but there could be more), right click on the entry, and choose Uninstall. On the popup asking you to confirm, make sure you click the checkbox that reads "Delete driver."

Reinstall the driver, then plug in the Dazzle. If it shows up in the Device Manager properly, then the problem was simply software. If it does not, plug it into a different USB hub. Nearly every USB hub consists of 2 ports side by side. A problem with that particular hub will affect both ports, so using a different hub will avoid this issue. On the back of your tower (if it's a standard desktop computer) any 2 USB ports that are paired right next to each other are part of the same hub.

If going to a different hub doesn't work, or you're working with a laptop, try every USB port available. If it does not show up no matter what USB port you use, the most likely cause is the device crapped out. The only way to confirm this is to use it on a different computer and see what happens. If the Dazzle works fine on a different computer, then the cause is a Windows issue which can only be fixed by reinstalling the OS, which is a last ditch effort.

Check this neat tool. Works wonders!!
The Dork Knight himself.
Thx dxtr, added to the other fixes. Btw, did you get to try the original method? If so, did it work?
You mentioned before any of this can work, the Dazzle DVC100 Audio Device must be seen by a capture program.  I am unable to see it in OBS, AmaRec or AM Capture.  I can, however, get sound fine when using Pinnacle Studio itself.  The Crossbar Thing also doesn't seem to solve my issue.

Am I missing something?