Roll Eyes
Lips Sealed
1 page
List results:
Search options:
Use \ before commas in usernames
Edit history:
recon: 2013-01-01 05:43:35 am
Hi there

I have made a speedrun that I want to submit to this site. I've read up on anri-chan and the likes, and seem to have gotten the hang of how to encode the files. That said, there's one rather annoying obstacle in my way. All my video files are recorded at 60 fps - except for one file that is 65 fps (don't ask me why - I don't know why I did this). As you guys know, the anri-chan program only accepts multiple video files in a project if they have same framerate and resolution. What I need to do, then, is to convert my 65 fps video file into 60 fps.  I have not managed to do this and make Anri-chan like it so far.

I've already tried something minor, as I have described in another thread:
Quote from recon:
This turns out to be pretty hard. I searched on Google and on this forum, and came across a command called ChangeFPS() for avisynth. I tried using a script with ChangeFPS(60), and it seemed to work, as in, I could make a new file containing the first segment, but with 60 fps.  Anri-chan wouldn't accept this file for some reason, and it kept giving me the same error that the files don't match in framerate or resolution or something like that. Maybe I should point out that the original 65 fps segment file is 642 MB, while the new 60 fps file is a whopping 2,8 GB.

Any suggestions?

edit: added "now with quality test" in title. Links and description can be found a few posts down in this thread. (look for the mediafire links)
Thread title:  
Fucking Weeaboo
Well, if you open the file in VirtualDub, there's an option under the Video menu to change the frame rate. Set it to match the other videos in your set and reencode. It may ruin your video/audio desync, so look it over before throwing away the original.
Edit history:
ballofsnow: 2012-12-31 08:13:47 am
Try a script like this:


See if that loads correctly in virtualdub. If not, let us know what the error message says.

edit- I'm a little rusty, might have to be b.changefps(a.framerate)
Sir VG: I have tried to use the framerate setting in VirtualDub, both the "change framerate to (fps):" setting and the "Convert to fps:" setting, and made the new avi file in both cases. The new avi files are indeed 60 fps, but still, when I try to use each of them with one of my other 60 fps fraps files, I get the error in anri-chan where the videos don't match in format/framerate/whatever.

ballofsnow: The unedited script did open in VirtualDub, and from that I saved the new avi file, which indeed turned out to be 60 fps. Still, I can't get anri-chan to use this new 60 fps file together with my other 60 fps files. :/ I find this weird. Both the framerates and the resolutions match. Could it be because the files made in VirtualDub use much higher bit rates? For example, my original 65 fps file uses 539xxx kbps bit rate, while the new 60 fps file uses 996xxx kbps. Do the VirtualDub operations change the video in any other way that could make Anri-chan complain about formats not matching?
Edit history:
ballofsnow: 2012-12-31 09:42:05 am
Does this work:

^ If needed you can do this type of test for all your videos, and eventually single out the problem file(s). This is essentially what Anri is doing on its initial test.

How many avi files are you loading? There's a chance we're looking at a different problem where Anri can't load too many avi files at the same time. The maximum depends on the system; iirc in my testing I had 117 files appended, but 118 would error out.

edit- Oh, almost forgot. If it's Fraps, the problem file(s) may need to be transcoded to e.g. Lagarith codec, then loaded in Anri. Fraps can be funky sometimes.
Edit history:
recon: 2012-12-31 12:53:32 pm
In the tests I have done, I've only used two files in the anri project. I've done tests with my original 60fps files, and Anri have no trouble with these. The converted 65 fps file (from 65 fps to 60 fps) seems to be the problem, exclusively. I think I need to modify/remake the 65 fps file so that Anri will load it together with my other 60fps files.
So, the problem is not that I'm trying to handle too many avi files.

You mention that fraps could be making trouble. I guess I will try to use that Lagarith codec you speak of, and transcode the file. (I'll see if I can figure out how to do this). Thanks for the help so far.

Awesome, the test script you showed went fine in VirtualDub when I used a regular fraps 60 fps file and then a Lagarith-transcoded file of my 65-->60fps converted file. Nice! Thanks for the help.
lagarith is already installed if you have anri installed. just open the source avi file in virtualdub, go to video -> compression, select lagarith, then save a new avi (i think it's the f7 key).

otherwise you can just make a new avisynth script:


for each of your source files. then save the file as a new lagarith avi as i describe above. this should totally solve the problem.
nate: Problem was solved by using the lagarith codec on the single file that was converted from 65 --> 60 fps. Thanks.

Also, if anyone would like to check it, I've uploaded a quality test to mediafire (I couldn't figure out how to attach files in these posts):

It's a HQ encode from anri-chan. (12.88 MB). Is everything looking all right if I were to submit this for verification? Also, is HQ overkill for verification or would MQ do?

(Here is the MQ encode:)
torch slug since 2006
hmm, around 00:17-00:20 the video gets slow, choppy and then gets faster and back to normal... dropped frames?

how to attach:
Thanks for the tip about attaching files. I must have overseen that.
I don't know what you mean by dropped frames, but I can tell you that I have not deleted any frames if that's what the sentence implies (of course, I can't prove that claim). I'm almost positive that it's computer lag I had during recording in fraps. It also happens a few other places later in the run. I hoped it was not a big problem.
torch slug since 2006
yeah dropped frames are basically when you are recording, and something "gets behind"/slow and because of that it has to drop some frames. your computer lag is probably the reason behind it.
nate or ballofsnow will have to tell you if its a big problem.
meh. those drops aren't too bad. way better to have 60 most of the time and dip occasionally than to go to 30 all the time. looks good to me.

verification files are usually hq nowadays.
All right. Thanks for the help.
I've found a place in my current run where it's even worse, though. Take a look at the uploaded clip made with Anri. There's MQ and HQ clips. It's more visible in HQ.

at this point it seems like you are needing to optimize your system for fraps capture which i know very little about. maybe try searching or else someone else can post some pointers.
Ok. I'll take it that the verdict is that I need to redo that particular segment which contains both of the shown lag clips. In case I can't find any way of reducing this recording lag, would it be acceptable to go as far as to change graphical settings to make the system run smoother? This would mean that one clip in my run would have worse graphic. I could resort to this if I don't succeed with any other methods.
(user is banned)
Edit history:
MortyreR45: 2013-01-02 12:11:15 pm
Actually, I had never capture any PC game with over 60fps with fraps. because it do not work (on my fraps of all the years had it not work !), try it on xp and win7. It will work, but wrong. Fraps has only 3 options -> 60, 50, 30, than you can use a manually way and type a number in a field, but you can not go higher than 60, a example is 25 or 29. Your segment is dead you can do what ever you want, you can not repair this file. The yellow number from Fraps is not important (my yellow number is 999fps). The red number is important ! When you have a super power PC and the game is very old, than make sure the game run normal and not on super speed, like a game boy emulator with 2000% speed.

You will lost life time for virtualdub, you must fix fraps. say him 'not more than 60' Smiley

And generally, when I read that there is a run with more than 60fps recorded with fraps, I do not watch it, because I think it is manipulation. sorry

I remember on Cold Fear, was rejected, because the fps was to high. or to slow ? verify index
The Dork Knight himself.
Mort: Jedi Outcast is built on the Quake 3 engine, so unless he plans on running the game at 250fps it will play the same with anything between 60 and 125.

recon: Can you list your current system setup? Cpu type/speed, amount of RAM, how many hard drives (along with fill capacities), video card, and if you know it your swap file settings.

Here are a few things that have always helped me with Fraps:
1) Always record to a secondary hard drive that does NOT have your OS loaded on. Windows likes to randomly get in the way of Fraps just by doing simple hard drive read/write operations which can cause a lot of chop.
2) Move your windows swap file to a secondary drive and lock the size. This is an old school trick I've used since Win98. I'm not sure how much it truly impacts today's systems, but I've always had more system stability by putting the swap file on a secondary hard drive. The reason I lock the size (currently I'm setting it to 4GB, or 4096 when setting the size in Windows) is to stop the constant hard drive thrashing as Windows resizes the file.
3) If you have at least a quad core cpu, you can try setting Fraps to use only 1 or 2 cores, and the game to use the remaining free cores. This should keep the game from interfering in the actual recording.
4) If you STILL can't stabalize the framerate, lower the resolution. This is the last thing you should have to do, although it is the only sure-fire way to get better recording fps.
oh cool qiii engine, thanks for the information.

But I talk about fraps for self. all my qiii demo videos are captured with 60fps on fraps. The problem is, fraps can not handle more than 60fps. And qiii runs so perfect on a very old PC systems I think it give no problems. I remember on my old win98 system with 3dfx voodoo2 grafic card pentium233mmmx.

For testing -> put a number more than 60 in the field in Fraps and tell me what you have.

djcj can more help than I, because I play also many console games and not only PC.

When you use the search function you will find the nightmare run for qiii in the pc board, this video was recorded with 30fps and looks not so good.

Also recon had say it his 60fps video is 2.8GB big and the 65fps video is ~600MB big, because fraps will lost many frames.
MortyreR45- I must admit I didn't understand most of what you said, but to be honest, I think you're overreacting. That I unknowingly used a crappy framerate (65) in the beginning does not imply I did it for covert purposes. In fact, as I recall it, I used a little higher framerate "just to be on the safe side", to get a maybe smoother video. It then turned out that the 65 fps video played very weirdly, why I changed the fps back to 60 in subsequent segments. And I did manage, with the help from techies on this forum, to convert the 65 fps video to 60 fps and get a good result in Anri. I uploaded the result earlier in this thread (it's the first segment), and if you can point out anything there's wrong with this, do tell me. I sure can't see anything wrong.

HonorableJay- Thanks for the tips. I did however manage to redo the particularly laggy segment with one graphic setting set lower, without any lag. I can upload the vid if wanted. I think there's hardly any graphic difference between the other segments and the newly done. So I hope it's okay. I'll refer to your tips if I have trouble recording smoothly in the future, and others will probably find it helpful, too.

If you're curious, I run on a laptop with 1366 x 768 resolution, intel dual-core 2.4 GHz, 640 GB HDD (of which I now have 61 gb available, thanks to the run's fraps files, lol). 6 GB RAM, 64bit Windows7, Intel HD Graphics 3000.
Edit history:
DJS: 2013-01-03 05:22:05 am
torch slug since 2006
it just occurs to me, did you record this game using like the ingame demo feature (assuming it has one, looks like it)? because if you still have those demo files, you could maybe send those to someone who has a "better computer" and have him record & encode them for you...

edit: looks like this game dosent have a demo feature. i thought it would since its a q3 engine game...

recon, when you have this small lag only in one segment and it is short, than I think there is no problem. But when your run is complete captured with 65fps and you will later all reencode to 60fps, than is this not ok, for me.
DJS- the game does have a demo function, but unfortunately it only works for multiplayer as far as I have understood.

MortyreR45- Ok, that's good to hear. I agree with you that 60 fps is definitely better than 65 fps.